Jump to content

ALC888 in laptop problems...


2 posts in this topic

Recommended Posts

My IdeaPad has 4.1 sound. Two main speakers on each side, two up by the screen, and a subwoofer underneath.

I've installed various ALC888 drivers and I get sound, volume button works, etc. But its very tinny; there's no bass, and it only comes from the two main speakers.

I've tried to add the other speakers through Audio MIDI Setup, but all the options for 5.1 etc except Stereo are grayed out. I'm pretty much stuck...anyone have any ideas?


Intel Core 2 Duo 2.0ghz (running with cpus=1), 3GB, 250GB

ICH8, X3100, ALC888 (I believe!), running JaS 10.5.4.

About this Mac dump here: http://paste-it.net/public/l6082f5/

Link to comment
Share on other sites

Bump. I've tried a few drivers but with every one, all the other options are grayed out.

Picture 1: Trying to select more speakers as Apple HD Audio device.



Picture 2. Trying to select outputs as an Aggregate Audio Device... which makes no sound whatsoever.



I noticed with one driver (I can't remember which!) it showed my line in and line out, but using those didn't do anything. Also one showed my mic, but it wouldn't hear anything. I'm guessing it's just confused which line is which, but I can't figure out how to change it.


Edit: Also this:


And checking in Windows confirms that it is indeed ALC888. The problem seems to be that it's not recognizing any of the audio ports...any idea what to do?

Link to comment
Share on other sites


  • Create New...