Jump to content

Need Help with New Install on an AMD Machine with SATA Drives


3 posts in this topic

Recommended Posts

Hello. Thanks in advance for any help you are able to give me.


I am trying to load leopard on my Dell Inspiron 531 for the first time with Kalyway 10.5.2 and I keep getting the dreaded "Still waiting for root device" error. I am attempting to dual boot with Vista. I have the boot screen working. I am hoping someone can give me some pointers on something I'm doing wrong. I'll start with a description of the hardware in my machine, and then I'll move on to what I did.


Dell Inspiron 531: http://en.wikipedia.org/wiki/Dell_Inspiron#Inspiron_531

Processor: AMD Athlon 64 x2 Dual Core Processor 4000+ 2.1 Ghz [sSE3]


RAM: 2GB DDR2 800


HDD: Western Digital WD3200AAKS 320GB SATA


Wireless NIC: Linksys Wireless G PCI



What I did:

1. I downloaded and burned Kalyway 10.5.2

2. I partitioned off 50g from my HDD and left it unallocated

3. I setup all the files needed to dual boot with vista as mentioned in one of the tutorials (this is working fine)

4. I booted from my Kalyway 10.5.2 DVD and attempted to install in -v mode, but a few moments into the install I received the "waiting for root device" error. This happened after it attempts to load the Nforce drivers (it looks like to me anyways).

5. I swapped around my SATA cables and turned off HD sound in Bios and tried again with the same results.

6. I tried another configuration with the SATA cables and still received the error

7. I posted this


If you know of anything that can help me fix this problem, or you need me to go into more detail about something let me know. Thank you.

Link to comment
Share on other sites

Root device means the device from which you are booting. Make sure that your DVD drive is primary master and your HDD is primary slave. Kalyway distro has a problem with IDE drives. You can also try using a external DVD drive it may work.

Link to comment
Share on other sites


  • Create New...