Jump to content

Lost PS/2 Keyboard / Mouse on laptop after 10.5.5 Update


23 posts in this topic

Recommended Posts

I tried upgrading from 10.5.4 to 10.5.5 using the combo update and it worked fine, aside from the fact that I lost use of my trackpad and keyboard on my laptop. I'm running a Dell Inspiron 1525 and I've tried a few times to get it working and I've come up with nothing. I'm on the third fresh install and I'm not touching it again until I have some info on what to do to restore the KB and Mouse. Tried just replacing the drivers with backups I made and it doesn't do anything, I have used kexthelper and done a manual disk permissions repair... Any ideas?




I didn't see the sticky saying to post in the particular OS forum... My apologies... I've been at it for a few hours and I'm tired.

Link to comment
Share on other sites

Fujitsu Siemens AMILO Pro 3505

Kalyway MAC OS X 10.5.3 + MAC OS X 10.5.5 Combo Update => Lost PS/2 trackpad/keyboard

I tried to solve this problem by 3-4 different ways . . . they have no result . . .

I think it is about PS/2 driver . . .


P.S. USB Mouse/Keyboard works correctly . . .


Yo))) Can this help us http://forum.insanelymac.com/index.php?showtopic=117359 ??

I will try it now . . .


No, it kills my MAC OS X . . . now i will try to alive it . . .

Link to comment
Share on other sites

  • 3 weeks later...

hmm, they don't seem to work for me.


I used kalyway 10.5.2 install, everything worked fine.

After that i updated to 10.5.5.


Everything still works fine, except keyboard, touchpad, nforce 7400 go no more Q.E.


Any suggestions on keyboard / touchpad issue?

Link to comment
Share on other sites

Here's another fix just in case..worked for me..


Found this on the net somewhere: I had to restore my ApplePS2Controller and AppleACPIPlatform kext (Kernel Extensions). Since I didn't backup was able to pull good kexts from from my install disk:

AppleACPIPlatform.kext ApplePS2Controller.kext


the way to restore them is from the command line:


open terminal and write these commands:

sudo -s (press enter and write your password and press enter again) 

mv /System/Library/Extensions/ApplePS2Controller.kext /System/Library/Extensions/ApplePS2Controller.kext.backup

mv /Extensions/AppleACPIPlatform.kext /Extensions/AppleACPIPlatform.kext.backup

these commands will backup your current kext, just in case


next copy the replacement kext and set their premissions like this:

cp -R /ExtensionsBackup/ApplePS2Controller.kext /System/Library/Extensions 

chmod -R 755 /Extensions/ApplePS2Controller.kext 
chown -R 0:0 /Extensions/ApplePS2Controller.kext 

cp -R /Extensions/AppleACPIPlatform.kext /System/Library/Extensions 
chmod -R 755 /System/Library/Extensions/AppleACPIPlatform.kext 
chown -R 0:0 /System/Library/Extensions/AppleACPIPlatform.kext 


If nothing works, you can always boot to your install disk (iatkos, kaly) then use teminal to run the commands..Remember to copy and set permissions to your /Volumes/(your main volume name here)/System/Library/Extensions folder as your Boot drive is your root drive!


PLEASE feel free to correct the terminal commands you need to

Link to comment
Share on other sites

  • 2 months later...

I was able to get functionality back on my kb and trackpad by using the rapidshare linked file.


I started with Kalyway 10.5.2 and their first update.

Then I applied apple's delta upgrade to .4. That's when trouble started.

.5 upgrade did not fix.


I applied the RS patch and all is well again.



--Acer Aspire One 160 / 1gb

Link to comment
Share on other sites


  • Create New...