Jump to content

screensaver issue after 10.5.5 upgrade


eraserhead77
 Share

10 posts in this topic

Recommended Posts

My screensaver will not kick on after the set time after the upgrade to 10.5.5. It will work if I logout then back in. I've seen posts about this before but never a solution.

 

Other threads show this relating to the PowerManagement.bundle or AppleACPIPlatform.kext

 

This has only started since the upgrade. Has anyone else seen this or know of a fix?

Link to comment
Share on other sites

after messing around with this I found the following

 

1) screensaver does work, but only comes on after 20 minutes regardless of settings in Sys Prefs

 

2) if I logout then back in, screensaver will work work with the proper time setting

 

Is there any way edit a plist manually to set the time frame?

Link to comment
Share on other sites

Well after trying just about every solution for a couple of days I came across this, run it in a shell command and set your idle time accordingly.

 

defaults -currentHost write com.apple.screensaver idleTime 180
/System/Library/Frameworks/ScreenSaver.framework/Resources/ScreenSaverEngine.app/Contents/MacOS/ScreenSaverEngine &
pid=$!
sleep 0.10
kill ${pid}

 

Changing the idle settings via the first string alone is not enough for system prefs to recognize the info in the updated plist. Running the rest of the command starts ScreenSaverEngine just long enough to get it to pull the updated info from the plist.

 

Hope this helps anyone else with this same issue. I don't take credit for the script, but I ran across it today in another forum.

 

:)

Link to comment
Share on other sites

Simply deleting the com.apple.screensaver files under /Users/(your username)/Library/Preferences/ByHost restored the screen saver and password prompt for me.

 

That was one of the things I tried to no avail, the shell script seemed to knock it back into action as it forced the ScreenSaverEngine to kick in and recognize the newly set value in the plist.

 

@eraserhead

the last command seems to be wrong.

could you correct that plz (i´ve got no clue)?

 

 

Looks like you are trying to run from root.

 

You need to run this in a shell script.

 

Open Terminal.

 

Choose Shell from the menu bar, then New Command from the drop down menu

 

Paste the Command into the "New Command" window that pops up, not the terminal itself

 

Be sure to check the box that states "Run Command inside a shell"

 

Click Run...command should execute and it will tell you when the process is done.

 

You should reboot at this point just to be sure. Save this command for later if you need to change values in the future.

 

At some point last night when I was wrestling with Time Machine I also trashed the preferences plist from here:

 

/Library/Preferences/SystemConfiguration/

 

After Reboot I was able to have the screensaver controlled by the system prefs pane as before...but the script is a good backup incase anything goes wrong again.

Link to comment
Share on other sites

  • 4 weeks later...

All of a sudden my screen saver fails to start and there is no password prompt after sleep. None of the above fixes mentioned worked until I removed all files except com.apple.Boot.plist and com.apple.smb.server.plist under /Library/Preferences/SystemConfiguration and this fixed and everything is back to normal.

 

Backup files before you delete anything if you're going to try this.

Link to comment
Share on other sites

All of a sudden my screen saver fails to start and there is no password prompt after sleep. None of the above fixes mentioned worked until I removed all files except com.apple.Boot.plist and com.apple.smb.server.plist under /Library/Preferences/SystemConfiguration and this fixed and everything is back to normal.

 

Backup files before you delete anything if you're going to try this.

 

I am having the same issues with the password prompt, but deleting the files did not solve my problems. Still dont get any prompt. Still working for you?

Link to comment
Share on other sites

 Share

×
×
  • Create New...