Jump to content

Ok, this time I really would appreciate some help please.

iAcid 

21 posts in this topic

Recommended Posts

Over months i've posted a few topics on here, as I love OS X, I have a MacBook Pro which due to a slight accident which wasn't my fault is dying. Anyway, more to the point these threads I have made got no replies which admittedly got me a little frustrated and made me give up on OSx86, also I'm short of money at the moment so I can not get one of the new MacBooks or MacBook Pros which are announced Tuesday and would love to get OSx86 running on this Packard Bell iMedia 2412 currently running Windows XP.


I have both Kalyway 10.5.1 and Kalyway 10.5.2 on disc, but both of these don't seem to pick up my hard drive at all, they only show the disc as being a storage device.


Specs of my PC: Intel C2 Duo E4500, 250GB SATA HDD in IDE (I think, I can check), nVidia 8400GS, Foxxconn motherboard, 2GB DDR2 RAM


Also it would be appreciated if someone could tell me if I could use the Belkin F5D7050 Wireless G Adapter with OSx86.


Anyone who can get me running OSx86 gets a cookie :(


Thankyou very much.

Link to comment
Share on other sites

yes that adapter will work fine (I used to use it for my hackintosh) but about your hdd not showing... I think its something to do with SATA im not to sure tho.. sorry


I can remember people complaining that SATA hdd wont show up but heres a way around it. Again I could be completely wrong its a long time since I tried this stuff again...


(currently trying to get a decent set up on my laptop)

Link to comment
Share on other sites

Thanks very much, I'll have a snoop around to see if there is anything on a work around.


If anyone has a link to a good work around I'd appreciate them posting it :(


Suggest you try iDeneb 10.5.4 v1.1...... :)

Link to comment
Share on other sites

Ok, I got iDeneb 10.5.4 v1.1, STILL not finding my hard drive!


Please please please tell me how I get my SATA hard drive in IDE config to work! I'm actually desperate now :)




Thats the product page for the PC i'm trying to get OSx86 working on incase it's needed.


Is this the installer DVD or the installed system on the HDD after instalaltion from the DVD?

Link to comment
Share on other sites

I can't install from the DVD on that PC as the iDeneb and Kalyway installers both fail to find my Hard Drive. The only stoarage it shows is the Installation Disc


I think your motherboard may be the San Fransisco which has VIA PT890 Northbridge and VIA VT8237A Southbridge chipsets.....see here.....



What are your BIOS settings?.......


You will also need the correct BIOS settings.......if you have the following or similar BIOS options....


Configure SATA as "AHCI" or Serial-ATA Configuration [Enabled]


JMicron SATA / PATA Controller [Disabled].....if JMicron present.....unless it works for you [Enabled].....but JMicron is known to cause problems for some....but JMicron patches for OS X Install DVDs are now appearing......

JMicron Controller Mode [AHCI]....if present.....


CPU Internal Thermal Control [Auto]

Limit CPUID MaxVal [Disabled]

Execute Disable Bit [Enabled]

ACPI APIC Support [Enabled]

ACPI Suspend Mode [s3] or [s1] or [s1 and S3]

Link to comment
Share on other sites

How can I patch my install DVD? Would I need the .iso file because I don't have that anymore... Apart from the iDeneb one if I could patch that?


I think the iDeneb has a VIA patch install package but not certain if it has VIA kext in the boot mkext file.........But first you need to check on your BIOS settings......

Link to comment
Share on other sites

Could you explain how i'd install it?


I checked my BIOS and the only setting I had out of those was Limit CPUID MaxVal which I disabled.


Not clear what you mean here.......


Have you rebooted from iDeneb v1.1 DVD again with -v?.........if so what are the exact error messages you see on the boot screen?


EDIT In your first post you mention a Foxconn motherboard.......is that in a different PC to the Packard Bell PC you posted details on......?


I need to be clear on which motherboard you are wanting to install OS X......


If it is the Packard Bell San Fransisco Foxconn-manufactured MOBO then you have the VIA chipsets (on iMedia J2412)...............and you should have a similar BIOS to the one shown with similar options here.......Do you?

Link to comment
Share on other sites

Yeah thats the mobo I have. And I havn't booted iDeneb up with -V, I was just asking how I could patch my installation disc.


For patching the installation DVD see here......but if your BIOS settings are not correct for OS X it will not make a difference........

Link to comment
Share on other sites

I just said, I checked my BIOS settings and none of those were there apart from Limit CPUID MaxVal


But that Stevo patch, will it work with iDeneb?


EDIT: It's fine, that was a silly question.


I'll leave it running tonight and patch the iso tomorrow.


But, I still have no clue what to do about my BIOS

Link to comment
Share on other sites

Oh, yeah thats my BIOS in that link you gave.


Anything I need to change in there?


Now you see why I kept on about your BIOS settings.....what I mentioned had to be present...... :(


Configure SATA [RAID] (in some BIOS setups RAID function includes AHCI function)


Limit CPUID MaxVal [Disabled]

C1E support [Disabled]

EIST [Disabled]

Execute Disable Bit [Enabled]

CPU Virtualization [Disabled]

ACPI Function [Enabled]

HPET Support Try Enabled first/then Disabled

HDD S.M.A.R.T. Capability Try Enabled first/then Disabled


SATA Controller [Enabled]

IDE DMA access [Enabled]

IDE Primary Channel [Enabled]

IDE Secondary Channel [Enabled]

IDE Prefetch Mode [Enabled]

IDE HDD Block Mode [Enabled]


HD Audio Controller [Auto]

Onboard Lan Device [Enabled]

Lan Boot ROM [Disabled]

Onboard 1394 Device [Enabled]


USB 1.1 Controller [Enabled]

USB 2.0 Controller [Enabled]

USB Operation Mode [Full Speed]

USB Keyboard Function [Enabled]

USB Mouse Function [Enabled]

USB Storage Function [Enabled]


Other settings as default

Link to comment
Share on other sites

Thanks for all the help man! Going to patch the DVD, change my BIOS then go from there.


Hope it works for you.......post what happens either way...... :thumbsdown_anim:


1 more thing, is there anything I need to be able to use my Belkin F5D7050 Wireless adapter?


Check here......

Link to comment
Share on other sites

  • 3 weeks later...

  • Create New...