Jump to content

Install vanilla Leo on a Dell Vostro 1310


8 posts in this topic

Recommended Posts

i got a new Dell 1310 with Nvidia 8400GS, 4GB, 250GB HD, 1505 wireless, 360 dell BT, and a Webcam.

Before i used a GB P35 chipset Desktop and setting up OSX was so much easier.

I always prefered to install vanilla than any distributions, and it worked like a charm with a second osx system running and installing vanilla and patching with chameleon in the end.

This is the way i tried with my Vostro 1310.

1. i installed a iAtkos v4 on a external USB Harddrive.

2. from this system i installed OSX original on internal hard drive, patched it 10.5.4 patch run a little modified post patch which i used for my P35 Desktop before.

3. installed Chameleon


Result system starts but i have no keyboard or mouse support after startup?


I also tried installing iAtkos directly on internal HD but i had problems.


Did someone installed a vanilla system on dell vostro 1310, or can someone recommend a distri/guide/etc. for this Laptop?


I read a lot of Gudie how tos etc., but this time i have to ask (i set up my last 2 systems without doing that)


Sorry for my english

Link to comment
Share on other sites

thanks good hint.

I downloaded iDeneb and choose the Ps2 Fix which seems to resolve the keyboard and mouse problem (my notebook keyboard and mouse seems to be PS2), without PS2 fix i had also non recognized kb and mouse.

He also needs (i think, did not try without) the ICH Fix, cause it is a 965 chipset wtih ICH8 (?).

On my vanilla install i also had to choose the Ich9 fix in the post patch to boot my vanilla install without still waiting for root device error.


I maybe take the ideneb cause it install flawless and seems to run good on vostro, but i still have many problems with sleep speedstep etc.


Some hints especially for this Dell Hardware will be great.

My System again.

Dell Vostro 1310 965 ICH8M

T5670 core2 duo 2GHZ

Nvdia 8400GS 128MB


4GB Ram

Webcam, 1505 Dell wireless, 360 Dell Bluetooth.

6 cells Li-ion

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...
  • 4 weeks later...

Has anyone figured out how to get sleep working on these Vostro 1310 yet?


My Vostro didn't have integrated camera and bluetooth originally, and it was not having sleep issue. Then I ordered them from Dell and installed, then I started getting the sleep issue.


But here's a hint that may help. When my vostro didn't have the camera, it at one time was having the sleep issue whenver there was an external USB device attached. To fix that, I had to enable USB power in the BIOS, then the sleep issue went away.


I am convinced that the resolution lies in the USB driver. And it may not be handling internal USB devices (the camera, for example) correctly.



Link to comment
Share on other sites

Hy there!


Can any of you point me the right direction to get osx on my vostro 1310?


I've installed iDeneb 1.3 on it, but I have a lot of problems :)


Tryed different audio hacks, but if my note can shut down properly after that I have no sound, after I reinstall a fix to get sound, I can't shut it down again :S


Sleep isn't works :S Actualli it looks like it's working, just it wakes up immediately after sleep... the system log tells me that there was an "USB caused wake up (ehci)... (or something like that I can't remember fully)


I have a hungarian keyboard, and my "0" key writes the "í" character and my "í" key does nothing :S I tryed a lot of layouts with international without luck :(


Please help me!!

Link to comment
Share on other sites

  • 4 months later...
I´m on the same boat here dudes, only sleep doesn´t work. I´m working on it. But I´m excited about something.

As soo as possible tell you guys.






Vostro 1310


WiFi 1395 OK

GeForce 8400GS QI/QE OK

Shutdown/Reboot OK

Sleep :unsure: !yet!


hey man !, can you tell me how you did to get shutdown and reboot to work?? i also have a vostro 1310, full hardware functioning but sleep, shutdown and reboot. (oh i hope you read this and help me)


Look at my signature. :P


I installed iDeneb 10.5.5+9.5.0 Vanilla Kernel adding the ICHFix and without the graphics driver. Everything - except no sound after sleep - is working.




BTW: SpeedStep does not work either. But for me it is no real problem.


Hey man, i also have a vostro 1310, can you tell me how didi you get sleep/reboot/shutdown?? whaty files should i look for?

thanks :D

Link to comment
Share on other sites


  • Create New...