Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


HP Compaq nc6220

11 posts in this topic

Recommended Posts



I wanted some feedback from people about running OSX on this machine. Perhaps someone got something working that I didn't :D


What works:


Installing and running Apple OSX 10.4.5.

Video with CI and QE enabled



Internal DVD-RL burner (Mat{censored}a UJDA765a)



What doesn't work:


Internal wired LAN (Broadcom something, how do I find out without Windows?)

Wireless LAN (Intel BG2200)

Bluetooth module (seems neither the WLAN or BT module is enabled, nor can I enable it)

PC-Card slots

SD-card reader

Smartcard reader (how to even use this one in Windows? :blink: )

Softscroll part of touchpad or tap-click (have to use hard keys to click)



I think that's it... System Profiler doesn't detect any audio hardware, and I can't format any external USB-drives - Disk Utility falls into an endless loop. Bluetooth only works with some USB dongles, but ONLY if I do a reboot of OSX. You also need a secondary monitor attached to boot successfully. I have built a small dongle to take care of that issue. Small annoyance but I can live with it :D


If anyone got anything more to work it would be nice to know. The complete lack of networking makes the machine pretty unusable since I want to use it as a workstation. The laptop feels a lot snappier than the dualG5 system I have, so I am happy anyway. But networking and SD-slot would be nice to get working...


Rock on! :guitar:

Share this post

Link to post
Share on other sites

Well my experience is very similar to yours except my Touchpad doesn't really work.


I do know that some people here have got the bluetooth working but I haven't yet (although I just read a tip to get it work, namely press the wireless on/off button before the Darwin prompt appears).


I have an external Belkin USB wireless card (any RT2500 based chipset should be fine) and there are Mac OS X x86 drivers available that work fine.

Share this post

Link to post
Share on other sites

I have a working HP Compaq nc6220. I used Intel/AMD JaS 10.4.8 DVD install. Install only choosing the Intel option. There are a few things. One, I have not gotten the internal NIC to work (Broadcom Gigabit 5171). After a couple days going through this forum, I did find a working installer for the internal Wireless (Intel Pro Wireless 2200bg). I have attached the installer. No need to modify the Info.plist. One caveat, The wireless network you connect to cannot be protected (i.e. no encryption) and if there are no networks that it can associate with, after about 5 minutes, you'll get the dreaded Restart / Powerdown screen. If you are not connecting, just turn off the radio and you'll be fine. Also, whatever video driver is being used only supports 1024x768 res. My next two items will be to get the wired network working and getting the video to support the native 1400x1050 res. I hope this helps. :thumbsup_anim:


Share this post

Link to post
Share on other sites

I have a very usable 6220 system as well. Wish I could get higher than 1024*768 though - was not able to get that to work. See my dmesg below: Please let me know if you find a fix. Thanks


display: family specific matching fails

Matching service count = 2

Matching service count = 4

Matching service count = 4

Matching service count = 4

Matching service count = 4

Matching service count = 6

Apple16X50ACPI0: Identified Serial Port on ACPI Device=C1A1

Apple16X50UARTSync0: Detected 16550AF/C/CF FIFO=16 MaxBaud=115200

C05A: family specific matching fails

display: family specific matching fails

C05A: family specific matching fails

display: family specific matching fails

ApplePS2Trackpad: Synaptics TouchPad v6.2

C05A: family specific matching fails

display: family specific matching fails

AppleAC97CodecAD198x: 2-to-4 channel spreading enabled

C05A: match category IOFramebuffer exists

IPv6 packet filtering initialized, default to accept, logging disabled

display: Not usable

Share this post

Link to post
Share on other sites

I also have an NC6220 that I have functioning at an acceptable level running Jas Intel

10.4.5. I tried other version (10.4.3, 10.4.4, 10.4.8) but they never completed the install

process and always came up with an error saying I need to reboot the machine. 10.4.5

seems very stable tho. Virtually no crashed, even playing graphic intense games.


Video works including 3d graphics (Have played Doom3 & Tomb Raider AOD with no problems)

802.1 g wireless is working without any shutdown issues as described above. Different driver.

Synaptic Touchpad is working with double tap and tap & drag functions working. No scroll

USB ports work with logitech wireless mouse and Various USB devices.


There is another small issue where if the pc goes into standby while my wireless mouse is

hooked up, the tranmitter won't power back up when it comes back up unless I restart.

Touchpad works fine and other usb devices work fine on resume. Just the wireless mouse

issue. No problem with corded USB mouse.


Bluetooth does not work (who cares) and the PC card slot (TIxx21) Also does not work.

Has anyone managed to find a working driver for the PC card slot yet? That's the only

thing I haven't got working that I would like so I can use my Verizon Wireless aircard.

I tried a couple driver mod tips from this site and while others reported they got their

TIxx21 slot working, no one has explained it with enough detail for me to make a working

driver. I assume if I can get it to work on mine, it will be good for most NC6220 units

without making any changes and I'd be happy to share if I find something that works.


If any of you would like to try out my Synaptics or intel wireless drivers, let me know and

I will gladly post them.


Any help you guys may be able to offer would be GREATLY appreciated. I've spent a lot

of time testing this machine with various drivers and such and feel I've gotten it working

quite stable. I'd be happy to pass on any info I've picked up should any of you have

questions about your nc6220 and osx86


Some of you mentioned video resolution issues... Have you tried this:


Typing: '?video' (without the ') at the boot prompt will display all video resulutions

available to you. (sorry, I don't think any widescreen modes are available)


then typing:


"Graphics Mode"="1280x1024x32"platform=x86pc


(With the " included)


You can put in any resolution and color depth for the values as long as it is one of the

supported resolutions displayed when you typed ?video.


My LCD only supports 1280x1024 so that's the highest I've tried.


Have fun!



Share this post

Link to post
Share on other sites

Hi Maj. I just got Jas 10.4.8 running on my HP nc6220 but as mentioned above, no wireless connectivity. Can you please explain how you got it to work?



Share this post

Link to post
Share on other sites

Did anyone get 'Uphuck 10.4.9' and/or 'Kalyway 10.4.10' to work on their NC6220? If so, please let me know the installation process. I am having trouble getting a 10.4 version on my NC6220. Thanks!

Share this post

Link to post
Share on other sites

Jeeze this thread is old, no updates on wifi drivers huh. I probably did 10 different trial and errors and no luck. Any thoughts on this guys? possible solution?


Boy it is a pain to keep reinstalling without the proper terminal commands to avoid it =\

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.