Jump to content

Vanilla 10.5.4 RAID on Bad Axe


3 posts in this topic

Recommended Posts

The purpose of this thread is to contribute to the OSx86 community documentation the problems I am encountering in setting up a Retail/Vanilla 10.5.4 RAID installation on a Bad Axe and their solutions.


Here is the relevant hardware:


Intel D975XBX (Bad Axe 1)

Intel Xeon 3060 (server version of E6600)


XFX Nvidia 7600GS 256 MB


Pioneer DVR-111D (IDE)

120 GB Seagate HD (SATA)

3 x 40 GB Western Digital HDs for RAID arrays (SATA)


For more information on my hardware and previous experience with Tiger (OS X 10.4) installs see this: http://forum.insanelymac.com/index.php?sho...+conroe+bad+axe


Note, I have not yet completed this install and will be updating this thread in blog-like style.

Link to comment
Share on other sites

Here are my Vanilla 10.5.4 installation notes for Bad Axe 1. Note that I did not exhaustively isolate or explicitly reproduce the assertions I make here, so some of them may be and probably are wrong.


These are the problems that I ran into when trying to follow guides like LTL's: http://forum.insanelymac.com/index.php?showtopic=86167


(1) I tried to follow SuperHai's guide to making a custom Boot-132 ISO: http://forum.insanelymac.com/index.php?s=&...st&p=803725


But I ran into the "isolinux: image checksum error boot failed" problem: http://forum.insanelymac.com/index.php?sho...;p=877016


The solution was to simply use the properly constructed "KISS" boot ISO: http://www.4shared.com/file/53547099/b8769...ABYL-BUMBY.html


The "KISS" ISO has all the kexts needed to boot and minimally run OS X. In fact, dsmos.kext, IntelCPUPMDisabler.kext, SMBIOSEnabler.kext are the only kexts I have installed, so my 10.5.4 is "vanilla".



(2) The Chameleon 1.0.11 Installer does not appear to work across drives: http://tinyurl.com/5m66sf


I had to boot into the bare 10.5 install with the KISS ISO and run the Chameleon Installer from there.


Manual installation of non-RAID Chameleon (following the "Readme" included with with Chameleon 1.0.11 Build) generated a error message like "MBR file not found" (not verbatim): http://tinyurl.com/64wh5u



(3) Bad Axe 1's are known to require that the manual activation of boot partitions, other 945/975 chipset boards may be the same. Like the Chameleon Installer, it appeared to me I had to do this after booting into the bare 10.5 install I was trying to activate. I also used the version of "fdisk" supplied with the Chameleon Build. Here are the commands. where the target disk number is X and the target partition number is Y (use Disk Utility.app or execute "diskutil list" to find X and Y for the target partition, diskXsY):


cd  /Path/To/Chameleon-1.0.11-build
sudo ./fdisk -e /dev/rdiskX
> update
> f Y
> w
> [yes]
> q


(4) "vsdbutil -a /Volumes/<OSx86 Partition Name>" did not seem to fix the "cross-disk" problems with the Chameleon Installer nor "fdisk". I do not use this command.





In short, this is how I install 10.5.4:


(1) Buy a Leopard retail disk (DVD) from Apple. Boot it with the KISS ISO or from a pre-existing Leopard installation ("cross disk") with the following command:


open /Volumes/"Mac OS X Install DVD"/System/Installation/Packages/OSInstall.mpkg


Install Leopard on to a GUID formated disk (hit the "Options" button" on the Partition panel of Disk Utility.app to select GUID). Note, that as of 1.0.11 Chameleon does not support "case sensitive" HFS+ formats (so just use the default HFS+ journaled), this is supposed to change with 1.0.12 which is already available in relevant part.


Tip: hit "Command-Q" to skip the OS X registration process.


(2) Download the 10.5.4 Combo update from Apple: http://wsidecar.apple.com/cgi-bin/nph-reg3...Combo10.5.4.dmg


WIth the KISS ISO, boot into the bare 10.5 partition to run the updater or run it "cross disk" from a pre-existing Leopard Installation.


Again wIth the KISS ISO, Reboot (or boot into the 10.5.4 for "cross disk" installation) to complete the 10.5.4 upgrade. Note, that the upgrade process itself might trigger a second reboot.


(3) Once you are in a 10.5.4:

- Run the Chamelleon Installer.


- Manual activate the partition with "fdisk" using the commands above.


- Install the kexts (dsmos.kext, IntelCPUPMDisabler.kext, SMBIOSEnabler.kext) required to boot OS X without the KISS ISO. I did this with Kext Helper:
using three kexts from the KISS ISO (note that you have to mount the "initrd.img" file in the KISS ISO disk). Alternatively, I wrote a short "post-patch" script to do the same modeled on those posted by LTL:


- Choose the video card, click "Add Device" and "write to com.apple.Boot.plist" with EFI Studio:


- Reboot without KISS ISO. Done!


~pcwiz also has produce an OSx86Tools application which has some similar functions to the OSx86 utilities I used: http://######.com/osx86tools/


I did not mess with audio or LAN, so other kexts may be necessary for those features. Bad Axe LANs usually work under OSx86 with no additional setup but the audio controller chip requires editing or replacement of AppleHDA.kext. Simon (sbeehre) reports some Bad Axe 1 (10.5.4) related audio issues here: http://forum.insanelymac.com/index.php?showtopic=117305





RAID Notes:


(1) Simply follow the instructions in the Chameleon 1.0.11 Build "Readme": http://tinyurl.com/64wh5u


 RAID Install:

 Suppose that your installation is on /dev/disk3, which is either a mirror- or a
 stripeset consisting of /dev/disk0 and /dev/disk1

 Mac OS X creates a small helper partition at the end of each RAID member disk,
 namely /dev/disk0s3 and /dev/disk1s3

  - Install boot0 to the MBR of both disks:
	  fdisk -f boot0 -u -y /dev/rdisk0
	  fdisk -f boot0 -u -y /dev/rdisk0

  - Install boot1h to the bootsector of each boot partition:
	  dd if=boot1h of=/dev/rdisk0s3
	  dd if=boot1h of=/dev/rdisk1s3

  - Install boot to both helper partition's root directories.
	  diskutil mount disk0s3
	  cp boot /Volumes/Boot\ OSX
	  diskutil unmount disk0s3
	  diskutil mount disk1s3
	  cp boot /Volumes/Boot\ OSX
	  diskutil unmount disk1s3

  - Add "rd=uuid boot-uuid=506D8F03-0596-32D8-BE0B-E3A4E7D5C72A" to your kernel flags
 (replace with your root volume's UUID; find out using "Disk Utility.app", right
 click on your root volume, then Get Info"):
	  nano /Library/Preferences/SystemConfiguration/com.apple.Boot.plist
	  touch /System/Library/Extensions



(2) Note that you are working on a "small helper partition" create by OS X at the end of each RAID slice, not the RAID slice partition itself. You can see these "helper" partitions named "Boot OSX" by running:


diskutil list


(3) Again for Bad Axe and possibly other 945/975 boards, manual activation of the each "Boot OSX" is required. Same commands as above, just target the "helper" partition not the RAID slice, nor the virtual RAID drive itself.




This Bad Axe is clocked to 3.0 GHz on the flat 1333 strap with memory speed to set 667 (3-3-3-4):


Xbench v1.3 results:


Results	213.01	
System Info		
	Xbench Version		1.3
	System Version		10.5.4 (9E17)
	Physical RAM		2048 MB
	Model		SomeModel
	Drive Type		RAID1
CPU Test	187.76	
	GCD Loop	352.95	18.61 Mops/sec
	Floating Point Basic	168.64	4.01 Gflop/sec
	vecLib FFT	139.42	4.60 Gflop/sec
	Floating Point Library	186.30	32.44 Mops/sec
Thread Test	255.23	
	Computation	239.44	4.85 Mops/sec, 4 threads
	Lock Contention	273.25	11.76 Mlocks/sec, 4 threads
Memory Test	206.61	
	System	247.92	
		Allocate	335.36	1.23 Malloc/sec
		Fill	206.84	10057.11 MB/sec
		Copy	233.43	4821.32 MB/sec
	Stream	177.10	
		Copy	165.16	3411.22 MB/sec
		Scale	170.29	3518.07 MB/sec
		Add	185.98	3961.72 MB/sec
		Triad	189.34	4050.35 MB/sec
Quartz Graphics Test	279.03	
	Line	216.86	14.44 Klines/sec [50% alpha]
	Rectangle	294.88	88.04 Krects/sec [50% alpha]
	Circle	241.58	19.69 Kcircles/sec [50% alpha]
	Bezier	233.17	5.88 Kbeziers/sec [50% alpha]
	Text	671.68	42.02 Kchars/sec
OpenGL Graphics Test	232.52	
	Spinning Squares	232.52	294.96 frames/sec
User Interface Test	449.43	
	Elements	449.43	2.06 Krefresh/sec
Disk Test	105.64	
	Sequential	204.43	
		Uncached Write	301.65	185.21 MB/sec [4K blocks]
		Uncached Write	293.09	165.83 MB/sec [256K blocks]
		Uncached Read	101.90	29.82 MB/sec [4K blocks]
		Uncached Read	330.40	166.05 MB/sec [256K blocks]
	Random	71.22	
		Uncached Write	32.59	3.45 MB/sec [4K blocks]
		Uncached Write	122.88	39.34 MB/sec [256K blocks]
		Uncached Read	96.00	0.68 MB/sec [4K blocks]
		Uncached Read	144.38	26.79 MB/sec [256K blocks]

Link to comment
Share on other sites

  • 1 month later...

I want to update this list of instructions with a couple of brief notes:


(1) Apple's upgrade 10.5.5 refuses to run either the RAID or normal OS X installations I describe above. I have not bothered to pursue it and suspect that I could have upgraded to 10.5.5 before adding Chameleon. This again seems to be a BadAxe or 975x chipset issue.


(2) The built-in Ethernet controller works but it seems to have an initial problem detecting the IP address issued by my ISP. However, my current ISP is a little sketchy so I can not rule out that the problem is really on their side. I worked around this by manual entering an arbitrary IP address like in SystemPreferences->Network->Configure and then switch back to Configure->Using DHCP. I had to do this on rebooting a couple of times, but now it appears to be set. The other thing is that the SystemPreferences->Network falsely shows a red "Ethernet Adaptor (en0) Not Connected" icon and likewise with the OS X network diagnostics. But once the IP address is detected, there are no problems and I assume that I could swap kexts or such to fix this problem entirely.


(3) The only issue I am concerned about is this error which comes up in log frequently and is supposed to be related to Ethernet controller problem, while I did not search exhaustively, I did try some things suggested for this that did not solve it:


"_CFGetHostUUIDString: unable to determine UUID for host. Error: 35"


Otherwise, the RAID installation really kicks a$$.

Link to comment
Share on other sites


  • Create New...