Jump to content

[Guide] Acer Extensa 5620e Dual Boot Vista w/iAtkos v1.0i


4 posts in this topic

Recommended Posts



Acer Extensa 5620e w/iAtkos v1.0i


Hey guys, this is my first ever guide which i basically wrote for a mate after i got Leopard successfully working on his Acer Extensa 5620e and then we did the cool thing of messing abit with time machine without using an external hdd and ended up with a chain booting error. This was my guide so that he could do it at home. I basically winged it and it payed off, as now he has an almost fully working hackbook i suppose you could call it :huh:


I'll give you abit of background on the situation.

Basically, met the guy in my IT class at school, heard him rave about vista to start with, but soon the issues with Vista slowing don and such appeared. Got chatting with him and told him of my osx86 adventures. He seemed intruiged. So, we partitioned the hard drive and all that jazz, booted my good friend iAtkos and everything seemed fine. Hit up the disk utility and tried to format to OS X Extended (Journaled) and nothing happened, no disk mounting, nothing. Woo. I decided best solution would be to re scheme the hdd with the disk utility. That worked and we got our partition mounted. So we proceded with install iAtkos. Just a bare install, no drivers, figured that way their wouldnt be too many errors. Blinking cursors make me quite disgruntled. i took the laptop home for the night and this is what i did:


Note: There may not be any need to completely re-scheme your hard disk with the disk utility. If you do, make sure you are on MBR in the partition scheme options!! Otherwise you can try partitioning your hdd then merely formatting the new partition to OS X Extended (Journaled), And skipping a few steps in the guide.


Here we go...


Mac OS X Leopard (iAtkos v1.0i) - Acer Extensa 5620 e

Dual Boot with Windows Vista.


Step 1. Cleaning


Insert iAtkos v1.0i disk and reboot pc.

Boot the iAtkos disk in verbose mode (-v)


When installer has loaded goto the Disk Utility

click on your hard drive.

Select the Partition option.

Choose a 2 partition Scheme.


name and select the format of your partitions.

(1. MS_DOS fat 32)

(2. Mac OS Extended (Journaled))






Quit the leopard installer and reboot.



Step 2. Setup for ms


Insert G-Parted


Format the fat32 to NTFS


format the hfs+ to unformatted!





Step 3. Vista Install


Insert Vista Install disk


install on the ntfs disk.


When installed update graphics driver.



Step 4. The Leopard will run again!


Insert iAtkos and reboot.


as always start in verbose (-v)


When iAtkos loads go Disk Utility


Select disk0s2


Go Erase.


Call it Mac OS X, format OS X Extended (Journaled)




Now Darwin Bootloader (Darwin_Boot)


y to all


go thorugh the installer to the custom menu


ONlY! Select

+Stock Kernel

+Intel GMA3100




When sucess (there will 100% be sucess) reboot. Leave the disk in.


boot into single user mode (-s)


run these commands:


fdisk -e /dev/rdisk0/


fdisk flag 1






~~~~END CODE~~~~



Step 6. Dual Boot


boot into vista! only pop iAtkos out of the disk tray

no point on fully removing it, just let vista start to boot and chuck it back in.


When in vista, copy the chain0 file to c:\


then run cmd prompt with Admin Priveledges(Important)


enter the following commands exactly as described:


bcdedit /copy {current} /d "Mac OS X"


bcdedit /enum active


bcdedit /set {numbers above where it says Mac OS X, has 12x0 on the end} PATH \chain0



~~~~END CODE~~~~



If this doesnt work try again, it has to work to be sucessful.


if all goes well, close cmd prompt take iatkos out of the tray and reboot.


The vista bootloader should appear.

Microsoft Windows Vista

Mac OS X


Select - Mac OS X


wait to see if it boots. if you get darwin, wait for it to count down first, it may send you back to the vista bootloader.

If so! select os x again, now press F8 and move down to hd2, and boot with cpus=1.


May get Kernel Panic, but not everytime.


[update] seems with cpus=1 there is very little kernel panics that ever occur.




i shall update this more tmoz as i have to go to bed because i am really tired. we have alot of findings and some driver fixes which work. The install results will also be posted. Hopefully this helps some people!!





Link to comment
Share on other sites

  • 4 weeks later...

Umm, i cant say for that specific laptop, youd have to search the HCL in the wiki or around the forums. Also that has an AMD processor which makes thing slightly more difficult. Sorry i cant be of more help!



Link to comment
Share on other sites

  • 1 year later...

so im having troubles:


i have been trying to dual boot win 7 and iatkos v1.0i


i get to the part where you have to change the bootmanager via command prompt-


i did exactly as this guide said (http://dailyapps.net/2008/03/hack-attack-dual-boot-leopard-and-windows-vista/) and everytime i go into booting the os x, it boots into windows-


its something with the GUID i think- i put in what he told me to put in- does anyone have any suggestions or do they want me to upload a pic of my bcdedit /enum-?

Link to comment
Share on other sites


  • Create New...