Jump to content

OSx86 10.5 on Shuttle SP35P2?


8 posts in this topic

Recommended Posts

Hey all...I'll admit that I'm very new to the OSx86 scene, still learning quite a bit. I've checked the Wiki for 10.5.2 hardware compatibility but don't see any mention of my Shuttle SP35P2.


Here is a link to specifications of my Shuttle straight from Shuttle.


Is there enough info listed on the above page to tell if the OSx86 install will go ahead without too many issues?


If there is any more information required I would be happy to assist. The only other thing that I do not see listed in the Wiki is my ATI HD4870 video card so if somebody could chime in and lend a hand to this newbie he'd very much appreciate it. :lol:

Link to comment
Share on other sites

  • 2 weeks later...
Anybody know at all if this is possible or has been done???


Yeah it works. Kalyway 10.5.2 boots and detects the network card. USB is all good, no audio and I haven't gotten sleep to work at all. I've tried updating that to 10.5.3 with the JaS updater and it lost my Quartz Extreme and Core Image hardware support, it also lost the ability to erase disk images and would give UUID problems when doing cloning.


So by Kalyway 10.5.2 I had a basic system with networking.


As of today I've installed the JaS 10.5.4 Client / Server and my video has QE / CI and seems to work fine for cloning so far. No audio, no networking. So now I'm trying to learn how to take the Kalyway network kext files and apply them to my JaS install. I need to be at 10.5.3 or above to do iPhone development with XCode so that's why I'm keeping JaS without networking when Kalyway had it.


Hope this helps, I don't know much more than you do, just dig around on forums and learn what you can. :-)

Link to comment
Share on other sites

Me again. More info on my Shuttle SP35P2 experiences. Hope this helps anyone out there looking for info.


I've finally gotten 10.5.5 working on my SP35P2.


The trick was, to first install Kalyway 10.5.2 then use the Kalyway 10.5.3 updater. Following the instructions I had to use the update command twice before it would boot normally. At that point I'd lose my QE and CI, but still have my network card working which is most important to me.


I downloaded the 10.5.5 Combo updater and then updated from 10.5.3 directly.

The trick is to run the following script as root in the background while using the Installer app.


sudo su

while sleep 1; do rm -rf /System/Library/Extensions/AppleIntelCPUPowerManagement.kext; done


I'm still learning this stuff but basically in the past when trying to do updates this file was killing it midway and borking my install. The script above deletes it right away before it can do any damage.


Right now I'm in 10.5.5 and my network card is good, HD fine, etc...

Not working are:

Audio drivers.


Graphics with Quartz Extreme and Core Image.


That's fine since I can go online and research, copy files from my server, etc...

Okay so the one bad thing right now is that I don't have a bootloader installed.

Normally what I do is I have the HD split into partitions (I'm using MBR so I can put XP on later), one named OSX, the other named Backup. I'd use Carbon Copy Cloner to make an exact backup, then test an upgrade on the Backup, if it fails, I just go back and wipe it then make a new backup and test again. That way setting everything up again in Kalyway 10.5.2 only takes about 15 minutes to do the disk image instead of installing off the DVD again.


Now with 10.5.5 my HD won't boot on it's own, I don't know why that happened but the way I worked around it is by putting in an install DVD and pressing f8 for options, I then typed.

rd=disk0s2 update -v

This boots from the second partition on my HD after loading the kernel and things from the DVD. So maybe my 10.5.5 really is hosed and I just don't know it yet. ;-) There's guides here on how to get it booting without the DVD, so I think all I need is to manually install the boot loader and I should be fine. Will update more here and I discover things.

Link to comment
Share on other sites

I got my QE/CI working again in 10.5.3 using the manual method of fixing explained here:;client=safari


Just incase that page soon disappears, I'll copy the instructions.



NVkush to fix QE/CI after 10.5.3 Update


Posted by Puttabong on May 31st, 2008 in Osx86, Releases |


Did you use one of the new 10.5.3 Combo Updates to update your Hackintosh to the latest version? If your machine uses one of the 7×00 or 8×00 series NVidia Graphic Cards you might have noticed a loss of Quartz Extreme and Core Image. Thanks to DiaboliK’s latest marihuana flavored NVidia Installer you might be able to fix the problems.




If your graphic card uses more than 256 MB RAM, try to create a customized plist file using DiaboliK’s Plist Generator.




NVkush can be downloaded at DiaboliK’s Helpful Files.


Manual Fix


If NVkush didn’t work you can try to use an EFI string for your card. If that doesn’t work either you could try Krazubu’s method instead. He claims that the process is very simple and the problem is caused by a little detail in the plist. However, the guide assumes that the card was working before the update, which means you were using the right kexts with the correct IDs and the injecter correctly set.


1. Open the Info.plist of your injecter



2. Find this line




3. Replace XXXX with 0


4. Save the new file to the desktop, move the file back and overwrite the original one. You will need to authenticate.


5. Fire up the terminal and type the following 3 lines to repair the permissions


sudo chown -R root:wheel /system/library/extensions

sudo chmod -R 755 /system/library/extensions

sudo rm /system/library/extensions.mkext

6. Exit and Reboot, QE/CI should be back.



Additionally after going into my BIOS and changing the Chipset drivers from using IDE mode to AHCI mode I now have all my controllers showing up in System Profiler. Although now my drives show up as orange. I may look for the fix to that, as I remember seeing it mentioned before.


Another tip I'll give you guys is to use google search instead of the built in one here. Often it finds nothing at all for example searching SP35P2 today I couldn't find this topic. Go to google and use this.

site:forum.insanelymac.com yoursearchtermgoeshere


And you'll get a LOT of results.

Link to comment
Share on other sites

More good news! :-)


Got my sound working! Woot!


Thanks to:


Use the link in the second post by zarac, I used Kext Helper .7 and installed both of those kext files included. A simple reboot and I'm good.


Also I forgot to mention that one of the advantages to use AHCI mode on the SATA disks is that now my HD light isn't blinking every 1 second. Previously it was constantly flashing once a second and bugging me. I did some research on blinking HD leds and the only mention I found was a post talking about Windows, however it stated the reason was polling for a CD in the drive. I figured maybe that had something to do with using an older style driver, so when I updated to AHCI it seems to have solved it.

Link to comment
Share on other sites

Good day today... got the Orange HD icons fixed. Via here:



What it basically does is updates 2 Info.plist files that are found inside kext driver bundles. Many of the updated kernel extensions on this site are just small text updates that name chips that are compatible with the standard Apple drivers. All you need to do is find the right identifier for it and the Apple drivers will recognize your hardware and load appropriate drivers for it. It's because Apple only added identifiers for the specific cards and chips they use on their own hardware.


I'm learning a lot about this stuff and hopefully after a while I'll be able to make a boot-132 disk specific to the SP35P2 hardware, which would let us use a standard OS X retail disk to install and prevents software update from killing your system.

Link to comment
Share on other sites

  • 3 weeks later...

thanks for the help! updating to 10.5.5 right now... can't wait to try the audio and orange icon fix. I hope sleep behaves better after the update! then all that is left is testing my 9600 GSO to make sure QI/QI is working and performance is actually up to snuff. more to come.

Link to comment
Share on other sites


  • Create New...