Jump to content

Language problem


1 post in this topic

Recommended Posts


I'm new to the OSX86 scene - to be honest, I didn't know much about it 3 weeks ago when I heard that the MSi Wind could run Leopard.

I've been following a few threads here and there in order to achieve a nice install, with all languages - at least mine: French, and my wife's: Spanish. I still have a few problems, I have managed to clear most of them, but with a little help I'm sure it could be done better.

So far, I've used the Kalyway method, as described on modaco's forum. I've also used the MSIWINDOSX86.iso which floats around on TPB, to which I added the optional languages using my genuine copy of Leopard. And the third method was with the help of Onetrack who helped me built an iso specific to the Wind and with all the optional languages.

In each case, here is what happened:

- I chose French as the main language in the Leopard installer

- at the end of the installation, I get a message -in the log window- which says that some files were not written for Setup to pick up on.

- I reboot after install, and the first Setup of the machine is back to US english.

- I setup the Wind, first login is in English. I switch to French using the International prefpane in the System Preferences, log-out and back in and it's in French. Well, almost: if you go to the Sytem Preferences, some are still in English, some have their name in English and are in French when you open them, and the Keyboard and Mouse just won't open at all.


That was the case regardless of the method I used for install. After some research, I found out that deleting all the Caches (/System/Library/Caches, /Library/Caches and homefolder/Library/Caches) cleans the System Preferences which are all in French after rebooting. But the Keyboard and Mouse one still won't open.


When I compared the Keyboard.prefPane with the one I my MacBook Pro, I realised that the MBP was more recent. So I just copied it using a USB stick, replaced the one in the Wind, repaired permissions because traveling on the USB screwed things up, and then Bingo!!! I can now open Keyboard and Mouse in French - and in Spanish too. My MacBook Pro is one of the latest, with the new trackpad, which would explain why the creation date was different from the one in the Wind. So on the next installation test, I used the one in my wife's MacBook - it had the exact same creation date as the one in the Wind - and it worked too. I don't quite understand what's going on. I tried to make an Install Package with the MacBook Pro's prefpane using Package Maker, but it crashes when I build it. Don't know why, and I'm not very familiar with those tools.


After much research on my MacBook Pro and Google, I found out that OSX stores the default language in a file called CDIS.custom which resides in /var/log - it has one line: LANGUAGE=French

That file defines the language in Setup, and also in the Login window. It does get created on the MacBook Pro near the end of installation. It doesn't get created during the install on the Wind, hence the message in the log window I mentioned earlier. So what I tried was to install the OS on the Wind, then when it reboots, I use Darwin to boot in single user with the -s option. From there, I can create the CDIS.custom file using nano, then reboot, and then the first Setup is in French! Hurray! Well almost... the first login after setup is in French, but when I launch System Preferences, the Keyboard and Mouse won't open...

So back to the USB stick to copy the prefpane from the MacBook.


Thanks for your suggestions on how to make that work in a simpler manner - for those guys who want to use their Wind like a real Mac!

Link to comment
Share on other sites


  • Create New...