Jump to content

Need Help with Firmware Update

3 posts in this topic

Recommended Posts

Hi, I just got a Dual 500 Powermac which is running Tiger very well but as my other Macs run Leopard I thought I'd try it on this machine as well as I've heard reports that it runs fine.

The problem is whenever I put in the Leopard disk to start up I get a kernel panic and I think it's to do with the firmware being out of date. The boot rom version is 3.3.4f1 and I know the latest for this machine is 4.4.8. I know I'll need to do some tinkering with either open firmware or the DVD to fool the machine but at this stage I just want to get the firmware up to date.

The problem is I need to install OS9 on a separate disk to run the firmware updater and I don't have an OS9 retail disk. I've tried a few torrent files, my thinking here was it would be ok to run OS9 unlicensed just for the firmware update as I won't be using it after that. The trouble is I can't get any of these downloaded images to boot on the Powermac. Some are just bypassed completely with the machine going straight into OSX, others hand at a Finder icon with a ?, which I think means it can't find a valid system to boot from.

I know I could purchase OS9, but to be honest, the prices are more than the cost of the Powermac.

So can anyone help with any suggestions please, either a known image that I can get that will boot, or any way I can get the system files for OS9 onto the Hard Drive so I can boot from it.

Thanks a lot. RS

Link to comment
Share on other sites

Search up "Mac OS 9" (without quotations) on TPB/Bay of Pirates :P


Hmm! Maybe you should have read my post before replying.


Anyway, I solved the problem and this may help others. I used the OS9 Classic Disk 2 from my Powerbook G4 original restore disks. All I did was extract the US version, don't suppose it matters which language you choose as long as you can read it, with Pacifist on a spare OS9 driver prepared hard disk in the PowerMac. I then went into Start Up Disk and the OS9 system showed up, so I selected and restarted. I didn't expect this, but it booted straight into OS9 on the second hard drive. From there it was all plain sailing. I updated the firmware, rebooted back into OSX and I now have Boot Rom version 4.2.8f1! (Plus a lot of coasters from TPB downloads that wouldn't boot!)

Link to comment
Share on other sites


  • Create New...