Jump to content

New Generation Motherboards

7 posts in this topic

Recommended Posts

I'm looking to install Leopard on a computer using an Asus P5Q-E (or better) motherboard.

Unfortunatly the hardware guide hasen't been updated past 10.5.2 or past the P5K series.


Does anyone know if Leopard is Compatible with the P5Q series motherboards?


Thanks in advance,


Link to comment
Share on other sites

  • 2 months later...

Yes, it is. I just spent the past week battling my P5Q-Pro and finally got it up and running using Kalyway 10.5.2, running the vanilla kernel. I haven't gotten the onboard audio or ethernet working yet, but haven't started to look into those issues yet. If you beat me to it, please let me know.


See this post:




I can let you in on everything I've learned through this painstaking process, can't say 100% this will work for you, but in the end it was the only configuration that would work for my mobo.


1) You need a modified bios (see post #40 on that thread). You'll get nowhere without this. Just a note, I patched my bios after I had windows installed and after that XP went to {censored}. Don't know why, but it happened...registry errors, crashes, blues screen, you name it. I fresh install after the bios mod fixed it and running smooth ever since.


2) You must enable AHCI in the bios. This was the major culprit to the installation being unsuccessful. Installation kept giving and error half way through until I changed it. Again, make sure you do this before you install windows - if you change it afterwards windows will not boot. If you want to for some reason, you can change it back to ide/compatible after OSX is installed but if you do not have it enabled any additional logical partitions on your hd will not show up in OSX.


3) I tried everything for 2 days to to get the install disk to boot up and kept getting the error "still waiting for root device". I was using an ide dvd drive. Nothing I tried would work. I ordered a sata dvd drive ($30 Lite On drive form New Egg). Put that in and boom, install booted right up. There's alot of talk on that thread about that problem and this seems to be the solution (for me anyways).


4) Turn off you ethernet in the bios. You can turn it back on after OSX is installed.


5) Last thing is disable "MAX CPUID". Leaving it enabled will only show 1 core in OSX.


Hope this info helps. If anyone has any input on the ethernet or audio or any other questions, message me.




Asus P5Q-Pro

Intel Core2 Duo 3.16Ghz - E8500

4GB (2x2) Corsair XMS RAM (4-4-4-12)

PNY 8800GT 512MB

Seagate Sata II 640GB HD

Lite-On 20X Lightscribe DVD-RAM

Link to comment
Share on other sites

  • 5 weeks later...
  • 3 weeks later...
  • 4 weeks later...
  • 1 month later...
  • 2 weeks later...

Hi everyone B)

This is my computer


Motherboard: Asus P5Q SE/R

Chipset: Intel P45

CPU: Intel Core 2 Quad Q9550 @2833 Mhz

Ram: 4096 (4x1024 DDR2-Sdram)

Video: Nvidia GeForce 9600 GT

HD1: ST3250820AV (250GB)

HD2: Maxtor (500GB) USB

HD3: WD (500GB) USB


Network: Atheros 10/100


I also have the retail Leopard DVD and i would like to install it on my Maxtor usb


Anyone can tell me the easiest way to proceed ?

Thanks a lot B)




Link to comment
Share on other sites


  • Create New...