Jump to content

Nvidia 135M SLOW performance


4 posts in this topic

Recommended Posts

I am currently running Kalyway 10.5.2 upgraded to 10.5.3 My video card is an Nvidia Quadro 135m in my laptop. All appears to be installed ok, i have CI/QE running ok. My issue is with the overall feel, it feels slow. Xbench (i know not the best test) seems to confirm my suspicions.

Note the OpenGL scores especially. My other laptop running a GMA950 intel onboard devices beats this by a long shot. The specs say i should be well above this. I am running NVinject 0.2.1 and i have tried Natit 1.0, NVkush, and even older versions of NVinject, all with similar results. Is there a kext somewhere i should be looking at? any kind of parameters that may point me in a better direction???




Results 87.75

System Info

Xbench Version 1.3

System Version 10.5.3 (9D34)

Physical RAM 2048 MB

Model MacPro3,1

Drive Type ST980813AS

CPU Test 125.06

GCD Loop 235.14 12.39 Mops/sec

Floating Point Basic 113.27 2.69 Gflop/sec

vecLib FFT 91.73 3.03 Gflop/sec

Floating Point Library 124.98 21.76 Mops/sec

Thread Test 154.09

Computation 163.00 3.30 Mops/sec, 4 threads

Lock Contention 146.11 6.29 Mlocks/sec, 4 threads

Memory Test 147.10

System 146.16

Allocate 168.00 616.95 Kalloc/sec

Fill 130.78 6359.03 MB/sec

Copy 144.38 2982.03 MB/sec

Stream 148.04

Copy 139.00 2870.97 MB/sec

Scale 143.23 2959.14 MB/sec

Add 155.27 3307.65 MB/sec

Triad 156.18 3341.02 MB/sec

Quartz Graphics Test 83.81

Line 72.73 4.84 Klines/sec [50% alpha]

Rectangle 69.22 20.67 Krects/sec [50% alpha]

Circle 56.98 4.64 Kcircles/sec [50% alpha]

Bezier 104.49 2.64 Kbeziers/sec [50% alpha]

Text 230.49 14.42 Kchars/sec

OpenGL Graphics Test 61.40

Spinning Squares 61.40 77.89 frames/sec

User Interface Test 114.04

Elements 114.04 523.37 refresh/sec

Disk Test 46.51

Sequential 100.20

Uncached Write 98.30 60.35 MB/sec [4K blocks]

Uncached Write 95.03 53.77 MB/sec [256K blocks]

Uncached Read 106.07 31.04 MB/sec [4K blocks]

Uncached Read 102.10 51.31 MB/sec [256K blocks]

Random 30.28

Uncached Write 9.69 1.03 MB/sec [4K blocks]

Uncached Write 93.85 30.04 MB/sec [256K blocks]

Uncached Read 92.90 0.66 MB/sec [4K blocks]

Uncached Read 134.04 24.87 MB/sec [256K blocks]

Link to comment
Share on other sites

  • 4 months later...
...Nvidia Quadro 135m in my laptop. All appears to be installed ok, i have CI/QE running ok. My issue is with the overall feel, it feels slow.

Same thing here. I have 10.5.4 installed (using iATKOS 4) and res-change / QE / CI work, but my 3d performance (even desktop effects) is poor. This may be because this vid card likes to dynamically clock down to half speed on both vram and GPU. I run ubuntu on this laptop and I had this issue but only for the first 5s of 3d usage, after which the GPU would clock up and perform as it should. In ubuntu there was a script I used to stop this behaviour while on AC power;

while true; do
if on_ac_power; then
	nice /usr/bin/nvidia-settings -q all > /dev/null
sleep 25;

This only works though if you're using the nV driver. I suspect that this is our problem but because we're not really using a nV driver, we'll not have control of how the GPU clocks itself.


Does anyone know how to check GPU clock speeds in OSX? Any 3rd party apps that can tell me? That would help confirm my explanation.

Link to comment
Share on other sites

  • 1 year later...
  • 3 weeks later...

  • Create New...