Jump to content

Getting Belkin FireWire/USB expresscard to work

6 posts in this topic

Recommended Posts

Dear folks,


Thank you for wonderful support on this forum. A lot of information. However I cannot find answer to one question. I have a Belkin FireWire and USB 2.0 ExpressCard, which is supposed to work on Macs. Though in my case only the USB port is working, but the FireWire sockets are dead. When starting up in verbose mode it says "FireWire: Unable to get device memory."


I had the same problem with the built-in mini FireWire port. It resolved after I installed beta versions of IOPCIFamily and IOPCCardFamily kexts provided by Chun-Nan (currently beta3). However, the built-in chip is not made by Texas Instruments and does not function properly with my MOTU soundcard. Thus, I desperately need to get the ExpressCard FireWire ports working.


I have a barebone notebook with Intel processor, chipset and graphics card, O2Micro Cardbus and FW controller, Iatkos v1.0r updated to 10.5.2, Belkin FireWire and USB 2.0 ExpressCard (F5U506)


Would Kalyway installation solve my problem?




Link to comment
Share on other sites

So you actually have the express card slot working. Wow LUCKY! :unsure: I cant even get that far.


Well, USB woked by default. This should not come as a surprise, since the ExpressCard device supports USB 2.0 connectivity along with the PCI Express. So partially it can be regarded as a basic USB port. However, the card does not show up in any other way neither in the system profiler nor on the desktop. It is only visible as additional USB root hub.


If you tried ExpressCard USB adapter, theoretically it should work, given that other built-in USB ports on your computer are functioning correctly. Other adapters is a different game. Have you tried it?

Link to comment
Share on other sites

  • 4 weeks later...

I just plugged one into my macbook pro and the usb work but no firewire :(

As you say nothing shows up as a device, did you get anywhere with this? What is really annoying is that I got it because apple have it listed on the store.



Link to comment
Share on other sites

  • 3 weeks later...

No progress as of yet. Maybe Apple will solve this in some of their OS updates.


Otherwise we have to hope for help from some tech wizards on the forum. For an expert it should not be too much of a problem to add one more device and two arrays of addresses to the list of parameters.


Just in case some developer reads this, I have copied the information from Windows device manager below.


Device instance id:



Hardware ids:







Memory range: FBFFB800 - FBFFBFFF

Memory range: FBFFC000 - FBFFFFFF

IRQ: 16

Link to comment
Share on other sites


  • Create New...