Jump to content

Sleep function doesn't Work


5 posts in this topic

Recommended Posts

Sleep works depending on your motherboard. I think it has something to do with the AppleIntelCPUManagement.kext that people need to remove to get the 10.5.2+ updates on their machines. Thats why I've read some posts that peoples laptops are over heating and battery life isn't as good as it could be. You could try a hacked kernel instead of a vanilla one, it might work because I've read that some have. Go to the OSx86.hu IRC and look for the following suffixes: SS3, Sleep, and etc.

Link to comment
Share on other sites

My motherboard supports SS£ and sleep and im running the following:


9.3.0 Darwin Kernel Version 9.3.0: Fri May 23 00:49:16 PDT 2008; root:xnu-1228.5.18~1/RELEASE_I386 i386


There must be someone with this kernel who knows how to get sleep working!!

Link to comment
Share on other sites

I got sleep working here..


I made a readme about it.. let me paste it.



This is a plugin that should be copied to:
(if there is not one there already)

* Make sure (preferrably before copying to System/) AppleACPIPowerSource.kext/Contents/Info.plist and /System/Library/Extensions/AppleACPIPlatform.kext/Contents/PlugIns/ACPIPS2Nub.kext/Contents/Info.plist has the correct version numbers for 


Check what your system has by doing:

sudo kextstat | grep ACPI

and uses these versions in the AppleACPIPowerSource.kext and ACPIPS2Nub.kext

Fix the permissions by running "Extensions-Repair" utility.

Reboot once with -x boot option, and then reboot again into normal mode.
Then Go to System Preferences -> Energy Saver and enable battery.

If this does not work, install "PowerManagement" bundle, fix permissions and
try. It should work once the correct version numbers are in place!

Note: If you have updated to 10.5.3 combo, use Superhai's Power Management


Link to comment
Share on other sites


  • Create New...