Jump to content

Problems partitioning hd in acer laptop


10 posts in this topic

Recommended Posts

I have just bought a new acer Laptop, and downloaded Kalyway 10.5.2.

-Acer Aspire 5715Z

-Mobile Intel® 965 Express Chipset Family

-Intel® Pentium® Dual CPU T2370 @ 1.73Ghz

-Mat{censored}a DVD-RAM UJ-850S ATA Device

-Motherboard Chip: Intel Crestline-GML GL960

-Ram: 2037 MB (DDR2-667 DDR2 SDRAM)


Its very strange. I can't create partitions in GUI mode, before installing, gets stuck or shutdown.

Boot from Kalyway 10.5.2 in single user mode with option cpus=1, I've tried fdisk and newfs, but it fails.

newfs, after some sectors, stops with a Segmentation Fault.


Many thanks!!

Link to comment
Share on other sites

It seems everything is working, but very very slow.

First it has detected the current partition, about 25 minutes to get ready... Then I choosed one partition, named Leopard.

I have clicked Apply, three minutes ago, and still waiting... It says it is creating The partition Map...


More details:


- Serial ATA 2

- S.M.A.R.T. not supported


Whats wrong?

Link to comment
Share on other sites

i had that problem on tiger, the problem was bad driver for sata chipset controller


So use gparted live cd to partition and set active, disk utility to erase the selected partition partition in hfs+journalled, then install and try to find a solution for your chipset problem. Once you figure out the problem, integrate the driver to the kalyway dvd 10.5.2 with it's provided script.


Use this guide to install on guid, it works, although it has some extra-steps

Link to comment
Share on other sites

thankyou sama7896.


I did something similar. Was booting in single mode, using fdisk to change partition scheme, and trying to format from disk utility, but it didn't work.

It fails when trying to format drive using disk utility. Using newfs to format from command, I got a Segmentation Fault and halted.


I have also put the drive in external SATA to USB box, and partition and format from my mac mini, but still fails...


Do I need a special boot disk??

Link to comment
Share on other sites


No, I tried gparted and still doesn't work.

I want to try Leo4All instead of kalyway, but can't find it...


Also, between tries, the computer gets very hot... it seems the fan is stopped.


Any other help?



Link to comment
Share on other sites

Finally, it works.

Important steps:

1. First of all, under win vista, update firmware with acer utility found here

This will correct the "hot computer because stopped fan problem". Now, it won't poweroff, and everything will work smoothly.


2. Install Leo4Allv3. This is the only version that works. With basic kernel, select GMX3100 graphics and thats all. After rebooting, system perhaps stops, or loops, just before account creation, to solve it boot in single mode with '-s' option, and use ./Options script.


3. At these step, lan/wifi neither audio, doesn't work. But, using ALC268_installer1, you'll have at least audio working.


4. Finally, what to do with WIFI or LAN? My solution, at the moment is to buy an apple mini PCI-e airport (like used in macbook pros), and change with the one is instaled. (four screws at the bottom open a tap, where you can find the mini PCI-e, and also the memory modules).


That's all at the moment...


Perhaps, you will want to have both vista and osx, then I recommend using EasyBCD, instructions here.


Good luck, and thanks for all!!!

Link to comment
Share on other sites


  • Create New...