Jump to content

Choppy Spaces performance, graphics in general

5 posts in this topic

Recommended Posts

Has anyone else experienced choppy graphics performance while using "Spaces" or generally using "Expose"? For me it manifests when I bring up the 9 Spaces I have created on my Hacki. The animation as they are rendered on the screen seems rather choppy, and same is the case for Expose. This usually sets in around 10-15 minutes after I have been working on my machine. Same is the case for Expose.


My Specs

I am running a Kalyway Combo Updated 10.5.3 on my C2D 6600 OC 3.2 GHz, 4 GB 800 MHz DDR2 RAM, 256 MB GeForce 7600GT, 3.5 TB SATA HDDs, GA P965 DS4.


What I did

I first ran into this issue in 10.5 and thought perhaps upgrading to 10.5.1 and then the graphics update to 10.5.2 would solve the issue. To my chagrin, it was all ok for the first couple of days and then the problem crept back. I updated my NVInject from ver. 0.15 to the latest, to no avail. I have now updated to 10.5.3 and have removed NVInject altogether, and am currently using the GFX String for my card. Nothing seems to help.



Conversely, in-game performance is spectacular. For instance, I have high framerates in AOE III, with everything (except the res) set to Max. I love it.


Am I being rather too fastidious? Maybe, considering there are others here who face bigger issues in their installs. It is really not a functional issue or problem, however in an otherwise perfect installation, this is the thorn sorely sticking out, and being a heavy Spaces and Expose user, really rattles my nerves.


Anyone facing similar issues, or with suggestions on how to get rid of this problem?

Link to comment
Share on other sites

I have also that issues with my system, Kalyway 10.5.3, wich is E6660, 4GB and a Nvidia 8800GT. Gaming works perfect, but not spaces / expose. It looses frames with it.


You are not alone :hysterical:

Link to comment
Share on other sites

Hi and thanks for replying. I followed Kilven's suggestion and looked the beamsync issue up. It indeed seems to do the job for the people on a forum I ran across. Yeah that's right I found more people facing the same problem.


I think I shall try it out indeed the next time my Spaces act up. Funnily enough the performance is rather fluid right now after a fresh install. I didn't install the Java Update (which some people remarked led to the graphics getting choppier. Rather weird I must remark.


Here's how to solve your problem just in case (found via another forum).

- launch quartz debug

- tick "automatic beam sync"

- force quit quartz debug

- run this command in the terminal

sudo defaults write /Library/Preferences/com.apple.windowserver Compositor -dict deferredUpdates 1
Link to comment
Share on other sites

  • 4 weeks later...

Sorry for reviving an old post. Seems my problems have vanished of late. I didn't actually implement the beamsync hack. I did however do the following:


1. I was assigning applications to specific spaces. I no longer do that

2. Java update 6 - a lot of users on apple forums reported choppiness in their expose and spaces rendering after installing this update. I would advise you to leave this update out, unless you rely extensively on the latest builds.


That's all, just these two simple solutions and I have noticed a sea change in the performance.

Link to comment
Share on other sites


  • Create New...