Jump to content
hf206

Mac OS X 10.5.4 sur portable Asus G2S avec vista en dualboot

22 posts in this topic

Recommended Posts

Bonjour,

 

J'ai découvert un peu par hazard qu'il était possible de mettre un MAC OS X sur un PC. Et aujourd'hui, je me surprens à lire des magazines Mac :angel:

 

Afin de comprendre enfin pourquoi Mac OS X attirait de plus en plus de fidèles, je me suis lancé dans une installation.

 

Voici pour information voici les caractéristiques de la machine que j'utilise pour ce test. Il s'agit n'y plus ni moins de mon laptop personnel.

 

Voici pour les détails :

 

ASUS G2S

Bios version 300 modifié

Core 2 Duo T7500 2.2 Ghz

HDD 160 Go actuellement partitionné en 3 volumes

- Partition principale 1 : Recovery Asus

- Partition principale 2 : Vista SP1 NTFS

- Partition principale 3 : espace de donnés NTFS

- Partition principale 4 : 25 Go en Fat 32

2 Go Ram

Carte graphique : Nvidia Geforce 8600M avec sortie HDMI + VGA

Carte wifi 4965 intel a/b/g/n <- Pas bon du tout ca pour Mac OS

Lan Altansic L1

Chipset PM965

Carte son ALC 882 RealTek

Webcam + micro intégré

Carte d'acquisition analogique intégré

Tuner TNT intégré

Modem 56 Motorola

eSata via controleur JMicron

Souris MX518 Logitech 5 boutons

 

Notez que ce topic peu parfaitement être utilisé par les possesseurs de portable Asus (G1S ou autres) car les caractéristiques matérielles sont trés proches

 

Sachez qu'avant d'y arriver , il m'a fallu :

 

- parcourir 3 forums (certains en Fr et d'autres en US).

- Télécharger 2 distro différentes de 10.5.2. Au final dans ce tuto nous utiliserons une Kalyway.

- patcher le bios de ma machine avec un bios "tuned" Voir lien plus bas dans ce post.

- télécharger et décompresser un boot fix : http://rapidshare.com/files/65965115/files.rar.html

- télécharger et décompresser les drivers de ma 8600m GT : http://www.mediafire.com/?mi2obzt2ont ou http://scottdangel.com/blog/?page_id=20

 

Là sans prétentions , je vous fait gagner 10h de galères.

 

Qq explications auparavant.

 

Il existe plusieurs distro (Kalyway, Leo4all,....). Le soucis au final pour sur ce type portable (asus G2S), ce n'est pas la distrib 10.5.2 -> C'est le BIOS !

 

Contrairement au bios des PC desktop sur lesquels vous pouvez faire des modifications, ici ya rien de possible. Si vous tentez de booter sur une Kalyway ou une Leo4all sans changer le bios, soit vous bloquerez au boot soit votre partition libre à votre futur Mac OS est indisponible.

 

Si vous ne préférez pas prendre le risque de flasher votre machine avec un bios modifié par un forumeur, je le comprends. Vous devez arrêter la lecture du sujet ici :(

 

Pour les autres 8) , voici la suite :

 

Tout d'abord téléchargé le bios modifié.

Vous le trouverez sur ce fourm : http://forum.insanelymac.com/index.php?act...rinter&f=2…

 

ou là : http://osrom.net/biosmod/

 

Utiliser l'outil Asus winflash sous windows pour installer votre bios "moded".

 

Suite à l'installation rebooter sous windows vista afin de valider que votre widows fonctionne toujours bien avec ce nouveau bios.

 

Assurez-vous d'avoir une partion libre pour votre trés prochain Mac OS X. Si ce n'est pas le cas. Réduisez la taille de votre dernière partition avec le gestionnaire de disque windows.

 

Ensuite il vous faut créer une partition FAT 32 PRINCIPALE à la suite de vos partoches widows. Pour cela n'espérez rien de Vista. Il vous crééra que des partions logique.

 

Utiliser un liveCD de Gparted par exemple pour créer cette partition FAT32.

 

Ue fois faite, insérer le DVD de la Kalyway 10.5.2 .

 

Au prompt, comme vous êtes en Bios modifié, plus besoin de taper quoi que ce soit. Valider par entrée.

 

@darkgold : ne m'en veux pas mais je reprends qq. passage de ton tuto :

 

Après un long script la fenêtre d'installation se lance.

 

Choisir "Utiliser le français comme langue principale" puis suivant. Dans le menu supérieur cliquer sur "Utilitaires" puis "Utilitaire de disque" ensuite cliquer sur la partition que vous avez prévu pour Mac OS puis sur l'onglet "Effacer".

 

Dans format de volume choisir "Mac OS étendu (journalisé)" et dans nom mettre le nom que vous désirez pour la partition (moi j'ai mis MAC HD) puis cliquer sur "Effacer". Fermer "l'utilitaire de disque" et continuer jusqu'au choix des partitions pour l'installation.

 

Cocher "Vanilla_Kernel" ainsi que l'ensemble des applications que vous souhaitez. N'installer pas le pilotes de votre carte graphique maintenant. Nous le ferons plus tard.

 

Terminer et lancer l'installation (si vous êtes sur de votre DVD vous pouvez ignorer la vérification).

Une fois l'installation terminé le système ne démarrera pas tout seul il faudra réaliser quelques manipulations (à noter que vous n'aurez pas accès à Windows, nous verrons comment y accéder de nouveau par la suite).

 

Rebooter sur le dvd

 

Après un long script vous arriver sur Mac OS X (le système sera en anglais pour l'instant). Répondez aux différentes questions (utilisez une password simple genre toto dans un premier temps car votre clavier est en us) et vous arrivez enfin sur le bureau.

Allez dans les préférences systèmes et mettez en francais le clavier (French windows PC).

aller dans le terminal

 

sudo -s

diskutil list

fdisk -e /dev/rdisk0 (0 correspond au disque dur ou est mac)

update

f 4 (4 correspond à la partition de mac)

w

ok? y

q

 

cd /Volumes/nom de la cle usb/files/bootfix

./dd if=/usr/standalone/i386/boot1h of=/dev/rdisk0s4 bs=512 count=1

sudo diskutil unmount /Volumes/volume_mac

./startupfiletool -v /dev/rdisk0s4 /usr/standalone/i386/boot

 

voila là ca boot sans le dvd à présent

 

Pour réactiver vista :

 

Booter le DVD

 

francais

next

reparer

command dos

 

diskpart

list disk

select disk 0

list partition

select partition 1 (1=partition VISTA)

active

 

reboot sur le dvd et là il doit réparer tout seul . Il vous faudra cliquer sur le bouton gauche de la fenetre qui s'affiche trés mal.

redémarrer

enlever le dvd pour boot sur le disque dur

Vista se lance.

 

Téléchargez (http://www.clubic.com/telecharger-fiche33420-easybcd.html ) / installez easyBCD

Faites add/remove

MAC X86

et ajouter

redémarrer et c'est bon !

 

Retourner sur Mac , nous allons installer le pilote graphique :

Copier sur le bureau le fichier "10.5.2_NVkexts+.pkg" qui est sur votre clé USB. Double-cliquez sur le fichier ensuite continuer et à la fin de l'installation il vous sera proposé de redémarrer. Vous le faite et voilà la carte graphique est reconnu et l'affichage est en 1400*900 ou 1900*1200 en fonction de la résolution native de votre dalle.

 

Edit du 26/05/2008 : Premiers constats

 

Je n'ai n'ai pas terminé le tuning de l'ensemble.

 

J'ai constaté que le PC n'est pas capable de sortir d'une veille (écran noir) si je le laisse sans le toucher. Du coup pour l'instant j'ai désactiver la mise en veille. Sur ce point j'ai vu des choses sur les forums.

 

Edit du 04/06/2008 : Mise à jour 10.5.3

 

Voici le mode opératoire à suivre :

 

- Télécharger le Kalyway 10.5.3 combo update

- installez le package comboUpdate10.5.3, ne rebootez pas

- installez le 10.5.3kernel.pkg en cochant vanilla

- réparer avec onyx

- rebootez puis F8 et update -v,ca reste bloqué un petit moment sur le texte puis ca reboot et la c'est ok.

 

Depuis cette update il y a un pbl de driver video QE.

 

Pour corriger cela faites les actions suivantes :

 

* Téléchargez le fichier NVkushInstaller.pkg.zip ( 313.03K ) http://forum.insanelymac.com/index.php?act...st&id=2872… ou là : http://diabolik1605.com/DHF/

* Dézippez et installez le package

* Supprimez le fichier "NVinject.kext" dans le dossier "Extensions"

* Redémarrez, puis à la phase de boot, tapez : -f

 

Edit du 05/06/2008 : Re-fonctionnement du driver NTFS en R/W

 

Le fait de passer en 10.5.3 dégage le pilote de paragon permettant d'accéder aux disques NTFS en R/W . Suite au passge du 10.5.3, je n'ai plus que les droits R. Il faut réinstaller à nouveau le driver paragon et ca refonctionne en R/W..

 

Edit du 06/06/2008 : La carte Ethernet Altansic L1 fonctionne trés bien.

 

Pour cela il vous faut installer le package suivant : http://forum.insanelymac.com/index.php?act...st&id=2659…

 

Installer le pilote. Redémarrer.

 

Allez dans les préférences réseaux et appliquer les changements au niveau Ethernet.

 

Edit du 17/06/2008 : La gestion de la batterie, quelle galère !

 

Bon , j'ai essayé plusieurs totu mais visiblement mes tests s'interféraient entre-eux. Voici une méthode qui fonctionne.

 

Pour cela il vous faut télécharger 3 fichiers :

 

http://osx86heb1.googlepages.com/AppleACPI...10.5.3.orig.zip

http://osx86heb1.googlepages.com/ApplePS2C...kext.10.5.3.zip

http://osx86heb1.googlepages.com/PowerManagement10.5.3.zip

 

Sauvegarder vos deux kext actuellement présent sur votre machine (AppleACPIPlatform.kext et ApplePS2Controller.kext) vers une destination de votre choix.

 

Faites de même pour le bundle présent sur votre machine PowerManagement.bundle

 

Décompressez les 3 zip. Installer le package de Powermgt.

Ensuite déplacer les 2 ktext dans /System/Library/Extensions

 

Sous un terminal taper sudo -s

 

Ensuite faites :

 

chown -R 0:0 AppleACPIPlatform.kext

chown -R 0:0 ApplePS2Controller.kext

chmod -R 755 AppleACPIPlatform.kext

chmod -R 755 AppleACPIPlatform.kext

 

Rebooter et au prompt taper : -f

 

O grand micracle , l'icône de batterie fonctionne. Le shutdown /reboot aussi.

Remarque :

Chez moi le sleep mode fonctionne mais lorsque je rallume le PC j'ai écran noir.

Le temps restant en mode batterie est incorrecte. 9mn sous MacOS et en rebootant sous VIsta 1H30 ;) Strange.

 

Edit du 23/06/2008 : La gestion de la batterie suite

 

Bonjour, comme je n'était pas satisfait de la gestion de la barre d'énergie j'ai utilisé d'autres bundle de powermanagement. Comme ca ne fonctionnait pas mieux, je suis revenu à la solution décrite dans ce topic et là oh miracle, l'affichage est bien correct. :roll:

 

Edit du 25/06/2008 : La gestion de l'heure en mode dual boot

 

Bon, vous l'aurez remarquez si vous êtes sous windows et que vous rebooter sous MacOS , le premier truc qui saute aux yeux , c'est qu'en heure d'été l'heure du Mac avance de deux heures. La raison a cela est du au référentiel de temps qui n'est pas le même.

 

Pour avoir l'heure exacte sur Mac comme vous l'aviez sous windows, installez ce package et rebooter : http://forum.insanelymac.com/index.php?act...st&id=29835

 

Edit du 08/07/2008 : Passage en 10.5.4

 

C'est super simple. Allez dans le menu pomme puis mise à jour. Télécharger la 10.5.4 et rebootez. Voilà.

 

Edit du 09/07/2008 : Ajout d'une clé USB WIFI

 

Bien qu'ayant un chipset wifi intel intégré à mon laptop, je ne suis pas en mesure de le faire fonctionner. J'ai donc du me résoudre à installer une clé USB WIFI. J'ai récupéré mon Asus 167g. Pour l'utiliser sous Mac OS , c'est trés simple. Téléchargez le pilote ci-dessous

http://www.ralinktech.com.tw/data/RTUSB%20..._2006_11_10.dmg

Installez-le et rebooter. Bancher votre clé USB et voilà.

 

Ce qui ne fonctionne pas :

Wifi Intel 4965 <- Si vous y arrivez je vous fais des bisous :D

Modem 56 k

eSATA, le controleur JBM36X de JMicron ne dispose pas de driver pour MacOS X

Webcam, malgré macam 0.9.2 et iusbcam 2.2.4

 

Fonctionne :

Sortie HDMI <- fonctionne à merveille mais étrangement ne me propose que du 1080i 50/60Hz alors que ma TV siat faire du 1080p 50/60Hz.

Son chipset Realtek ALC 882

La carte réseau Ethernet Attansic L1

La gestion d'énergie (sleep mode à moitié/ power off / reboot / icone de batterie)

 

Non testé :

Lecteur de carte

Expresscard

Sortie s-video

VGA

Prise micro

Share this post


Link to post
Share on other sites
Advertisement

Bonjour,

 

super tutorial :P

 

Je cherche depuis longtemps à installer léopard sur mon Asus M51Sn.

J'ai voulu essayer de patcher le Bios comme indiqué or winflash me dis que la taille du fichier est erroné et je peux donc pas patché :angel:

 

Comment puis je faire ?

 

Merci de votre aide

Share this post


Link to post
Share on other sites

Bonjour,J'ai mis à jour le topic en intégrant la maj 10.5.3.Bonne continuation.

Bonjour, super tutorial -_- Je cherche depuis longtemps à installer léopard sur mon Asus M51Sn.J'ai voulu essayer de patcher le Bios comme indiqué or winflash me dis que la taille du fichier est erroné et je peux donc pas patché :) Comment puis je faire ?Merci de votre aide
Attention chaque modele chez ASUS a son propre bios/ Regarde bien j'ai mis de nouveau lien dans le 1er post.

Share this post


Link to post
Share on other sites

Excellente initiative!

Félicitations à toi et bonne chance pour la suite :(

Share this post


Link to post
Share on other sites

Salut tout le monde, J'ai enfin fait fonctionner la gestion d'énergie.

 

Voir post 1.

 

J'ai mis à jour pas mal de choses.

 

SI vous y arriver mieux que moi , tenez moi au courant. ;)

Share this post


Link to post
Share on other sites

Merci pour ce tuto, tout réuni en un

Et ça fonctionne !

bon boulot, je suis de près pour voir les évolutions quotidienne :D

Sinon,pour la gestion de la batterie, j'ai le même souci, sous leo 100%, 10mn; sous vista, 100%, 2h11

Je n'ai pas eu le temps de voir si le pourcentage était juste, je fait ça dans la soirée, mais j'en doute.

A+!

Share this post


Link to post
Share on other sites
Tu peux acheter une minicarte dell si tu veux pas avoir a mettre une clé wifi ...

 

 

Qu'est ce que tu entends par minicarte dell ? Un module express card ?

 

Tu aurait un lien ?

Share this post


Link to post
Share on other sites

SUperbe topic :)

 

J'ai une question est-ce que ta carte son alc 882 fonctionne nativement?

 

J'ai un laptop asus m51sn avec la même carte son mais je n'ai pas de son il y a pourtant l'icon son dans la barre des taches.

L'ors de l'installation personnalisé j'ai coché chipset audio alc882.

Share this post


Link to post
Share on other sites

bonjour,

 

j'ai le meme pc que vous, j'ai fait pareil , l'installation ce passe bien, mais au redémarrage, je n'arrive pas à lancer mac Os X, il repart sur une seconde installation

auriez vous une solution à me proposer s'il vous plait?

j'ai suivi votre tuto à fond...mais rien, je ne comprend pas..

merci

Share this post


Link to post
Share on other sites

Tout d'abord, merci pour ton tuto !

L'installation se déroule bien, et osx est fonctionnel, j'ai suivi ton tuto à la lettre, mais j'aurais juste une question.

Tu dis que le son marche, en effet, la carte est reconnue, et le son marche sur les HP internes, mais si je branche des HP externe ou des écouteurs, là, plus rien.

Faut-il installer un autre driver, ou fallait-il cocher la case carte audio Alc882 à l'installation ?

Merci d'avance.

Share this post


Link to post
Share on other sites
Edit du 17/06/2008 : La gestion de la batterie, quelle galère !

 

Bon , j'ai essayé plusieurs totu mais visiblement mes tests s'interféraient entre-eux. Voici une méthode qui fonctionne.

 

Pour cela il vous faut télécharger 3 fichiers :

 

http://osx86heb1.googlepages.com/AppleACPI...10.5.3.orig.zip

http://osx86heb1.googlepages.com/ApplePS2C...kext.10.5.3.zip

http://osx86heb1.googlepages.com/PowerManagement10.5.3.zip

 

Sauvegarder vos deux kext actuellement présent sur votre machine (AppleACPIPlatform.kext et ApplePS2Controller.kext) vers une destination de votre choix.

 

Faites de même pour le bundle présent sur votre machine PowerManagement.bundle

 

Décompressez les 3 zip. Installer le package de Powermgt.

Ensuite déplacer les 2 ktext dans /System/Library/Extensions

 

Sous un terminal taper sudo -s

 

Ensuite faites :

 

chown -R 0:0 AppleACPIPlatform.kext

chown -R 0:0 ApplePS2Controller.kext

chmod -R 755 AppleACPIPlatform.kext

chmod -R 755 AppleACPIPlatform.kext

 

Rebooter et au prompt taper : -f

 

O grand micracle , l'icône de batterie fonctionne. Le shutdown /reboot aussi.

Remarque :

Chez moi le sleep mode fonctionne mais lorsque je rallume le PC j'ai écran noir.

Le temps restant en mode batterie est incorrecte. 9mn sous MacOS et en rebootant sous VIsta 1H30 :) Strange.

 

salut, merci pour ton topic, il m'a bien aidé à demarrer mon install de macOS sur un G2s, parcontre j'ai un souci imprevu, tt fonctionnait plutot bien, jusqu'au moment ou je me suis occupé de la gestion d'energie et que j'ai suivi le tuto en quote.

depuis pour demarrer mon os il faut à chaque fois que je boot en -f ( plutot galere ) sinon j'ai un blocage du kernel, une idée d'où cela peut provenir et surtt comment y remedier ( je cherche aussi, je posterais la solution )

 

pour aider : je suis sous kaliway 10.5.2 et mon kenel est un darwin 9.2.0

 

edit +15 min :

j'ai resulu le souci en installant le packaging trouvé ici :

http://apple2pc.blogspot.com/2008/06/power...nt-on-1053.html

l'icone de batterie fonctionne correctement, le timer aussi ( charge / decharge )

shutdown : partiellement, part moment ne s'eteind plus s'il est longtemp allumé, le fait depuis le debut, la dale s'eteind, disque dur aussi, pas de le lecteur dvd, reste sous tention obligé de l'eteindre à l'arrash avec le bouton power :)

reboot : ok

sleep : nok, je cherche tjs une solution d'hibernate correct.

je continue de chercher qlq option d'opitimisation de l'energie, le G2s est gourmand en energie, je voudrais bien bien gagner en autonomie..

Share this post


Link to post
Share on other sites

Regarder dans la section tuto ou cliquez dans ma signature, il y a des explications pour le G2 concernant la batterie et le speedstep. Car en effet certains trucs le font planter.

Share this post


Link to post
Share on other sites

salut,

bon bah je fais de pire en pire.

tt fonctionnait plutot bien sauf l'extinction et le sleep ( wifi, bt etc mais c'est pas important )

 

j'ai pas trouvé qlq chose qui réussissait à me convaincre d'etre sur de la methode, j'ai donc decité de faire une sauvegarde Timemachine et une image, les deux sur deux disque separé.

 

je fais mon bidouillage et kaboum, kernel panic à tt de champs, impossible de faire quoi que ce soit..

 

bon, ok pas de souci j'ai mes sauvegardes, pour Timemachine, on oublie le system de fonctionnant pas, c'est pas viable.

Alors je boot sur le cd, comme pour une install, je dump depuis l'image que j'ai créé.

il a fallu que j'efface le disque, je le reformat, et que je fasse une verif de l'image avant que cela ne fonctionne.

depuis que j'ai redump l'image tt refonctionn comme avant à une chose pres, ça ne boot pas sans le cd.

j'ai beau repatché ( inutile normalement vu que c'etait deja fais )

suivre les tuto avec les boot fix que l'on trouve sur ce topic ici ou la

rien y fait.

si je boot sans le cd, j'ai un kernel panic juste apres le choix des options de darwin

si je boot avec le cd, ça fonctionne niquel ( sauf pas d'extinction ou de sleep )

 

ça fait depuis 2h ce matin que je cherche et que j'essais, j'avoue que la je sais plus ..

Share this post


Link to post
Share on other sites

Non mais laisse tomber Kalyway ! c'est trop obsolete pour cette bécane. Passe a une version plus recente telle que iDeneb ou XxX

Share this post


Link to post
Share on other sites
Non mais laisse tomber Kalyway ! c'est trop obsolete pour cette bécane. Passe a une version plus recente telle que iDeneb ou XxX

 

ça m'aide pas des masses sur le souci d'origine ...

j'aimerais plutot comprendre pourquoi est ce que ça plante sans le cd alors qu'avec ça fonctionne à merveille.

Share this post


Link to post
Share on other sites

parceque ton patch pour le boot est mal installé ou alors ta partition Mac n'est pas active.

Si tu tiens a rester avec cette version, met ta partition en active et installe chameleon

Share this post


Link to post
Share on other sites
parceque ton patch pour le boot est mal installé ou alors ta partition Mac n'est pas active.

Si tu tiens a rester avec cette version, met ta partition en active et installe chameleon

 

je suis en train de telechargé la version IPC 10.5.6, j'ai un peu peur que ce ne soit pas compatible avec mon bios comme j'ai pu le voir sur certain topic, on vera.

 

à la base je voulais macos sur un SONY ux380n, mais trop difficile pour debuter, et depuis que c'est sur l'autre j'suis accroc ! :D

 

je vais testé le coup de chameleon, mais la partition est bien active, et "theoriquement" le system est patché vu que c'est une image qui bootait bien.

 

je me demande si desfois il n'y aurait pas une incopatibilité entre la 10.5.2 et OpenHaltRestart_1.0.3.kext ce qui m'entraine un kernel panic au boot..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×