Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
sama7896

Can kismus hackintosh tools be written on a usb drive and how ?

5 posts in this topic

Recommended Posts

Hi !

i found some topics on how to set a usb drive bootable as follows :

 

-partition drive as mbr, so it can be seen on a system without darwin (found some opinions it should be guid), enable owner with

sudo /usr/sbin/vsdbutil -a /Volumes/osx86

- mount kismus

cp -R /volumes/kismushackintoshtools/* /volumes/osx86/

- bless usb (although i did not find any bootefi file inside) with

sudo bless –verbose –folder “/Volumes/osx86/System/Library/CoreServices” –bootinfo

-repair permissions on the usb drive ( drink a coffee or two)

 

But the problem is that it does not boot. On bios the usb device is recognized as 1st floppy device (! i have no floppy or ide devices) but does not boot. Tried on 3 devices without succes.

 

Can anybody guide me where i have failed ? Is it even possible ?

Share this post


Link to post
Share on other sites

Grab a copy of startupfiletool

with diskutility.app figure out where the USB is mounted (disk0, or disk1, etc)

 

1) Update MBR bootloader and flag as bootable:

sudo fdisk -e /dev/rdiskX <<<HERE YOU MUST REPLACE 'X' with your USB stick mounting point

fdisk: 1> update

Machine code updated.

fdisk:*1> f 1

Partition 1 marked active.

fdisk:*1> w

Device could not be accessed exclusively.

A reboot will be needed for changes to take effect. OK? [n] y

Writing MBR at offset 0.

fdisk: 1> q

 

2) put boot1h at the beginning of the partition:

sudo dd if=/usr/standalone/i386/boot1h of=/dev/rdiskXs1 bs=512 count=1

 

3)

copy the startupfiletool to /usr/sbin first,

unmount the usb stick, and then you execute the command.

run startupfiletool:

sudo startupfiletool -v /dev/rdiskXs1 /usr/standalone/i386/boot

 

4) bless the partition:

sudo bless -device /dev/diskXs1 -setBoot -verbose

 

This works for Hard disks; I think it should work for USB sticks too.

Share this post


Link to post
Share on other sites

Could not succeed. This is a copy of the terminal output:

bash-3.2# sudo dd if=/usr/standalone/i386/boot1h of=/dev/rdisk2s1 bs=512 count=1

1+0 records in

1+0 records out

512 bytes transferred in 0.020849 secs (24558 bytes/sec)

bash-3.2# cd /users/User/desktop/

bash-3.2# sudo startupfiletool -v /dev/rdisk2s1 /usr/standalone/i386/boot

sudo: startupfiletool: command not found

bash-3.2# ./startupfiletool -v /dev/rdisk2s1 /usr/standalone/i386/boot

HFS+ filesystem detected

Looking for 1 words free

reading 4096,4096

Marking word 193

writing back 4096,4096

allocated blocks 32 at start 6176

bash-3.2# sudo bless --device /dev/disk2s1 --setBoot --verbose

EFI found at IODeviceTree:/efi

Other partition scheme detected

No auxiliary booter partition required

Returning booter information dictionary:

<CFDictionary 0x109500 [0xa037d1a0]>{type = mutable, count = 3, capacity = 3, pairs = (

0 : <CFString 0x18db0 [0xa037d1a0]>{contents = "Auxiliary Partitions"} = <CFArray 0x103a50 [0xa037d1a0]>{type = immutable, count = 0, values = (

)}

2 : <CFString 0x18da0 [0xa037d1a0]>{contents = "Data Partitions"} = <CFArray 0x109620 [0xa037d1a0]>{type = immutable, count = 1, values = (

0 : <CFString 0x109660 [0xa037d1a0]>{contents = "disk2s1"}

)}

3 : <CFString 0x18dc0 [0xa037d1a0]>{contents = "System Partitions"} = <CFArray 0x1090c0 [0xa037d1a0]>{type = immutable, count = 0, values = (

)}

)}

IOMedia disk2s1 does not have a partition UUID

DADiskRef disk2s1 has Volume UUID 5BE7B085-8880-340E-AC40-3745AE11915A

IOMedia disk2s1 has path IODeviceTree:/PCI0@0/EUSB@1D,7/@2:1

Setting EFI NVRAM:

efi-boot-device='<array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPathMatch</key><string>IODeviceTree:/PCI0@0/EUSB@1D,7/@2:1</string></dict><key>BLVolumeUUID</key><string>5BE7B085-8880-340E-AC40-3745AE11915A</string><key>BLLastBSDName</key><string>disk2s1</string></dict></array>'

Could not set boot device property: 0xe00002c7

what is it i'm doing wrong ? Perhaps the fact the kismus hackintosh tools is actually a modified installDVD is the problem ?

Share this post


Link to post
Share on other sites

It looks nothing is wrong. Try to use boot0 instead of boot1h in this line:

 

sudo dd if=/usr/standalone/i386/boot1h of=/dev/rdisk2s1 bs=512 count=1

 

I use this method when I make my install DVDs: for testing is much faster to boot the installer from a HD than from a DVD. Also you dont have to reburn discs everytime you fix some bug.

But as I said before, I've tryed this on HD not on usb sticks....

Share this post


Link to post
Share on other sites

Just a note, to help others if not you (I know it's been a month):

 

I was getting the same error, then realised it was the version of bless. There's the vanilla one in usr/sbin in Mac installs and DVDs, BUT there's the patched one that comes with the EFI files.

 

So, you need to be in the dir where the EFI patch is and do: sudo ./bless -device /dev/disk2s1 -setBoot -verbose

 

Note the ./ before bless, that'll use the local one, as opposed to the Apple one in the system.

 

Hope that helps. :thumbsup_anim::2cents:

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×