Jump to content

Can't boot to OS X partition


5 posts in this topic

Recommended Posts

Hello all. I started off by using Partiiton Magic on my Windows partition to create a small (~50gb) partition for OS X (10.5.1). It was an NTFS partition. I booted up the installer, erased the NTFS partiton and made it Mac Extended, then installed. Went fine, but when I boot up, it goes right into Windows. In my Partition Magic, the option to set the OS X partition to active is grayed out. I then booted up my OS X DVD with -s and typed in


fdisk -e /dev/rdisk0

flag x (tried x=1 through x=5, rebooted after each attempt and still no OS X :thumbsup_anim:)




Like I said, I tried making partitions 1-5 active, which really confused me because I have only 2 partitions. Anything other than 1-5 gave me an invalid partition number, but 1-5 worked each time. I installed Acronis Boot Selector and my Windows showed up plus an Unkown Operating System, which I assumed to be my OS X installation. When I selected that option, I got an "HFS+ Partition Error"


Any help would be awesome, and thank you.

Link to comment
Share on other sites

I've run into this before personally.


My conclusion: Acronis isn't great.


I believe the HFS+ error is to do with an error of the Darwin bootloader.


Did you install EFI/Darwin bootloader at install?


XP can remain active, as it is needed to boot the OS. But Mac OS, at least in my system, hasn't required an "Active" flag to successfully boot.


I would suggest reinstalling Mac OS and making sure to install the bootloader. Given that you can use the Darwin bootloader to boot XP, you should focus on making OS X boot.


In my tri-boot system, I use GRUB as a boot manager. I installed XP then Mac OS X then Ubuntu with GRUB. And tada. Chronic success.

Link to comment
Share on other sites


  • Create New...