Jump to content

Kernel, smbios, Efi Studio (video audio y red)


111 posts in this topic

Recommended Posts

CODIGO PARA EL com.apple.Boot.plist:

0400000000000100020000000000000000000000

texto NVCAP:

BAAAAAAAAgANAAAAAAAABwAAAAA=

 

y para lo del apagado pues no lo apago, lo dejo en sleep asi el pc responde para regresar cuando se lo indique...

 

El codigo que pones no va en com.appleBoot.plist, sino en el Info.plist que esta dentro del injector.

Y tienes que poner solo 1 de las que nombras (o numeros o letras, pero no ambas)

Gracias a todos por la ayuda! especialmente a derty, Macoff y Xxp/TuX

 

No me aparece asi! solo el xml en la parte de arriba, no entiendo que estoy haciendo mal!

 

Lo que hago es lo siguiente: abrir el efi studio, dejo en el menu device y abajo busco mi modelo de tarjeta. Luego le doy a add device y me aparece la nueva ventana con el xml arriba y ahora si me aparecio abajo jajaja, pero las otras veces no! no se si es un problema con el programa o algo particular en mi configuracion.

 

La pregunta ahora es, para colocar ambas cadenas en el com.apple.boot.plist concateno ambas cadenas y las coloco de la siguiente manera:

 

<key>device-properties</key>

<string>cadenas concatenadas</string>

 

O las coloco de esta otra forma?

 

<key>device-properties</key>

<string>cadena video</string>

<key>device-properties</key>

<string>cadena alc850</string>

 

Otra cosa, una vez que coloque estas cadenas que cambios debe hacer en las extensiones del sistema? cuales tengo que eliminar? Igual tengo que instalar el package que me pones en tu post derty?

 

Gracias de nuevo!

ok creo que me explique mal, el primero que son solo numeros es el string para los que utilizan strings en el com.apple.Boot.plist, el otro que si tiene letras y termina con un "=" es el nvcap que se coloca justo en el plist del kext nvinject, ahora para hacer esto arriba de estos comentarios xXp/Tux y Derty explican muy bien como hacerlo

Gracias a todos por la ayuda! especialmente a derty, Macoff y Xxp/TuX

 

No me aparece asi! solo el xml en la parte de arriba, no entiendo que estoy haciendo mal!

 

Lo que hago es lo siguiente: abrir el efi studio, dejo en el menu device y abajo busco mi modelo de tarjeta. Luego le doy a add device y me aparece la nueva ventana con el xml arriba y ahora si me aparecio abajo jajaja, pero las otras veces no! no se si es un problema con el programa o algo particular en mi configuracion.

 

La pregunta ahora es, para colocar ambas cadenas en el com.apple.boot.plist concateno ambas cadenas y las coloco de la siguiente manera:

 

device-properties

cadenas concatenadas

 

O las coloco de esta otra forma?

 

device-properties

cadena video

device-properties

cadena alc850

 

Otra cosa, una vez que coloque estas cadenas que cambios debe hacer en las extensiones del sistema? cuales tengo que eliminar? Igual tengo que instalar el package que me pones en tu post derty?

 

Gracias de nuevo!

 

Las 'strings' van en la .com.apple.boot.plist (todas).Cuando vas a agregar mas de un dispositivo,no van concatenadas,sino que debes seguir el esquema que tiene macgirl en la lista que muestra

 

ok creo que me explique mal, el primero que son solo numeros es el string para los que utilizan strings en el com.apple.Boot.plist, el otro que si tiene letras y termina con un "=" es el nvcap que se coloca justo en el plist del kext nvinject, ahora para hacer esto arriba de estos comentarios xXp/Tux y Derty explican muy bien como hacerlo

 

A ver si me explico...Las 'strings' o cadenas van en la .com.apple.boot.plist siempre.El valor de NVCAP lo utilizas en los casos siguientes:

1) En el injector NVinject o NVinjectGo (si no vas a usar GFX Strings)

2) En la template que utiliza el programa gfxutil o EFI Studio para generarte la string o cadena que va en la .com.apple.boot.plist

Gracias a los dos por la dedicación con la que me explicaron!

 

Ya logré construir ambas cadenas para usarlas con efi (en com.apple.boot.plist). Pero me he dado cuenta que tengo otro problema y parece ser referente al video: a veces el mouse se congela, la hora en la pantalla tambien y luego, después de 10 15 seg quizás, los segundos comienzan a avanzar de nuevo y finalmente regresa el movimiento del mouse. Saben a que se puede deber eso y como se soluciona?

P.D. TuX, sería bueno que hubiera un Tutorial, o al menos una definición concreta de las Strings en el Foro, ya que la información no está bien estructurada... o no hay un post específico para ello...

 

Si.Lo voy a hacer...Este no es un hilo dedicado a EFI Studio (aunque está relacionado).

 

Gracias a los dos por la dedicación con la que me explicaron!

 

Ya logré construir ambas cadenas para usarlas con efi (en com.apple.boot.plist). Pero me he dado cuenta que tengo otro problema y parece ser referente al video: a veces el mouse se congela, la hora en la pantalla tambien y luego, después de 10 15 seg quizás, los segundos comienzan a avanzar de nuevo y finalmente regresa el movimiento del mouse. Saben a que se puede deber eso y como se soluciona?

 

¿Ya el video está por 'strings'?

Si, el video ya está por 'strings'. De todas formas no se que tan cierto sea, pero supuestamente usar video por injectores y por strings, a nivel de estabilidad y rendimiento es igual, con la diferencia que no necesitas un kernel extension como nvinject o titan.

 

Hize una prueba usando nvinject y el video string con efi. En ambos casos ocurrió el problema del congelamiento.

si freeza el escritorio es lo que dice hecabe tal vez, puede ser una incompatibilidad entre el sistema smart y tu disco , o alguna parte de tu hardware no va bien o no esta bien soportado, entonces el micro y el ICH se quedan esperando respuesta y de ahi que queda todo bloqueado.

 

pobre hecabe nadie le responde, sera que no tenemos ni hueva de idea..... :(

Gracias por las respuestas!

 

Yo ya tenía la opción 'Dormir discos duros cuando sea posible' deshabilitada, por lo que me voy por la segunda opción que me comentan. Pienso que lo mas probable es que sea un problema con el smart, porque a pesar que el bios de la máquina me dice que el disco duro 2 está bien (smart status ok), el everest en windows me dice que hay problemas con el smart de ese disco!

 

Gracias de nuevo!

el modem usb no me reconocio en leopard :thumbsup_anim:

 

 

por otro lado quiero instalar el video mediante string

alguien que tenga una 8600m gt y stac9228 que me ayude

salud-II

 

 

pd: si uso los strings ya no nesesitare usar el nvinject por lo que aora se podra reinicar o apagar mi notebook ¿¿¿¿

 

 

bye..

una pregunta...

 

Cuando mi pc entra en sleep y despues de un rato lo despierto, ( para ponerlo en sleep, primero cierro sesion, costumbres mias :P ), aparece kernel panic y no puedo recuperar el pc, amenos de que forzee el apagado de este... alguna idea?

 

PTT: esto casi nunca aparece pero ultimamente me di cuenta que esta pasando frecuentemente....

 

tengo 10.5.4 con vanilla 9.4 :P

 

GRACIAS POR LA AYUDA

el modem usb no me reconocio en leopard :P

 

 

por otro lado quiero instalar el video mediante string

alguien que tenga una 8600m gt y stac9228 que me ayude

salud-II

 

 

pd: si uso los strings ya no nesesitare usar el nvinject por lo que aora se podra reinicar o apagar mi notebook ¿¿¿¿

 

 

bye..

 

El EFI studio trae unas cuantas tarjetas de video para la cual colocar sus 'strings'

 

http://forum.insanelymac.com/index.php?showtopic=102868

 

Al igual que audio y red.

 

Es una 'automatización' amigable de colocarlas.Fíjate como hacerlo de forma manual (en caso de que el EFI Studio no posea el modelo de gráfica que quieres o tengas problemas)

 

http://forum.insanelymac.com/index.php?showtopic=118990

 

Si tienes audio con Azalia o con algún patch de Taruga,es posible hacerlo de forma manual (lo de crear la 'string')

 

Si,es cierto lo del video:debes eliminar todo injector que estés usando,pero creo que ese problema está mas relacionado con algunas extensiones Nvidia.Tambien si usas el kernel vanilla.Si mal no recuerdo,algunos resolvían esos detalles con algunas Nvidia's .kext de versiones previas de 10.5.x (Ejemplo,de 10.5.1)

 

No sé si será necesario actualizar la guía para colocar las 'strings' de forma manual para que abarque tambien audio y red...

acabo de echar al perder el com.apple.Boot.plist nose como recuperarlo o instalarlo de nuevo :blink: leopard ya no me parte incluso intente con “./efigfxrestore.sh” y nada murio mi osx .. tendre que intalar todo de nuevo x laa shet :(

 

salud-II

 

 

acabo de echar al perder el com.apple.Boot.plist nose como recuperarlo o instalarlo de nuevo :( leopard ya no me parte incluso intente con “./efigfxrestore.sh” y nada murio mi osx .. tendre que intalar todo de nuevo x laa shet :(

 

salud-II

 

 

 

edit : lo solucione con el programa para windows macdrive (exelnte programa)

 

crea un archivo txt

 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>Boot Graphics</key>

<string>Yes</string>

<key>Kernel</key>

<string>mach_kernel</string>

<key>Kernel Flags</key>

<string>-f</string>

</dict>

</plist>

 

 

guardar como com.apple.Boot.plist y meterlo en la carpeta /Library/Preverences/System Configuration/ y remplasarlo

 

 

salud-II

una pregunta...

 

Cuando mi pc entra en sleep y despues de un rato lo despierto, ( para ponerlo en sleep, primero cierro sesion, costumbres mias :) ), aparece kernel panic y no puedo recuperar el pc, amenos de que forzee el apagado de este... alguna idea?

 

PTT: esto casi nunca aparece pero ultimamente me di cuenta que esta pasando frecuentemente....

 

tengo 10.5.4 con vanilla 9.4 ;)

 

GRACIAS POR LA AYUDA

 

alguien puede ayudarme con esto porfavor?, estare muy agradecido

:hysterical: Una preguntota, haber si me pueden aclarar lo que me paso. Tengo Kalyway 10.5.3 con kernel Vanilla 9.3; todo bien cuando la actulize con el comboupdate de Kaly, se apagaba bien y luego de instalar office 2008 y CandyBar ya no se apaga automaticamente le tengo que forzar con el clasico botonaso, no se que paso, habra algo para corregir esto o ver cual es el verdadero problema que causo esto, o ver si actualizando a 10.5.4 con el procedimiento de Schweppes se podria arreglar. Agradeceria mucho su atencion hacia un compa mexicano. :lol:
  • 2 weeks later...

Amigos, estoy empezando en el interesante mundo del osx86 y me surgen un par de dudas:

Instale osx 10.5.2 Leo4allv2 con el kernel ToH 9.2.2.

Mi laptop es un HP530 Coreduo T2050, 2gb ddr 667, me funciona casi todo (menos la wireless), el punto es que quiero cambiar de Kernel por el vanilla que creo es mas compatible con intel, dado que con el de ToH no me funcionan los 2 cores.

La pregunta puntualmente es: ¿con OSX86 Tools, cambio nomas el kernel o necesito hacer algo mas?, no se que es smbios y no se si lo tenga instalado.

Gracias

La pregunta puntualmente es: ¿con OSX86 Tools, cambio nomas el kernel o necesito hacer algo mas?, no se que es smbios y no se si lo tenga instalado.

Gracias

Bienvenid@ al foro kalmira4

Sí,con OSx86 Tools puedes colocar el kernel vanilla.Al mismo tiempo,la aplicación te hará un respaldo del actual (según comentas,el el kernel de ToH 9.2.2).Es sencillo ya que pregunta al usuario lo necesario a medida que avanza.

Si quieres cambiar el kernel solamente,pues hazlo así.Tan sencillo como eso...Cambiar un kernel no necesita algún extra para funcionar si te es compatible.

 

El SMBIOS o 'AppleSMBIOS.kext' es una extensión del kernel.A 'grosso modo',informa al sistema el hardware que posee tu PC (tus memorias,frecuencia de las memorias,información del sistema,etc).Si en tu Perfil de Sistema aparece información errónea (por ejemplo,si la frecuencia de tus memorias es de 800Mhz pero te aparece otro valor) es buena idea cambiarlo.Si no,no lo hagas.'AppleSMBIOS.kext' es una extensión (.kext)

 

De si la tienes instalada seguro que sí:compruébalo por tí mism@ yendo a la ruta

/System/Library/Extensions

aqua-mac realiza un gfx para la 9800 GTX dual 512

 

http://forum.insanelymac.com/index.php?showtopic=101121

 

y vean las fotos de su maquina, alucina, jajaja

 

http://forum.insanelymac.com/index.php?sho...1121&st=40#

 

Aquí se aprecia mejor (I am sorry,pero hay que colocarlo)

 

http://forum.insanelymac.com/index.php?sho...mp;#entry821769

 

 

string

 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0)</key>

<dict>

<key>@0,compatible</key>

<string>NVDA,NVMac</string>

<key>@0,device_type</key>

<string>display</string>

<key>@0,name</key>

<string>NVDA,Display-A</string>

<key>@1,compatible</key>

<string>NVDA,NVMac</string>

<key>@1,device_type</key>

<string>display</string>

<key>@1,name</key>

<string>NVDA,Display-B</string>

<key>@2,#adress-cells</key>

<string>0x01000000</string>

<key>@2,#size-cells</key>

<string>0x00000000</string>

<key>@2,compatible</key>

<string>NVDA,sensor-parent</string>

<key>@2,device_type</key>

<string>NVDA,gpu-diode</string>

<key>@2,hwctrl-params-version</key>

<string>0x02000000</string>

<key>@2,hwsensor-params-version</key>

<string>0x02000000</string>

<key>@2,name</key>

<string>sensor-parent</string>

<key>@2,reg</key>

<string>0x02000000</string>

<key>NVCAP</key>

<data>

BAAAAAAAAwAMAAAAAAAABwAAAAA=

</data>

<key>NVPM</key>

<data>

AQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA==

</data>

<key>VRAM,totalsize</key>

<data>

AAAAIA==

</data>

<key>device_type</key>

<string>NVDA,GeForce</string>

<key>model</key>

<string>NVIDIA GeForce 9800 GTX DDL</string>

<key>name</key>

<string>NVDA,Parent</string>

<key>rom-revision</key>

<string>3172a</string>

</dict>

<key>PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)</key>

<dict>

<key>@0,compatible</key>

<string>NVDA,NVMac</string>

<key>@0,device_type</key>

<string>display</string>

<key>@0,name</key>

<string>NVDA,Display-A</string>

<key>@1,compatible</key>

<string>NVDA,NVMac</string>

<key>@1,device_type</key>

<string>display</string>

<key>@1,name</key>

<string>NVDA,Display-B</string>

<key>@2,#adress-cells</key>

<string>0x01000000</string>

<key>@2,#size-cells</key>

<string>0x00000000</string>

<key>@2,compatible</key>

<string>NVDA,sensor-parent</string>

<key>@2,device_type</key>

<string>NVDA,gpu-diode</string>

<key>@2,hwctrl-params-version</key>

<string>0x02000000</string>

<key>@2,hwsensor-params-version</key>

<string>0x02000000</string>

<key>@2,name</key>

<string>sensor-parent</string>

<key>@2,reg</key>

<string>0x02000000</string>

<key>NVCAP</key>

<data>

BAAAAAAAAwAMAAAAAAAABwAAAAA=

</data>

<key>NVPM</key>

<data>

AQAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA==

</data>

<key>VRAM,totalsize</key>

<data>

AAAAIA==

</data>

<key>device_type</key>

<string>NVDA,GeForce</string>

<key>model</key>

<string>NVIDIA GeForce 9800 GTX DDL</string>

<key>name</key>

<string>NVDA,Parent</string>

<key>rom-revision</key>

<string>3172a</string>

</dict>

</dict>

</plist>

  • 4 weeks later...
×
×
  • Create New...