Jump to content

Dual Booting Problems


6 posts in this topic

Recommended Posts



I got Kalyway installed on the second partition of my hard drive (Vista's on the first), but I can't get it to dual boot.


Basically, I installed Kalyway using EFI_MBR and it booted fine. I needed to get back into Vista, so I marked the first (Vista) partition as bootable, but Vista said winload.exe was missing. I started up my Vista install CD, chose repair, and "Yay!" now Vista is booting again.


I read that I needed EasyBCD, so I installed it, added an entry for Mac OS X, rebooted, and got an HFS+ Partition Error when I selected Mac OS X.


Next, I tried booting via a chain0 file instead of the default EasyBCD one, HFS+ Partition Error.


Finally, I installed Gentoo+Grub on a third partition, added an entry for efi boot_v8 according to [How to] Boot OS X from grub using PC_efi - InsanelyMac Forum and I get com.apple.boot.plist not found (no matter which harddrive I choose, even one I don't have). If I hold F8, though, I can use the darwin bootloader to choose whether to boot into Vista or Mac (though for some reason both partitions are identified as Vista). When I choose the Mac partition from the Darwin bootloader, I get, you guessed it...


HFS+ Partition Error


What am I doing wrong?!


Thanks a mucho,


Link to comment
Share on other sites

Macshiba - Sorry, forgot about that, that was actually one of the first things I tried. Wouldn't you know it, it gives an HFS+ Partition Error.


prairidog - I tried the repair (nothing seemed to happen when I ran it, but that might be how it works), grub still gives HFS+ Partition Error, the Vista bootloader now gives Chain Booting Error (not sure if that was the error before instead of HFS+ Partition Error, actually).


Thanks for the help guys.

Link to comment
Share on other sites


  • Create New...