Jump to content

Kernel Panic during boot after NVinject install


9 posts in this topic

Recommended Posts

So after a long and arduous journey to get my vostro 1500 up and running (MBR nightmare), I tried to install the graphics driver for NVidia cards and it comes back with a Kernel Panic.


So exactly what happened:

installed NVinject, said to restart

I restart gets to grey apple and says I have to restart (kernel Panic)

I boot in safe mode "-x" and it starts once, I am relieved that it may work.. I restart and it has the same problem and won't boot in "-x"

I read a lot online and the only thing I come up with is booting with the command "old_kernel", which works perfectly - with the graphics driver installed.

I try to find out how to restore the kernel and came up empty handed.


I am really new to this whole thing and have never really had to troubleshoot OS X before, so the commands are a little non-intuitive.


I don't even know how to unistall the NVinject pack I installed...


Let me know your thoughts.



Link to comment
Share on other sites

Having the same issue here..


I tried your suggestion, PlayingKarrde, but I tried booting in -v and it stopped at


"AppleNForceATA: NVIDIA nForce MCP 51 by MeDevil (CMD 0x1f0, CTR 0x3f4, IRQ 14, BM 0x3080)"


Tried booting with -v and -F and it stops at


"wl0: Broadcom BCM4311 802.11 Wireless Controller" <- this line is directly below the "AppleNForceATA" one.


I'll try booting using the "old_kernel" now. :D


Edit: "old_kernel" method didn't work for me. Left me at the same "AppleNForceATA" line.


Erasing the partition and starting over feels more tempting now! >:)

Link to comment
Share on other sites

I can't boot in '-s', it hangs at the same point as in '-v'. The error doesn't say anything about an nvidia controller error. I think the error is related to the shutdown update/fix that comes with the latest version of NVinject. I think the error says something about intel. I need to look at it again but it looks like a driver that is supposed to control the processor is hanging on boot. The old kernel seems to not have this problem.


The only way I can boot is with the old_kernel, a backup in the root dir, but I can't boot to remove mach_kernel and replace it with old_kernel. If I boot old_kernel I can't modify it. Seems like I might be stuck. Any thoughts on how to copy over the file?


I have a vostro 1500 for those who want to know. The shutdown doesn't work, or sound (yet), and I had to re-write the MBR to get past a HFS+ partition error on boot.


I will try to play around with '-f', maybe that will help.


Does anyone know a way to boot the old kernel with a '-s' parameter?

Link to comment
Share on other sites

Since the "default" kernel is mach_kernel, you can rename old_kernel this and boot as if you entered old_kernel at boot.


Make sense?


Like this:


Boot with old_kernel


Backup mach_kernel

cp mach_kernel mach_kernel.backup


Remove it.

sudo rm mach_kernel


Make old_kernel mach_kernel

sudo cp old_kernel mach_kernel


Now old_kernel and mach_kernel are the same, and mach_kernel is mach_kernel.backup.


Repair permissions to keep things happy.

diskutil repairpermissions /


There are more succinct ways of doing this, but separating out the commands tends to help noobitis.


If this doesn't work, you are still OK to boot with old_kernel as we have maintained the file here. The backup of mach_kernel will also help in the event of trouble.


If you ever are unable to boot in single-user mode (-s), you can always boot to the install disc and use Terminal from there. Your hard drive is located under /Volumes/[Volume Name] in this method.


As a rule of thumb, I never use any NVInject or similar graphics driver installer. Doing it manually ensures you know which files are modified and makes it easier to "Reverse" any ill effects.

Link to comment
Share on other sites

I broke down and reinstalled. I know, for shame. I reinstalled the NVinject but left off the kernel patch and everything was great. Even got some sound working.


I was able to boot into single user mode (-s) using the old_kernel, but when I got there I didn't know my unix well enough anymore to copy/replace/find the needed files. It has been a while.


I realized that I didn't really have that much to lose in re-installing.


On a sidenote, why does it say it only takes 5 gigs to install and then it takes almost 10GB when you boot it? Is there a problem with my install or does the OS create a large swap file or other operating file when it boots? I put it on a 10GB partition on my laptop and now I only have like 700MB free.

Link to comment
Share on other sites


  • Create New...