Jump to content

[Guide] XPS M1710 OS X Leopard

- - - - -

  • Please log in to reply
118 replies to this topic

#101
Marucins

Marucins

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:PL [Bia]
Hi

My XPS M1710 with GeForce Go 7950GTX 5120 MB he can not to run with the full hardware acceleration.

I check NVinject 0.2.1 512MB / NVinjectGO 512MB - nothing.

GeForce Go 7950 GTX:
	
	  Chipset Model:   GeForce Go 7950 GTX
	  Type:   Display
	  Bus:   PCIe
	  PCIe Lane Width:   x16
	  VRAM (Total):   512 MB
	  Vendor:   NVIDIA (0x10de)
	  Device ID:   0x0297
	  Revision ID:   0x00a1
	  ROM Revision:   NVinject 0.2.1
	  Displays:
	Display Connector:
	  Status:   No display connected
	Display:
	  Resolution:   1920 x 1200
	  Depth:   32-bit Color
	  Core Image:   Software
	  Main Display:   Yes
	  Mirror:   Off
	  Online:   Yes
	  Quartz Extreme:   Not Supported

When I start on full screen - MEGA LAGS, next i download "MonsterTrucksNitro_DEMO_v120" on apple site - ULTRA MEGA LAG


What has to do?
How I can install correct driver?

#102
akirasee

akirasee

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
same laptop as yours, i found a driver for it, but no sound at all, however i was able to use the sound buttons

#103
bomoogo

bomoogo

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
if you use an extern monitor it may work with QE. But i havent tested it yet.
Unfortunatly nobody cares about the geforce 7 to make it working they all say Geforce 9 or 8. -.-
The lags can be maybe solved if you deaktivate 1 core in Bios.

#104
Devil_Jin

Devil_Jin

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hi guys, I just installed the 10.5.7 update, the patched kernel for core duo and everything is working fine (except for the wi-fi), with just some small issues with the sigmatel 9200 (always the same: mute doesn't work, headphones+speakers, but at least the SPDIF out was detected) and I finally got the broadcom 5752 to work (yeah, I'm using safari now :whistle: )!
Should we update this guide?

#105
thomaske

thomaske

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
you serious? :) tell us XD

#106
Devil_Jin

Devil_Jin

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Sorry, I'm quite busy in this period, however, just use the attached kext to get the broadcom 5752 to work.
The 3945abg driver from jalavoui doesn't work yet, but the card is detected.
If you wish to try, always remember to keep the wi-fi switched on while starting Os X, or you'll get a kernel panic.
Sigmatel kext still requires some work...

Attached Files



#107
the5th

the5th

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

Sorry, I'm quite busy in this period, however, just use the attached kext to get the broadcom 5752 to work.
The 3945abg driver from jalavoui doesn't work yet, but the card is detected.
If you wish to try, always remember to keep the wi-fi switched on while starting Os X, or you'll get a kernel panic.
Sigmatel kext still requires some work...



Hi it's been a while since u post but , would appreciate it if u can post recent guide currently trying to install iatkos 10.5.7.
Thanks for the help.

#108
Devil_Jin

Devil_Jin

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Hi it's been a while since u post but , would appreciate it if u can post recent guide currently trying to install iatkos 10.5.7.
Thanks for the help.

Sorry for the late reply. I'm planning to format my hdd the next month (in order to install windows 7) so I'll be able to write down a guide. However, considering the new windows bootloader's capabilities it wouldn't be such a bad idea to install osx on a virtual machine.
--edit---
Just found out that Virtual pc doesn't support mac os x like Vmware. :P

#109
RRRRyan

RRRRyan

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Sorry, I'm quite busy in this period, however, just use the attached kext to get the broadcom 5752 to work.
The 3945abg driver from jalavoui doesn't work yet, but the card is detected.
If you wish to try, always remember to keep the wi-fi switched on while starting Os X, or you'll get a kernel panic.
Sigmatel kext still requires some work...

You're a champ! Installed kext from OSX86 Tools, restarted, and the broadcom ethernet works on my M1710, posting through wired ethernet! Thanks!

#110
Devil_Jin

Devil_Jin

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
After 20 downloads at least one thanks...
Glad it was helpful for you. ;)

#111
insaneSOJO

insaneSOJO

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:The States
Has any1 tried and/or been successful with SL 10.6 on the M1710?

#112
psilocybin

psilocybin

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts

Has any1 tried and/or been successful with SL 10.6 on the M1710?


yup...im running 10.6.2 vanilla fully workin but 3945 abg

#113
insaneSOJO

insaneSOJO

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:The States

yup...im running 10.6.2 vanilla fully workin but 3945 abg



Is it similar to the 1530 install? Any help would be appreciated :D

#114
master666

master666

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
the Broadcom NetXtreme 57XX works completely with this driver

http://www.insanelym...p...ost&p=44281

#115
master666

master666

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
I've noticed a bug in the keyboard layout,

I can't type the "@"-symbol

are there any solutions?

#116
TheMediaGuy

TheMediaGuy

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I've heard that you can now install OSX without the hacked Disc... and I downloaded Snow Leopard 10.6 retail DVD (7GB) to try it... the idea is if this works and I like working with OSX, I'll go buy the retail DVD and make it legit.

I have an XPS M1710, intel wireless, 7950 512MB Geforce.

I'd like to dual boot with WinXP on 2 partitions.

I'm a computer tech, but just stumbled on this "hackintosh" concept, so it all makes very little sense to me right now... kext, boot loader etc...

1) After all this time, have the kinks for video, dual core, and wireless(intel 4965AGN) been sorted out?
2) If all this should be able to work, is there an updated "idiot's guide" that I can follow instead of sorting through 2 years worth of threads that slowly reveal improvements? I don't want to sound like a baby who asks for everything on a silver platter - but has someone put this on a silver platter? If not - is anyone willing to? As a matter of fact, if someone helps me go through this, I'd gladly write the "how-to" for others. I don't mind documenting.
3) Please reply or PM me if you have a helpful response to my Noob questions. Thanks!

#117
nerdyperdy

nerdyperdy

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
I'm getting one in the next couple weeks.

System: Dell XPS M1710 (Red color lid)

Processor: Intel Core Duo T2600 (2.16 GHz)

Memory: 2GB @ 667MHz - 2 DIMM Slots (2 x 1GB) (Max Ram 4GB)

Hard Drive: 100GB capacity at a speed of 7200 RPM

Graphics Card: NVIDIA GeForce Go 7900 GTX with 512MB DDR memory

Screen: WUXGA Truelife (1920 x 1200)

Optical Drive: 8x CD/DVD burner (DVD+/-RW/+R) with Dual-Layer

OS: Microsoft MCE 2005

Wireless Card: Intel 3945 (802.11b/g)

Battery: 9-cell lithium ion recharegable battery

Ports / Slots: 5-in-1 Memory Card Reader, DVI-D, VGA video output, S-Video, IEEE 1394 (Firewire), 6 USB 2.0, Express Card slot, Modem, Ethernet/LAN, Microphone in, Headphone out
Integrated Subwoofer,

I have read thru this thread and found out that wifi dosent work..Does mine??? I also have a Broadcom 4311..Is that interchangable??

Any help would be awesome.

~Nerd

#118
nucker

nucker

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
  • Gender:Male
  • Location:croydon


M1710 Sound Blaster Audigy

Hi does anyone know of a driver for Sound Blaster Audigy as thats my M1710 sound chip installed.
i have tried keep looking not much luck.
any info be great




#119
idefix09152006

idefix09152006

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
sorry, the thread is over 1 year old, but... is anybody out there that runs lion on the xps m1710 ???
i have the model with 2,33ghz-chip and the 7950gtx.
anyone can send me an dsdt.aml that can work for me ???





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy