Jump to content

Ladies and lads I would like to introduce to you a functioning ALC262 driver


  • Please log in to reply
231 replies to this topic

#221
argotera

argotera

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
  • Gender:Male
  • Location:Athens, GR
hi, don't know if it shows up in about this mac ( it doesn't work in my installation) or system hardware profiler,
but if you have windows installed,
open device manager,
find the webcam, double-click it,
go to the "Details" tab,
and then from the drop down menu named PROPERTY, choose "hardware id", or "device instance path"
it should be written there after SUBSYS.

i hope i helped

#222
minguz

minguz

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

Ladies and lads I would like to introduce to you functioning ALC262 drivers with headphone, internal speakers & Mic Input support. (AKA) A Realtek High Definition Audio driver.

Update: Choose the appropriate ALC262_XXX.txt file by matching it up to the last 3 digits of your Subsystem ID, Install it using Taruga's patcher :P by dragging & dropping the ALC262_XXX.txt file onto the patcher, rebooting and checking to see if your mic, speakers and headphones are working. If they are you can stop here ;) but if the Mic is still not working then download the appropriate 262_XXX.zip file, extract it and perform the following steps.


1st. go to /System/Library/Extensions/
2nd . Backup then delete the file called AppleAzaliaAudio.kext (if you find it) if not its okay. now do the same to the file called AppleHDA.kext.
3rd. drag and drop the contents of my zipped file into the Extensions folder.
4th. Start up terminal & type in the following commands without the numbers or "enter"
5th. sudo -s "enter"
6th. Put your password "enter"
7th. cd /System/Library/Extensions "enter"
8th. chmod -R 755 AppleHDA.kext "enter"
9th. chown -R root:wheel AppleHDA.kext "enter"
10th. chmod -R 755 ALCinject.kext "enter"
11th. chown -R root:wheel ALCinject.kext "enter"
12th. now brows to "System/Library" and delete Extensions.kextcache & Extensions.mkext. (leopard users will only need to delete Extensions.mkext.)
13th. (for leopard users only!) open disk utility and repair permissions.
14th. close terminal, reboot & enjoy.

I hope this works for you. I offer no promises of any kind so if it blows up your computer don't try to sue me (That�s what you get for running OSX on a PC).

Ps. I realize every chip is not listed such as my chip (ALC262_600). But since all the files work just fine for me I choose to use the ALC262_F00 driver because I find it to be the best sounding driver for my system.


You're the one who saved me!
after months of tryouts, finally your solution made my line out works..
thanks so much!
wish you a special 2010...

#223
suskunqq

suskunqq

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Audio: Realtek ALC262 @ Intel 82801IB ICH9 kext pack ? for iaktos v7

#224
slugmaster12

slugmaster12

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Is the ALC262 driver similar to the ALC268 driver because I was wondering if its possible for me to use this with my ALC268 sound for 10.5.2

#225
bryan_mmx

bryan_mmx

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
tried the 262_508 and it didn't work. must have been a mistake on my part. am still a newbie to mac os by the way.

I'm installing this on my Toshiba R500 with iPC 10.5.6

I checked my subsystem ID and the last 3 digits are 508. so I believe I downloaded the correct zip file

after extracting the zip file I find 2 folders, one named 262_508 and one __MACOSX

based on your instructions, I need to copy both folders into /System/Library/Extensions. but looking inside, I see kexts and no folders. so I'm a little confused here

what I did was I copied the contents of 262_508 and put it into /System/Library/Extensions and followed the rest of your instructions in terminal

I ended up with no sounds. A little help would be appreciated thanks.

#226
Cestbeau

Cestbeau

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Germany
Hey,

hopefully someone of you guys could help me. I have a Sony VPCCW2S8E with the Realtek ALC262 and I'm using Snow Leopard 10.6.4. This is my driver code:

HDAUDIO\FUNC_01&VEN_10EC&DEV_0262&SUBSYS_104D4700&REV_1003


Well I tried several .txt and kext, but none of them worked. Is there any posibility, that you can help me to get my soundcard working?

Looking forward to an answer and thank you,
greetings

Sebo

#227
Dima Panov

Dima Panov

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 1 posts
By the way, is there a solution for next variant of ALC262?

FUNC_01

VEN_10EC

DEV_0272

SUBSYS_1025029E

REV_1000



Founded in Acer Ferrari One laptop, AMD780G chipset

#228
MegaShark

MegaShark

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hi there,

the link for Taruga's patcher is dead... where can we find it?

#229
QuadDragonE

QuadDragonE

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Hi there,

the link for Taruga's patcher is dead... where can we find it?


Do a google seach on HDA patcher

or click this link (if still active)
http://www.insanelym...showtopic=32859

#230
omp2k1

omp2k1

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Hi I have 10.6.8 and this dsdt code
Device (HDEF)
{
	Name (_ADR, 0x001B0000)
Method (_DSM, 4, NotSerialized)
				{
					Store (Package (0x0C)
						{
							"CodecAddressMask",
							Buffer (One)
							{
								0x01
							},
							"device-id",
							Buffer (0x04)
							{
								0x3E, 0x3A, 0x00, 0x00
							},
							"MaximumBootBeepVolume",
							Buffer (One)
							{
								0x40
							},
							"layout-id",
							Buffer (0x04)
							{
								0x0C, 0x00, 0x00, 0x00
							},
							"device-type", 
							Buffer (0x12)
							{
								"Realtek ALC262"
							},
							"PinConfigurations",
							Buffer (0x10)
							{
								/* 0000 */	0x30, 0x01, 0x10, 0x90, 0x40, 0x00, 0x21, 0x01,
								/* 0008 */	0x20, 0x00, 0x81, 0x01, 0x10, 0x01, 0xA0, 0x90
							},
							"platformFamily",
							Buffer (One)
							{
								0x00
							}
						}, Local0)
					DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
					Return (Local0)
				}

Anyone have Platforms.plist & layout.xml for this dsdt string that can be used with HDAWizard?
The soundcard shows up in the sys profiler but it doesn't work.
Any help would be appreciated since voodoohda is a poor solution because it somehow conflicts with my nvidia card... go figure :/

#231
redneck

redneck

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts

What is the codec format to dumb to Tagura.

I have Tagura on my Maverick and a ALC 262 codec txt file.



#232
redneck

redneck

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts

Finally got ALC 262 sound.

To use Tagura , don't open drag codec over icon.

I have both files in the same folder, happened to drag codec over icon .

now have  sound.

Good thing about Maverick you can clean out your kext. 

I had cleaned all bak and hda kext before i loaded the codec by accident.

then I reloaded 262 HDA kext.

I now have sound.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy