Jump to content

[How To]Sapphire ATI Radeon 9600XT AGP 256MB DDR solution


  • Please log in to reply
7 replies to this topic

#1
pvil

pvil

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Interests:Macintosh/Hackintosh,Windows,surfing
Ive had only CI/QE OR resolutions enabled.I'm not managed to get both anabled.It's OR resolutions OR CI/QE.
You could also change resolutions by editing com.apple.boot.plist with Terminal
Download the following packages:
UPDATED:
http://rapidshare.co....part1.rar.html
http://rapidshare.co....part2.rar.html
http://rapidshare.co....part3.rar.html
http://rapidshare.co....part4.rar.html
http://rapidshare.co....part5.rar.html
http://rapidshare.co....part6.rar.html
Download Pacifist:http://www.charlessoft.com/
Run Pacifist,open the Essentials.pkg
click the arrows : System -> Library -> Extensions
Right click on these files and chose :Install to Default Location
Click on replace all files.
ATIRadeon9700DVDDriver.bundle
ATIRadeon9700GA.plugin
ATIRadeon9700GLDriver.bundle
ATIRadeon9700VADriver.bundle

http://rapidshare.co...em.pkg.rar.html
Open BaseSystem.pkg with Pacifist, System->Library->Frameworks
install to default location following frameworks:
OpenGL.framework
Quartz.framework
QuartzCore.framework
Open Terminal.
In the Terminal type:
sudo -s
then your password,
then paste the following lines one by one,
after each line you paste press enter

chown -R root:wheel /System/Library/Frameworks/OpenGL.framework
chown -R root:wheel /System/Library/Frameworks/Quartz.framework
chown -R root:wheel /System/Library/Frameworks/QuartzCore.framework

chmod -R 755 /System/Library/Frameworks/OpenGL.framework
chmod -R 755 /System/Library/Frameworks/Quartz.framework
chmod -R 755 /System/Library/Frameworks/QuartzCore.framework
You need to edit info.plist in the ATIRadeon9600.kext
and info.plist in the CallistoHAL.kext
2) Download AGPGart.kext(version 2.2)http://x86dev.org/fo....php?topic=46.0
And place it to the Desktop.
Open terminal ,type sudo -s,type your password,and paste the following
sudo cp -R ~/Desktop/AGPGart.kext /System/Library/Extensions

chmod -R 755 /System/Library/Extensions
chown -R 0:0 /System/Library/Extensions
rm -rf /system/library/extensions.*
Repair permissions with disk utility.
Reboot.
Posted Image

#2
artcoholix

artcoholix

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:INDONESIA
hi pvil
got your file here...
need some lil guide i think

copy all ATI files to system/library/extensions right?
and othere so system/framework?

after replacing all file
what do i need to do?
i mean the command sudo, chown etc..
not really understand that langage..

thanks..

ok to make it clear (he he sorry if my english is bad)

got this file from you (10.4.4_Ati_kexts_and_Old_Frameworks.rar) thanks..
i got it extracted

what do i need to do with the files?

ATIRadeon9700DVDDriver.bundle
ATIRadeon9700GA.plugin
ATIRadeon9700GLDriver.bundle
ATIRadeon9700VADriver.bundle

OpenGL.framework
Quartz.framework
QuartzCore.framework

i think copy all ATI files to /system/library/extensions
and others to /system/frameworks
is it true?
and for ati files, is it normal to be like that? wan't it supposed to be .kext?
after copying the file do i need to do specific command from terminal? since i can't install it via pacifist

sorry if i to much askin' here :D

thanks for the support,,, Cheers... :unsure:

#3
pvil

pvil

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Interests:Macintosh/Hackintosh,Windows,surfing
i think copy all ATI files to /system/library/extensions
and others to /system/frameworks
Yes, copy and replace.
After open terminal ,type sudo -s,your pasword
paste the following lines:

chown -R root:wheel /System/Library/Extensions/ATIRadeon9700DVDDriver.bundle
chown -R root:wheel /System/Library/Extensions/ATIRadeon9700GA.plugin
chown -R root:wheel /System/Library/Extensions/ATIRadeon9700GLDriver.bundle
chown -R root:wheel /System/Library/Extensions/ATIRadeon9700VADriver.bundle

chmod -R 755 /System/Library/Extensions/ATIRadeon9700DVDDriver.bundle
chmod -R 755 /System/Library/Extensions/ATIRadeon9700GA.plugin
chmod -R 755 /System/Library/Extensions/ATIRadeon9700GLDriver.bundle
chmod -R 755 /System/Library/Extensions/ATIRadeon9700VADriver.bundle

chown -R root:wheel /System/Library/Frameworks/OpenGL.framework
chown -R root:wheel /System/Library/Frameworks/Quartz.framework
chown -R root:wheel /System/Library/Frameworks/QuartzCore.framework


chmod -R 755 /System/Library/Frameworks/OpenGL.framework
chmod -R 755 /System/Library/Frameworks/Quartz.framework
chmod -R 755 /System/Library/Frameworks/QuartzCore.framework


Also you need to do step 3) from the guide
Use Disk Utility and repair permissions on your system drive
Delete Extensions.kextcache and Extensions.mkext from your /System/Library directory
Reboot
And give your feedback.

#4
artcoholix

artcoholix

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:INDONESIA
hi..

just finished to install your method
some improvement happeds thanks :)
RESOLUTION CHANGE enabled

but still some prob

vga still detected as PCI
but i can't select some refresh rate i want,
1152x864 32 (75Hz) my monitor supoort this on windows, but only 60hz and 80hz available, (80hz cause black screen)
and the graphic responsive is not quite good,
i try the ripple effect on dashboard and it looks better before i install the driver..
also mouse tearing...

any idea?

#5
pvil

pvil

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Interests:Macintosh/Hackintosh,Windows,surfing
Install This :http://www.2point5fish.com/download.html
to remove mouse tearing.
I'll upload for Essentials.pkg and BaseSystem.pkg
so you'll be able to install this with pacifist

#6
artcoholix

artcoholix

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Location:INDONESIA
yow..
thanks for keep posting up..

i've try to install AGPGart from ATI_9600_C008_AGP.pkg using pacifist
and yeah.. my card known as AGP, and the card is more responsive, but i loose the QE & CI support..

after that i try to install whole package ATI_9600_C008_AGP.pkg and the screen goes black after apple grey screen..
now i have to reinstall it once more.., cause i don't know how to fix it from darwin..

i'll give another try from your upcoming upload :thumbsup_anim:

Cheers...

#7
bilditup1

bilditup1

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts
  • Gender:Male
  • Location:New York
Hmm...the drivers here didn't seem to work at all. I went back and installed the ones from the 10.4.4 dvd, which are ever older than those in the file pvil uploaded. That in conjunction with AGPGart got me back to having at least the mouse tearing errors and such, but still no QE/CI. I honestly have no idea how I got the damn thing working in the first place...

...perhaps its an AMD issue? Do these frameworks need to be 'decrypted'?

#8
pvil

pvil

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Interests:Macintosh/Hackintosh,Windows,surfing
Probably you have other id's from devID:4152,vendorID:1002.
First try to place AGPGart.kext(v2.2 this one helped me) or other version to your extensions folder.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy