Jump to content

Apple MacBook Pro track pad not working

macbookpro macbook highsierra

  • Please log in to reply
1 reply to this topic

#1
rostacik

rostacik

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

hi gents.

sorry if I post into a wrong forum, but I think this one is best I was able to find here.

 

so my problem :

After last big update on 22.12. my track pad is not working at all. I wasn't present when the update happened, but I was told that "everything worked fine, but after reboot, trackpad is not working at all". I tried to reset SMC, reset NVRAM, remove old OS and make a clean install, nothing helps. trackpad sometimes works at the startup like 10-20s, then if stops.

 

Data about the machine :

Current OS - High Sierra 10.13.2

Mac BookPro (Retina, 13 inch, mid 2014)

Model ID - MacBookPro11,1

Boot ROM - MBP111.0142.B00

SMC - 2.16f68

 

could you point me to some tool or some how to that would tell me if my HW is workig? how can I check, if my version of SMC or boot ROM is the correct one and is OK?

 

any help appreciated.



#2
pippox0

pippox0

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 580 posts
  • Gender:Male
Run Apple diagnostic at boot . see if it reports HW faults. On the other hand, you could try to boot another mac OS X version ( older one) from external HDisk and verify if trackpad works.

If it works then it is not HW issue; if it doesn't work it is an HW fault ..


sent from my iPhone






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy