Jump to content

Wrong resolution on VMware

resolution vmware High Sierra 10.13 VMware Vmware tools

  • Please log in to reply
1 reply to this topic

#1
sasa.1

sasa.1

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hello everyone

 

I have a problem setting the virtual OS X to display the screen's native resolution(1600x900). When the machine first boots up, it displays the right resolution then after the logging in by a few moments the screen displays a wrong resolution(800x450 HIPDI) which is a quarter of the resolution.

 

I have macOS High Sierra (10.13.1) on VMware Workstation 14 Pro version: 14.0.0 build-6661328. My laptop has i5-4310U CPU with HD graphics 4400 which has 128mb dedicated video memory and a 1600x900 screen.

I have installed VMware tools that was created on 14 September 2017 and VMware unlocker version 2.1.1 made by DrDonk.

 

When logging in the background isn't the blurred wallpaper and the dock isn't transparent as it should be, or at least from what I saw on the internet.

 

Here is what I have tried up until now:

1) Changing the resolution from the system preferences.

2) Using

sudo /Library/Application\ Support/VMware\ Tools/vmware-resolutionSet 1600 900

 Which displayed this output: 

Requested resolution: 1600x900
Effective resolution: 1600x900

Without any result.

 

3) I tried setting the screen's native resolution in the Display settings of VMware, still nothing.

4) I also tried to change virtualHW.version from 14 to 10 but it also did not do anything noticeable. The only thing that changed is that the blurred wallpaper was in the background when logging in.

 

One thing to note is that it runs correctly up until 1366x768. I think the problem may be that the OS tries to load kexts after the logging in that interferes with the VMware tools, but I am not sure or that there is a hardware limitation, but I do not know a way to test it.

 

 

Does anyone know how to fix that?



#2
moisiss

moisiss

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

I was having the same issue with my 10.12 VM in ESXi 6.0.  I would go to display resolution and try to select 1600x900 and it would auto-switch it to 800x450 HiDPI no matter what I did.  I was able to fix it by doing the following:

 

1) Open terminal in the OSX VM

2) Enter the following command (no quotes) "sudo defaults delete /Library/Preferences/com.apple.windowserver.plist DisplayResolutionEnabled"

3) Enter you admin password

4) Restart the VM

 

When the VM restarts it will now go to 1600x900 and the 800x450 HiDPI setting is gone.







Also tagged with one or more of these keywords: resolution, vmware, High Sierra, 10.13, VMware, Vmware tools


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy