Jump to content

Hello guys, I'm new here, please help X79-UD4 installation of Sierra

X79-UD4 sierra clover

  • Please log in to reply
10 replies to this topic

#1
triplekill111

triplekill111

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Hi all

 

I'm new here, but I really need help with OS X Sierra for my X79-UD4 motherboard.

I've been trying to figure out the problem again and again. Unfortunately no luck with that. 

I've got error from start (please see photo in attachment). I typed in these boot flag ( dart=0 cpus=1 npci=0x2000 nv_disable=1 -v) in boot loader Clover 4049.

 

Also got these setting in BIOS

XHCI Hand-off  Disabled,

EHCI Hand-off  Disabled,

Wake on Lan  Disabled,

VT-d  Disabled.

 

Much appreciated if any one of you can help me on this.

 

Many thanks

 

Here is the specs:

 

CPU: Xeon E5 2670

MOBO: X79-UD4

Graphics: GTX 760 2G

Ram: 32G

SSD: 1TB

 

Attached Files



#2
cyberdevs

cyberdevs

    InsanelyMac Deity

  • Donators
  • 1,877 posts
  • Gender:Male

Hi there and welcome to InsanelyMac.com :)

 

 

Change these setting in BIOS

XHCI Hand-off  Enabled,

EHCI Hand-off  Enabled,

 

Use clover configurator and mount the EFI partition on your bootable device (Most likely your USB disk) open the config.plist and under the ACPI--->DSDT add these patches:

change EHC1 to EH01
change EHC2 to EH02

Or just post your EFI folder so I can take a look. You can remove "APPLE" folder I don't need it and you can also remove serial number.

 

 

dart=0 is required when you have virtualization enabled in your BIOS if it's disabled you don't need it

nv_disabled= will disable nvidia GPU

npci=0x2000/3000 is for when you are stuck with the "PCI Configuration Began" error

cpus=1 is for single CPU core mode

 

Keep the -v so you can see the verbose boot log in case anything else pops up.

 

You can also add the USBInjectAll.kext in the /EFI/Clover/kext/10.12 or /EFI/Clover/kexts/Other along withe following patch for port limits under the "KernelAndKextPatches"

Comment: change 15 port limit to 26 in AppleUSBXHCIPCIName: AppleUSBXHCIPCI
Find: <83bd8cfe ffff10>
Replace: <83bd8cfe ffff1b>


#3
triplekill111

triplekill111

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Hi cyberdevs

 

Thanks for your prompt reply. 

I'm now get onto it by following our instruction. 

Thank you so much. Much appreciated.

 

Cheers



#4
cyberdevs

cyberdevs

    InsanelyMac Deity

  • Donators
  • 1,877 posts
  • Gender:Male

Hi cyberdevs

 

Thanks for your prompt reply. 

I'm now get onto it by following our instruction. 

Thank you so much. Much appreciated.

 

Cheers

You're welcome :)

 

Let me know how it goes. 



#5
triplekill111

triplekill111

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Hi cyberdevs

 

Just back home from work.

I added two patches that you mention (change EHC1 to EH01 change EHC2 to EH02) in Clover config under DSDT. But I realised that it has got "EUSB to EH01" and "USBE to EH02" already. Would that be a problem or affect to anything? Due to having the same "EH01" and "EH02" (Please see attachment)

 

Regarding to the USBInjectAll.kext, I got it from RehabMan, but don't know which one I need. It has one under Debug and another under Release folder.

 

Many thanks

 

P.S. I share the EFI folder in my drop box. Hopes you can get it and have a look at that for me.

 

 https://www.dropbox....kr/EFI.zip?dl=0


You're welcome :)

 

Let me know how it goes. 

Still no luck. Same problem after changed the setting and added patches. :(

Attached Files



#6
cyberdevs

cyberdevs

    InsanelyMac Deity

  • Donators
  • 1,877 posts
  • Gender:Male
I will take a look at your EFI folder as soon as I can.
About the USBInjectAll you need to use the one that is in the release folder. And use the latest version which is 0.6.2

Remove any other patch that you applied in your ACPI and just leave the ones I gave you and try again


Sent from my iPhone using Tapatalk

#7
cyberdevs

cyberdevs

    InsanelyMac Deity

  • Donators
  • 1,877 posts
  • Gender:Male

which version of macOS you are using? 10.12.5 or 10.12.6?


there are two files in the config.plist

 

One is for macOS 10.12 to 10.12.5 and the other one is for macOS 10.12.6 use the one that suits your macOS version. You need to rename them to "config.plist"

You also need to remove the GenreicUSBXHCI.kext and add the new USBInjectAll.kext to /EFI/Clover/kext/10.12.

 

Your clover is also out dated and I suggest you install the latest version from: https://sourceforge..../cloverefiboot/



#8
triplekill111

triplekill111

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

which version of macOS you are using? 10.12.5 or 10.12.6?


there are two files in the config.plist

 

One is for macOS 10.12 to 10.12.5 and the other one is for macOS 10.12.6 use the one that suits your macOS version. You need to rename them to "config.plist"

You also need to remove the GenreicUSBXHCI.kext and add the new USBInjectAll.kext to /EFI/Clover/kext/10.12.

 

Your clover is also out dated and I suggest you install the latest version from: https://sourceforge..../cloverefiboot/

 

Hi, Im using 10.12.4. I actually got the EFI folder from here http://www.insanelym...sierra-success/ . am thinking to start from scratch with installing a fresh Sierra on the USB. Because it stops somewhere else and now stuck at here (please see attachment). 

 

Thanks for your advice, I've have downloaded the latest Clover R4128 ver and updated Clover Configurator to 4.46.0. So do you think it's better to reinstall a brand new Sierra with latest Clover on to the USB? If yes, what is the best clover setting for my X79 UD4? Should I just go for "Install Clover in the  ESP" then tick "Install boot0af in MBR" in Bootloader, next tick "CloverEFI 64-bits SATA" in CloverEFI and plus select "EmuVariableUefi-64" in Drivers64UEFI?

 

Sorry about too many questions.

 

Cheers

Attached Files



#9
cyberdevs

cyberdevs

    InsanelyMac Deity

  • Donators
  • 1,877 posts
  • Gender:Male
Yes it is best to create the new installer with a clean EFI bootloader. Remember that each system needs a specific clover settings unless you use a config from a system which is identical as yours. Some times getting clover to boot macOS needs some trial and error to get it right.
For your system you can use uefi clover bootloader select install clover in uefi mode and the select the install in esp, install EmuVaraiableUEFI.efi and AptioDrvFix. You can use AptioFixDrv2 if the first one failed to boot macOS.
There is a link in my signature which explains some general aspects of creating bootable USB disk and installing clover take a look there and you might find some useful tips.


Sent from my iPhone using Tapatalk

#10
triplekill111

triplekill111

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Yes it is best to create the new installer with a clean EFI bootloader. Remember that each system needs a specific clover settings unless you use a config from a system which is identical as yours. Some times getting clover to boot macOS needs some trial and error to get it right.
For your system you can use uefi clover bootloader select install clover in uefi mode and the select the install in esp, install EmuVaraiableUEFI.efi and AptioDrvFix. You can use AptioFixDrv2 if the first one failed to boot macOS.
There is a link in my signature which explains some general aspects of creating bootable USB disk and installing clover take a look there and you might find some useful tips.


Sent from my iPhone using Tapatalk

 

Thank you so much, much appreciated. Finally, success for the Sierra installation. :) But only one minor issue is that can't get USB3.0 working. :( 



#11
cyberdevs

cyberdevs

    InsanelyMac Deity

  • Donators
  • 1,877 posts
  • Gender:Male

Thank you so much, much appreciated. Finally, success for the Sierra installation. :) But only one minor issue is that can't get USB3.0 working. :(

You're welcome :)

 

There is also a section in the manual for activating the USB 3.0 ports you can use it to create you custom SSDT-UIAC.aml it's for all the computers and it's not specific to my build.

 

You can also use the USBInjectAll.kext and the USB ports limit patch if you don't feel like to create the custom SSDT.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy