Jump to content

Gigabyte X79-UP4 macOS Sierra (SUCCESS)

* * * * * 1 votes X79 X79-UP4

  • Please log in to reply
87 replies to this topic

#81
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 15,930 posts
  • Gender:Male
  • Location:Rio de Janeiro
  • Interests:HacksLikeMacs

They were re-posted by JD Apolo just a few week ago at this new link https://www.dropbox.... Files.zip?dl=0

I update first post with folder by JD Apolo to avoid future problems

http://www.insanelym...cess/?p=2280318

 

Enjoy



#82
Incredibile1213

Incredibile1213

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

I've just finished to install it and wowwwww! It works! At this moment the only thing that doesn't work is audio and Usb 3.0

I have to try to solve the audio first and later we will see....

My config:
CPU:Intel Core i7-4930K (6 core)
MotherBoard:GA-X79-UP4 BIOS F7
Graphics: Ati Amd 7970 Dual-X (3GB)
Ram: Crucial Ballistix Elite 64 Gb
SSD 850 Pro 1 Tb
HD: Seagate 3 tb 7200 rpm
Power: Corsair HX 1000 Watt Modular
Apple wireless keyboard, Touchpad, IOGear Bluetooth 4.0 usb micro, TP-Link PCI Express Wifi Adapter.
OS: Sierra 10.12.2
Clover: 3979
SMBIOS: MacPro6,1

Can you post your EFI please?



#83
t0olbox

t0olbox

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male

Hi guys..

 

need help on my Sierra 10.12.6 fresh installation.

 

I have almost the same setup as JD except for the processor and others

 

Mobo: Gigabye X79-UP4 F5

Proc: i7-4930K

Video: NVIDIA GTX 680

HDD: Seagate 500gb Barracuda 7200

 

I used JD's clover settings but the system halts somewhere in the beginning.

 

I uploaded an image of where it is halting. 

 

By the way I previously have a mavericks installed on this same setup.

 

Can anyone please help me fix my problem?

 

Update

I already got it to install. I didn't changed the nv_drv=1 to nv_disable=1. I thought i did because i ticked it in the clover configurator. but it should be changed in the options tab to work. so i tried it and.. wallah.. it worked..

 

Update 2

Sierra is already installed and running. But nothing is working except for the usb slot in the front panel. I did not copy the full efi folder from JD's download file. I only copied the configlist file and the kext folder from JD's clover folder. Might that be the reason why nothing is working?

 

Thank you for your advice #JD and #mald0n for the "use latest version of clover" tip.

 

You guys made my life easier. 

I hope everything works.

 

Cheers! 

Attached Files



#84
t0olbox

t0olbox

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male

Hi Guys..

I already installed sierra in my setup. Everything is up and running. 
The only problem is i am having the flickering or i think they call it display tearing. 
And i only have one display resolution to choose from on the display settings, which is 1024x768. 
But my monitor has 2560x1080 optimum resolution. What could be the reason for this.

I installed OSX Sierra 10.12.6 with the latest nvidia web driver plus the Cuda package.

What should i do to fix those display problems.
And also i can't boot without the USB installer drive. 
What should i do so i can remove the USB installer drive already..

Thanks in advance..

 

Update

 

Everything's working great now. The reason was i forgot to remove the nv_disable=1 and replace it with nvda_drv=1 in the clover config.plist.

 

Now everything is fine. This thread is really informative and it works.

 

Thanks



#85
triplekill111

triplekill111

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Hi guys

 

First of all, Thank you so much for posting and sharing all you guys really useful information here. 

But I have problem with USB 3.0, Can't get them working for somehow. I installed FakePCIID.kext, FakePCIID_XHCIMux.kext and USBinjectAll.kext, still no luck.

Can you guys please help and give me advises on this? Do I need to change BIOS setting or something? I enabled USB 3.0 controller and Ports from BIOS already. 

 

Here is the specs:

 

CPU: E5 2670

MOBO: X79-UD4 (Latest BIOS)

Graphics: R9 270X 2G

SSD: 1TB 2.5" 

 

Much appreciated if someone can help me with this.

 

Cheers



#86
Gen_

Gen_

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

Not much in OSX86 will kill your parts instantly but there are things here that will over time. Also please get Clover Configurator and use the GUI, it's much easier and I see all these people stumbling over editing their config.plist in text edit... painful.

FakePCIID.kextFakePCIID_XHCIMux.kext and USBinjectAll.kext altogether with no DSDT edits will damage the devices you plug into your ports if they do large transfers because together they mangle the data sent. You need to create a DSDT patch listing the amount of devices on the buses and ports and get rid of USBInjectAll. This is not my recommendation, it's on the download page of the kexts. 

Everyone having issues with kernel panics caused by AppleIntelCPUPM need to read this: http://www.insanelym...ement-1012-beta/ and create an SSDT for their CPU model and stock/turbo clocks. After that, you will need to enable DTGP patch and HPET patch, then AICPUPM patch in clover. 

And you DO need to do a lot of the things that seem optional here, because this is not an easy mode board. Take it from me who has run this since 10.7, RMA'd twice over damage and even bought another up4 two years ago. Using VoodooTSCSync/NullCPUPM without a working SSDT over time damages your processor and you will get a CPU self-check failure after a while stopping you from booting any OS because it's a hacky solution.



#87
juanfran121982

juanfran121982

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hello friends, here I am after a long time.

Nowadays I have replaced my x79-up4, now I have an ASUS X79 Deluxe. Everything seems to work fine with Apolo's files but I have some doubts.

1. I have made some overclock to this old cpu, I have changed the multiplier (44) and the cpu voltaje 1.28 (more o less, I have to do some tests). So the cpu is working at 4.4 ghz. Here with the nullcpupowermanagement.kext on clover nothing happened, the same result test as 3.4 ghz. Geekbench score 20.006.
However, if we take the nullcpupowermanagement.kext off from clover the score is increased until 26.000 but "about my mac" is showing 3.4 ghz.
My cuestion is: how can i change the information in "about my mac" to show the real ghz (4,4 ghz)?? And other cuestion is: doing this (take the nullcpupower.... off clover), affect to the cpu?


2. The usb 3.0. It is a big problem for me not to get it work. How can we do it work?? Is a Bios problem, a kext, clover....?

3. Bluetooth and WIFI integrated on this motherboard. Will they work??

Thanks in advanced.

My config:
Intel i7 4930k 3.4 ghz running overclocked at 4.4 ghz
Asus X79 Deluxe
64 gb ram 2400 mhz
2 x MSI RX 580 X+
Samsung Pcie 960 PRO 1 Tb
Samsung 950 Pro SSD 1 TB
3 TB seagate 7200 rpm

#88
djeans

djeans

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Hello all,

 

I have still not been able to get Sierra running reliably on my Hackintosh.

 

I have the same setup as JD Apolo, except my video card is a GTX780, other than that, same CPU, same motherboard, etc.

 

I currently have Sierra installed, but when it is running, the system is slow (especially finder tasks like moving a folder etc may take minutes to complete) and there is a constant 100%-200% cpu usage by kernel_task.

 

I have tried all the clover folders that have been uploaded here, and each result in different things (Maldons breaks USB, but video works great)  but all still result in the same Slow finder and CPU kernel_task usage.

 

I have Yosemite installed and working very well, but I can no longer update several apps that I use and need to update.

 

I'm not very well versed in how to diagnose this problem - would anyone be willing to help me figure this out? I have the IOREG from both the working Yosemite and the Sierra installs but do not know what I'm looking at. 

 

Any help would be greatly appreciated.

 

UPDATE

 

I Started over with a clean install, and it is now working better. My kernel_task problem had to be something is the OS install, because now it is gone, and at the moment Sierra seems to be running smoothly. 

 

I do not have USB 3 working, as I have noticed others in this thread have also had problems with, and while the on-board audio works, audio being sent to my USB interface (which is use much more frequently) is distorted and broken.

 

I would greatly appreciate any help getting USB 3 and my audio fixed.

 

UPDATE 2 -

 

Tried installing VoodooHDA to see if that would fix my USB audio interface problem. It did not. Audio plays fine through my USB interface for about 55 seconds, then begins to distort and deteriorate, eventually to nothing. Switching to a different output then back to my USB interface makes it work again, for another 55 seconds, then it starts crapping out again.

 

UPDATE 3

 

My runaway kernel_task is back in my clean install. I don't know what screwed it up, but after the VoodooHDA experiment, then trying to undo it I now have a completely unresponsive finder (moving an item to the trash takes longer than a minute) and a kernel_task that as I type this is at 149%. I felt like I was SOOO close, now I'm back to unusable again. Sigh.

 

Thanks








0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy