Jump to content

Old MBP GPU problem


  • Please log in to reply
4 replies to this topic

#1
maukku

maukku

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
  • Gender:Male

Hi everyone

 

I happen to have a first-gen unibody MBP (Late2008), equipped with Nvidia 9400M + 9600M GT gpu's. Used it until about a year ago, when the discrete 9600M gave up and machine always kernel panicked in boot.

Now I'm trying to revive the machine. I booted the machine from old HDD with 10.7 Lion installed to it. To my surprise it booted fine to desktop and everything seems to work normally. Only that when I try to switch to 9600M, nothing happens, and the machine starts to run really hot even when idle. But again, using only integrated graphics seems to work ok.

I'm fine with the machine only working with the integrated graphics, but the problem is that post-Lion systems won't boot, to me it seems that they try to access the discrete GPU and panic when it fails (always nvidia mentioned at crash dump). So, my question is, is there any way to "disable" the 9600M GPU, so that the operating system would only see and use the integrated one? Or maybe just delete all references to 9600M from for example Yosemite's graphic drivers (and how it would be done)? Of course if this is not possible, I just have to stick with Lion, thats better than completely dead machine.

If anyone has ideas, please share :)



#2
luki1979

luki1979

    InsanelyMac Geek

  • Donators
  • 214 posts

Maybe you could boot with clover from usb and disable nvidia with a flag



#3
worf2

worf2

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male

i have a similar issue with my macbookpro mid 2010. sometimes kp with the nvidia card.

 

.... AppleGraphicsControl/AppleGraphicsControl-3.6.22/src/AppleMuxControl/kext/GPUPanic.cpp ....

 

missed apples exchange plan by 6 month. 

fewer kp but not solved on snow leo with https://gfx.io  

tried to disable totally but not success. if there is any progress in this case, pls let me know either. 

best



#4
kosakgroove

kosakgroove

    Unix Shepherd

  • Members
  • PipPipPipPipPipPipPip
  • 698 posts
  • Gender:Male
  • Location:ALGARVE
  • Interests:The unexpected is the real

I guess your best try would be deleting NVIDIA kexts from your install (probably listed as NVDA something in /System/Library/Extensions), rebuilding the kernel cache, and entering the " nv_disable=1 " boot flag in your nvram, so it is active at next reboot. That's what I would try at least.

 

If that doesnt work, simply open up your Mac (very hard task even for experienced hardware geeks like me) and see if the card is not essential for your system to work and REMOVE! :D


BTW, how in Earth can you boot Clover on a MBP? Theoretically it is possible but it is a totally unadvisable and dangerous thing to do. Hackintoshing a real Mac effectively proves more damaging than throwing it out of the 100th floor of a skyscrapper.



#5
mendietinha

mendietinha

    mendi

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,184 posts
  • Gender:Male
  • Interests:full hackintosh.

did you try to remove the gpu id from nvidia kexts?







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy