Jump to content

Computer name changing constantly (two or one network interfaces enabled)

Yosemite computer name two network interfaces

  • Please log in to reply
29 replies to this topic

#21
gusev_vlad

gusev_vlad

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Do you all have Apple TVs? If yes, did you update it to iOS 7/8 restyle?



#22
Stefan Milev

Stefan Milev

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 118 posts
  • Gender:Male
  • Location:Barcelona, Spain

I don't have. 



#23
cflmark80

cflmark80

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

I have two Apple TVs, but they are the 2nd generation, and those do not get the new iOS 7/iOS 8 restyle. Only the 3rd generation got that update.



#24
diddl14

diddl14

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts

Having the same issue on a Macbook Air running latest Yosimite build (GM3).

Network has an Airport Extreme and an AppleTV, both acting as sleep proxies.

 

Hack running 10.9.5 doesn't have the issue so maybe a 10.10 bug..?



#25
Stefan Milev

Stefan Milev

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 118 posts
  • Gender:Male
  • Location:Barcelona, Spain

I installed Yosemite in MacBook Pro late 2010 and am observing the same issue. Name started to change. Never had this in Mavericks so for me totally Yosemite bug, but on the net I've red that people have it on other versions of the operating system. 



#26
jamies

jamies

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

I was plagued by this issue until I logged into Back to My Mac on the Airport Extreme. Since then, it's been working without incident. I wonder if this makes it so the APE manages the Wake on LAN function. Maybe the Apple TVs doing this for Yosemite macs is not working properly?

 

I perhaps spoke too soon. The issue seems to be back on my Mac Pro on GM3. I can't seem to peg down when it happens, though it's very possible it occurs when my Mac is sleeping and waking to notify other devices with Wake On Lan. Also, the wake on lan doesn't seem to work with Back to My Mac. I can never get my Mac at home to wake up when I'm at work.

 

This does seem like a Yosemite bug; I wonder if there's a radar filed for it.



#27
Synapsis

Synapsis

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts
  • Gender:Male

Got the same Issue,

 

My setup:

MBP Pro (late 2012),

an iMac 27 (early 2014)

Apple TV (late 2012)
Time capsule 2tb (early 2014)

Hackintosh (Asus p67 Sabertooth, 2011)

 

after upgrading all of them to Yosemite – the host name seems to change randomly on each of them

adding (number) after the name, so from time to time I see a couple of computer in the shared list, and I see the localhost (the computer is sit on)
in the same list and connect to it as if it were a remote machine (?!?)

 

the issue never existed on mavericks - therefore must be a Yosemite issue.

 

Anyone got any more findings on this? This is quite annoying, I don't use any kind of NAS aside of time machine automated backups.

 

update 1:

 

found a tip on another forum to cycle (load/unload) mDNSResponder to solve this:

 

sudo launchctl unload -w /System/Library/LaunchDaemon/com.apple.mDNSResponder.plist

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

 

gotta give it a try, I think this has something to do with the waking up from sleep on yosemite.



#28
Stefan Milev

Stefan Milev

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 118 posts
  • Gender:Male
  • Location:Barcelona, Spain
What I did is to disable "Find my Mac" feature in settings. After that three days now I don't see the name changing. Maybe you can try that as well and see if it works for you too.

#29
Irish10

Irish10

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Got the same Issue,

 

My setup:

MBP Pro (late 2012),

an iMac 27 (early 2014)

Apple TV (late 2012)
Time capsule 2tb (early 2014)

Hackintosh (Asus p67 Sabertooth, 2011)

 

after upgrading all of them to Yosemite – the host name seems to change randomly on each of them

adding (number) after the name, so from time to time I see a couple of computer in the shared list, and I see the localhost (the computer is sit on)
in the same list and connect to it as if it were a remote machine (?!?)

 

the issue never existed on mavericks - therefore must be a Yosemite issue.

 

Anyone got any more findings on this? This is quite annoying, I don't use any kind of NAS aside of time machine automated backups.

 

update 1:

 

found a tip on another forum to cycle (load/unload) mDNSResponder to solve this:

 

sudo launchctl unload -w /System/Library/LaunchDaemon/com.apple.mDNSResponder.plist

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.mDNSResponder.plist

 

gotta give it a try, I think this has something to do with the waking up from sleep on yosemite.

 

To disable this behavior on Yosemite you can do it by running following command and reboot:
 

sudo /usr/libexec/PlistBuddy -c "Add :ProgramArguments: string --no-namechange" /System/Library/LaunchDaemons/com.apple.discoveryd.plist

As seen on: http://ispire.me/fix...m-wakeup-issue/



#30
bobbles

bobbles

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

folks fyi, I'm having the same issue. setup as follows:

 

  • Timecapsule (Handles DHCP, back to my mac disabled)
  • Synology NAS
  • Apple TV
  • Macbook Pro 2007
  • Macbook Pro 2011
  • Mac Pro 2013
  • Mac Mini
  • Comcast with simultaneous IPv6 and IPv4 addresses on the network (not sure if relevant)

All running Yosemite. But for some reason the MBP 2007 is the only machine that has this naming issue. In finder I have like 15 copies of that same machine name with (2), (3) etc after it.

 

Also have issues with wake on lan. 








0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy