Jump to content

Issues with ALC892


  • Please log in to reply
5 replies to this topic

#1
ikingblack

ikingblack

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts

Hey all,

 

I just updated to the Public Beta and I've encountered issues (yet again, this darn thing) with ALC 892 audio. I've tried the kexts from the AppleHDA thread, as well as numerous other "fixes" for this chipset. However, no matter what I try, the "Output" tab in System Preferences --> Sound will ONLY show Line-Out, headphones, and Digital-Out. in the past (DP4 and previous), I used "Built-in Speakers" which are no longer available. My current setup:

 

HDA Enabler (I've tried Layout ID 1,3,5,7)

Patched AppleHDA

Clover + "Fix HDA" patch for the DSDT

 

 

I tried the latest version of Voodoo HDA however this didn't work.

 

 

Thanks for any help in advance!

 

Update: The Built-in Output shows up in Apple's "Audio MIDI Setup" but still not in system preferences. Strange.



#2
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 1,111 posts
  • Gender:Male

Update: The Built-in Output shows up in Apple's "Audio MIDI Setup" but still not in system preferences. Strange.

Problem with front panel headphone jack.  If headphones connected, remove.  If no headphones connected, jack is stuck/failed.



#3
ikingblack

ikingblack

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts

Problem with front panel headphone jack.  If headphones connected, remove.  If no headphones connected, jack is stuck/failed.

Assuming the jack is stuck, how would I fix this?

 

FYI sound works in Windows so I don't know if it's a software issue or a hardware one.

 

Thanks for the response!



#4
bluenote56

bluenote56

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
  • Gender:Male
  • Location:ROME ITALY
  • Interests:Music, movies, books, hi-end hi fi, computers, electronics.

Hey all,

 

I just updated to the Public Beta and I've encountered issues (yet again, this darn thing) with ALC 892 audio. I've tried the kexts from the AppleHDA thread, as well as numerous other "fixes" for this chipset. However, no matter what I try, the "Output" tab in System Preferences --> Sound will ONLY show Line-Out, headphones, and Digital-Out. in the past (DP4 and previous), I used "Built-in Speakers" which are no longer available. My current setup:

 

HDA Enabler (I've tried Layout ID 1,3,5,7)

Patched AppleHDA

Clover + "Fix HDA" patch for the DSDT

 

 

I tried the latest version of Voodoo HDA however this didn't work.

 

 

Thanks for any help in advance!

 

Update: The Built-in Output shows up in Apple's "Audio MIDI Setup" but still not in system preferences. Strange.

 

Hi I don't know what system you got but this patched kext works for me. Give it a try you can always trash it and us the backup one if you install with Kext Wizard. Of course repair permissions rebuild cache before rebooting. I'm on Yosemite DP6. Ciao

Attached Files



#5
capitanbelico

capitanbelico

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 151 posts
  • Gender:Male
  • Location:Santo Domingo
  • Interests:OSX, Mac

Hi I don't know what system you got but this patched kext works for me. Give it a try you can always trash it and us the backup one if you install with Kext Wizard. Of course repair permissions rebuild cache before rebooting. I'm on Yosemite DP6. Ciao

try this ALC892_YosemiteDP3.

 

is in download section from this forum, its work for me using yosemite 10.10 Beta public 1



#6
zeroxw

zeroxw

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Install VoodooHDA will solve ACL892, I have the same problem solved by VoodooHDA







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy