Jump to content

Won't boot OSX (DualB) without USB...


  • Please log in to reply
1 reply to this topic

#1
dudeinco

dudeinco

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Colorado
  • Interests:Everything PC? Programming, PC Gaming, Android, Skiing, Biking, Business Development / Manageme...

OK, so I have read through the guides (and I think I read through them before.)  I'd rather not start over if I don't have to (specifically on the Windows side), so here we go...

 

I had W8.1 installed on my machine ("hacknstream" in sig), and decided to make this a dualboot OSX.  I purchased a second HD (because I heard this was easier) to install OSX on.  

 

I started off with the Niresh ISO that wouldn't boot when burned to USB, so I downloaded the dmg, and while it would boot, I'd always get a panic.  So... I mounted the dmg (MacDrive), found some kexts for my PC and copied them in.  Failure.  I mounted the dmg again, copied kexts from the ISO to the dmg using MacDrive - perfection!  Installed OSX, and with my USB still defaulted on boot, I was able to get in, update to 10.9.4, and everything worked beautifully (sound, acceleration, usb, everything).

 

Pulled out the USB, didn't work - straight to Windows.  I installed EasyBCD and went to town - 8.1 menu item, 10.9 menu item (MBR).  Upon reboot, I had the two options and went for Mac - Chameleon loader (and 2.0 at that?).  I hit a key to continue, and it would sit for a while, flash an error for a split second:  efi_inject_get_devprop_string NULL trying stringdata (took me many reboots to get it to pause at that).  -v option at boot flips through hundreds of kext items, and then just split-second reboots.  I made the OSX partition active, still nothing.  I've tried modifying the Chameleon bootlist to *almost* match the install dmg (left out the base dmg entry, of course).  As an aside, I backup files before playing with them...  Booting directly from Disk1 gives me the same thing.

 

So here's where desperation kicks in... I start copying the kexts into OSX and fixing the permissions.  No luck.  I tried to install 2.2 Chameleon, and while it installed correctly, it also warned me in the logs that Chameleon was installed on Disk0, and that would be the default (how'd that get there?).  I got really desperate and started coping over boot and boot.efi from the USB to Disk1.  Nada...  It appears that no matter what I do, it still goes to that Chameleon 2.0, then won't load.  I've destroyed my bootloader for both Windows and OSX several times - no big deal, you just go back and fix it.

 

So where we are today after 30-40 hours is:  I'm stuck with the USB for booting.  Nothing I seem to do changes that.  My OSX runs gorgeously with it, and not at all without it.

 

The only thing I can think of (because I was attached to using EasyBCD for boot) is to install Chameleon on Disk0?  I think I tried that once, and it wouldn't let me.  If someone thinks that's the solution, I'll try it later tonight again and report back...

 

Help?



#2
polyzargone

polyzargone

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 201 posts
  • Gender:Male
  • Location:France

Well, first, could you tell us what type of HDD you're using ? Sata or PATA, in what bios mode AHCI or Enhanced IDE and, most importantly if those drives are in 512 bytes or 4k bytes sectors (google your brand and model HDD to find out) ?

 

If they're 4k bytes sectors, there's a good chance that Chameleon bootloader is not properly installed. Since you seems to be comfortable with Linux, I suggest to take a look at here : http://www.insanelym...-way-to-fix-it/

 

Did you tried Chameleon Wizard ? It's a must-have app for configuring the bootloader and install the right boot files (in your case, it should be Boot0md) at the root of your OS X partition.

 

Ultimately, you could re-install OS X using a "vanilla" install method (which is always a better solution than Distro's because as you've experienced it, you are not polluted by useless kexts that can create conflicts). There's a lot of Guides on this forum to help you and I'm sure that there's also a lot of people that can assist you too.

 

Hope this helps !

Welcome aboard and good luck !







2 user(s) are reading this topic

0 members, 1 guests, 1 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy