Jump to content

10.9.1 cannot recognize intel 7 series in RAID mode


Best Answer chung1107, 19 February 2014 - 04:25 AM

Problem SOLVED

added the device ID 2822 in 7 Series Chipset string

After that when boot osx even BIOS in raid mode (not AHCI)

OSX can also boot properly :)

Go to the full post


  • Please log in to reply
6 replies to this topic

#1
chung1107

chung1107

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

10.9.1 cannot recognize intel 7 series in RAID mode

 

I installed 10.9.1 in USB HD driver in SATA\AHCI mode, can work fine,

But, change BIOS, SATA\RAID mode, system cannot recognize intel 7 series anymore

 

BTW, the previous version, such as 10.8.3 can work fine

## in RAID mode, I know only can discover non raid system disk



#2
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,016 posts
  • Gender:Male

If you want to use Mac as a non RAID setup but want RAID for windows you need to add Intel's device ID for RAID to the SATA driver.

 

Else you can do software RAID for your Mac install or buy a real RAID card. 



#3
chung1107

chung1107

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

How to add Intel's device ID for RAID in SATA driver?

due to my system have raid0 and non raid HD, but I just want to install osx in non raid HD

The Last version (10.8) can recognized my sata system, even BIOS in raid mode

only the raid0 HD cannot see, but the others can work fine!



#4
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,016 posts
  • Gender:Male

Find the proper kext and then add the ID. 

 

Look up Intel 7 Series Chipset Spec Sheet for the ID that needs to be added. 

 

Your RAIDed drives will not show up under Mac OS X. 



#5
chung1107

chung1107

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

so, which kext will affect that?

and how to modify that kext? thanks



#6
chung1107

chung1107

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

Best Answer

Problem SOLVED

added the device ID 2822 in 7 Series Chipset string

After that when boot osx even BIOS in raid mode (not AHCI)

OSX can also boot properly :)



#7
davidm71

davidm71

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 167 posts
  • Gender:Male

How did you do that exactly???

 

Wow!







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy