Jump to content

Asus G73JH-xx i7-740QM HD5870m - Mavericks 10.9.X


  • Please log in to reply
66 replies to this topic

#1
Kuebeker

Kuebeker

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts

!! ONLY "Asus G73JH-xx" ONLY!!

This post is a work in progress and will be edited.

 

Update!

I'd love to help but I'm lacking time. I need to make some cash $$$.

I will update the work I've done and post the fixes when the OS X updates breaks them.  

 

Specifications: Asus G73JH-xx 
 

TO DO / TEST :   :unsure:

- You can contribute by addressing the following and reporting back.

  I'll incorporate your solutions or confirmation of working options to this post.

- Ethernet I have to test ALXEthernet.kext for the 7Gb transfer crash.
- Audio: ATI HDMI
- 802.11N not tested.
- Bluetooth.
- Add missing _DSM methodes.

- Get Asus Turbo mode ( instant OC ) working. 

- Tweek Intel turbo mode.  One of the 4 cores gets the boost. 

  ex: One of the i7 2.66Ghz core can Turbo Boost to 3.33Ghz.

- Find out why , for the 2 identical laptops, A working DSDT does not work for both.

 

WORKS 100%:   :thumbsup_anim:

- Shutdown, Restart and Sleep: Display Sleep, System Sleep and System Sleep when LID is closed. 

- USB2.0 WebCam

- Keyboard proper layout.

- Trackpad

- DVD Player / Chess

- Memory Card reader

- Sensors : CPU & GPU

​- Disable intel CPU Turbo mode when powered by battery.

- Audio Internal speakers /autos witch/ headphones and internal mic / auto switch / external mic. 

 

WORKS BUT COULD BE BETTER:   :| 

- Wifi 802.11B/G

- AsusATKD.kext :  To bad the source code is not available to add KD backlit, turn WiFi on/off etc. 

 

STUFF I'VE TRIED TO GET WORKING AND FAILED:  :wallbash:

- VGA. I disabled it through FrameBuffers because the VGA is always active and creates a ghost display in preferences.
- Example: Attached File  Ghost Display.tiff   81.13KB   74 downloads

- Ejectable SATA ports (2x). ( You can have up to 3 internal drives in this laptop. )

- Bluetooth. 

- Get USB devices to auto eject on sleep via DSDT.

 

Processor: Intel Clarksfield Core i7-740qm, 1.73-2.93GHz  

Bios version 213 - 2011/02/24

Using SMBOIS : MacBookPro,6.1

 

Chipset: HM55

  • Note  : Make sure you add all _DSM methodes. 

Graphics: AMD Radeon 5870m mobility 1Gb
  • ID#    : PCI\VEN_1002&DEV_68A0&SUBSYS_1C021043&REV_00
  • KEXT   : AMD5000Controller.kext Patched.
  • Version: NA
  • Source : 10.9 install
  • Note   :  DSDT PEG3.GPIO._DSM method added. VGA port is disabled. HDMI Hotplug works. Using Frambuffer Langur with a cinebench GPU score of 40.25 @ 1.99GHz and 38.68 @ 1.73GHz.

 

Display:

  • ID#    : MONITOR\AUO109D
  • Note   : None.

 

Ethernet: Atheros AR8131 

  • ID#    : PCI\VEN_1969&DEV_1063&SUBSYS_18201043&REV_C0
  • KEXT   : ALXEthernet.kext
  • Version: 1.0.2
  • Source : Here
  • Note   : Crashes when copying files larger then 7Gb 

 

WiFi / BlueTooth Combo : Atheros Azurwave AR9285 

  • ID#    : PCI\VEN_168C&DEV_002B&SUBSYS_10891A3B&REV_1
  • Kext   : 
  • Version:
  • Source :
  • Note   : 2.4 GHz, abgn, 1 stream, 54 Mbs
Optical Disk : LG Blue Ray Combo
  • Model  : hl-dt-st bddvdrw ct21n
  • Note    : It just works.

TrackPad: Synaptics


WebCam: Chicony
  • ID#    : USB\VID_04F2&PID_B106&REV_8915&MI_00
  • Kext   : 
  • Version:
  • Source :
  • Note   : 2.0 Mega Pixel web camera
Audio: Realtek HD Audio ACL 269
  • ID#    : HDAUDIO\FUNC_01&VEN_10EC&DEV_0269&SUBSYS_10431373&REV_1000
  • Kext   : AppleHDA.kext patched 
  • Version:
  • Source : 10.9.1
  • Note   :  You need to create a "Multi-Output device" through "Audio Midi Setup.app" and use SoundFlower for volume control. 
Audio: ATI HDMI
  • ID#    : HDAUDIO\FUNC_01&VEN_1002&DEV_AA01&SUBSYS_00AA0100&REV_1002
  • Kext   : 
  • Version:
  • Source :
  • Note   :
Memory Card Reader: Alcor AU6433
  • ID#    : ND
  • Kext   : Default Mass Storage Class driver from OS X
  • Version:
  • Source :
  • Note   : 8 in 1 card reader SD,MMC,MS,xD,Smart Media,mini SD w/ adapter,MS-Duo

 

SPECIAL NOTES FOR THE ASUS J73JH LAPTOP:  :poster_oops: 
- Fans run at full speed and/or laptop runs very hot. 

  These Asus laptops are known to run hot because the paste used on the CPU and GPU is cheep. 

  Buy the best paste you can afford and repaste GPU and CPU, while your at it, clean those fans.

  Make sure you generate P and C states and enable C2, C3 and C4 your boot.plist/Chameleon.

 

- You can add a 3'd hard drive by removing the DVD drive and getting a DVD Hard drive tray. Search Ebay.    


HOW TO INSTALL 10.9.0  :graduated: 

- Create your USB Key installer by following this thread.

- Download the Asus G73JH-B1 - Boot Files. See link below.

- Use the files for both your Maverick Install USB Key and final install.

- Read the “- Apple kext's to remove” in S/L/E.
- Put all kext’s found in the folder S/L/E to /System/Library/Extensions.

  Once booted off the Maverick USB key you will get a long white screen delay, be patient the installer window will pop up.

 
 

10.9.1 - BOOT FILES. Work still in progress.

Attached File  Asus G73JH-B1 Maverick Files 1.1.zip   3.97MB   107 downloads

 

10.9.2 : Added 2014-04-20

Attached File  10.9.2 - AMD5000Controller 1.20.11.zip   965.75KB   60 downloads
reinstall AppleHDA.kext from 10.9.1 files above. 

Attached Files



#2
drone4zone

drone4zone

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

Good post...did you try any of the  kexts I posted earlier their is a Airport kext along with  backlight keys  DSDT patch,that works 


http://www.filedropp.../g73jh-kextpack


Ethernet should work if you  use chameleon wizard in boot.plst or add them  as

 

<key>EthernetBuiltIn</key>

<string>Yes</string>


#3
Kuebeker

Kuebeker

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts

I tried the EthernetBuiltin but it does not work. I'll attack it again tomorrow. 

 

I will be doing the Backlit DSDT hack tomorrow.

 

I used your AirPortAtheros40.kext but I had to install it to S/L/E/. Is this where you installed yours?

 

I tried your ATI5000Controller.kext but could not get it to work.

I'm using your rom and Boot.plist entries for AMD. 

I used pacifist to re extract the kext's for 5870m to get the Info.plist. The default install of 10.9 no longer has Info.plist in the Kext's.

Update: I've done 2 installations from scratch. On one the Info.plist where missing from the AMD kext's but on the other the Info.plist's where installed. My take on this is if your Inf.plist are missing, reinstall and use a good quality USB key. 

Besides I love to do every thing manually that way I get e better understanding. 

Apple must be using another way of linking the drivers to there devices. Is it a sign that Apple will disable info.plist reads in the near future? 

 

List of extracted kext's with Info.plist's from 10.9.0:
AMD5000Controller.kext
AMDFramebuffer.kext
AMDRadeonVADriver.bundle
AMDRadeonX3000.kext
AMDRadeonX3000GLDriver.bundle
AMDSupport.kext
 
I will be reinstalling Maverick on this system using a good quality USB key. 


#4
drone4zone

drone4zone

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

wifi  fn,f2 toggles the  wifi  blue led icon but that's about it it will not power it off or on , you  can  with mouse   with  AirPortAtherose40 kext

just enable it in sys preferences after installed with kext utility reboot is required.


Yeah kextutilty puts in S/L/E..keyBacklight works good  you  get the  3 stages of low med, high while pressing  ctrl,Alt together + or - and blue led light works for top left for toggle as well off,or on off for  blue shader under led Panel,i'm trying to figure out to toggle Turbo mode for middle  blue led top left .


yeah seems the kextATI5000 is for ML,not sure if works with Mavericks..I'm using it with  "Nomascus" frame buffer  personality and it shows up in sys profilers  Ati 58000 series but having issues with sleep and changing resolutions  crashing ,I hear it needs a dual link dsdt patch fix ,I'm looking into that now 


VoodooPs2controllerKext in my pkg is tweaked to give you more control over the trackpad install it with kextUtility it will place it in S/L/E

you must remove any ps2hubKext along with any other versions of VoodooPs2Kext that may be installed in your extra or S/L/E folder,otherwise it will not work..then you can go to sys preferences tweak it  has three finger (TAP) to enable middle mouse button I use it to  pop Mission control set middle mouse button then you tap three finger to enable it again reboot is required after you  install this  kext



#5
Kuebeker

Kuebeker

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts

VoodooPs2controller.kext v 1.8.9

How did you get the 3 finger tap to work? Which preference pan is it in? 

 

I hate the trackpad tracking. Even at the fastest settings it's to slow.



#6
drone4zone

drone4zone

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

to get  3 finger Tap  go to Sys  Preference  ,TrackPad, enable "use 2 fingers" ,"Clicking" make scrolling very slow peed  2nd  hash I use, same for Double Click Speed.Then go to Show all ,then Click on "Mission Control" to the bottom right click on next to hot corners  triangle to show  "Middle Mouse Button" and  close sys preference tap 3 fingers onto desk top to  enable Mission control !


also 3 finger swipe upwards activate new open  finder window ,I imagine anywhere you can make  "Middle mouse button setting  you can tweak more 


Also zoom while holding ctrl works its handy


how are you at compiling Kexts ? I have  two Kext drivers that you can  compile with frame buffers,and  driver files  if you want to  try 

here is the linked file :  

 

http://www.filedropper.com/vbios



#7
Kuebeker

Kuebeker

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts

Changes made in red

 

- Cant get the 3 finger TAP, Zoom or New Finder window to work. 

 

- I've never compiled a Kext before. I would snot know where to start. 

 

- I noticed in your DSDT you have not added 4 IRQ's to HPET. 

HPET need 4 static IRQ's.

Symptoms of IRQ conflicts are audio is spitting out static, your mouse/trackpad jumps allover the place. USB devices stop responding.

 

Device name : IRQ  : Change to 

HPET        : None : 2,8,11,14

IPIC        : 2    : Removed

Math        : 13

RTC         : 8    : Removed

TIMR        : 0    : 10

PS2M        : 12

PS2M        : 12

PS2K        : 1

PS2K        : 1

 

HPET has no IRQ's of make it look like this:

Name (BUF0, ResourceTemplate ()
                    {
                        /* Added IRQ's 2,8,14,14 */
                        IRQNoFlags ()
                            {2, 8, 11, 14}
                        Memory32Fixed (ReadWrite,
                            0xFED00000,         // Address Base
                            0x00000400,         // Address Length
                            _Y0F)
                    })

 

To find the other IRQ's search for IRQNoFlags ().

 

- Got thermal sensors working. My Asus is nice and cool. 

 

- I need to work on the battery sensor and get it to charge.



#8
drone4zone

drone4zone

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

you can get most HW sensors to work with  these kexts...voodoo battery for mavericks and  "RehabMan" version of Fake kext I,just use  kextutility to insatall into S/L/E .I'll upload them for you ..as far as IRQ I'm using another patched  dsdt file,not  good at DSDT  patching  I would like to figure out how to dual link patch dsdt for the  Ati 5870m  so I can get sleep and display sleep to work properly,as now i can get system to sleep but awakes with  white distorted contrast looking  and I have to  carefully  track mouse  to reboot annoying ...I'm also using Voodoo 8.4 Audio  it's not as good as Patched  audio ,but not sure how to get it working with the  Base speaker..Voodoo seems to work but it's buggy,had to have "nullPCUMangementKext" to not have audio or media player issues,I fixed that with an SSDT patch and removed the NullCPUPowerMangaement kext and it seems cooler temps average around 45-50 C,before was 50-60C. Other issues I'm having is  when I click onto hard drive it takes 40-50 seconds to show items ,I've read it's a issue with mavericks and  few fixes I did try but was not a  permanent fix  for me .waiting for Apple update to address it.

sofar, the  system works well  besides a few things I've mentioned.I guess I'll do some research on patching DSDT more  any  tips would be  most welcomed

thanks .

 

http://www.filedropp.../additiontweaks



#9
drone4zone

drone4zone

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

any feedback?



#10
Kuebeker

Kuebeker

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts

Still working on appleHDA.kext to get 2.1 audio. IT's a pain in the ....!

My harddrives respond instantly.  

Battery charging and sensors all work perfectly. 

Temp sensers all work perfectly. My cpu die 1 at idle( 931 Mhz ) is 51and GPU is at 55 

Some random usb issues. ( Twice )

Sometimes when I boot the video is all noisy. A reboot fixes it.

I disabled sleep on lid close. If I close the lid the display turns black and turns back on when I flip it open. I leave it a bit opened to let the heat dissipate. 

 

There is still lots of life left in this laptop and i want to get it working perfectly. 

 

My Dropbox

There are lots of stuff.  If you need help finding something let me know. 

 

If you do not have SugarSync use this link (  SugarSync ) to create your account. It will give me more space.



#11
drone4zone

drone4zone

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

Been looking through your drop folder list  seems you have  compelling  information that needs  to be sorted  out.I'm particular interested in "IRQ" and "ACPI" information, I finally got the resolution  Dual link  patch fix working now I can change the resolution  fine in  system Preferences without the  distorted  screen issue,the system sleeps  perfect as well except I have to fix the distorted contrast which happens  when the display wakes from sleep...I can't figure that out it's driving me  mad...the cpu is running cool at about 44C on idle ...back to the drawing board for now 


after some digging seems  the issue is called "PSOD"  Purple screen of death" hmmmmmm scratching head again  this Asus version5870M video card does not  work well with mac ..period...but I'm the dude that will never stop till I get it sorted out ...maybe I can find out from Ubuntu and port it  and patch it  more ,any one  who can help  I'm all ears 



#12
gebeater

gebeater

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

to get your 5870m fully working you have to adopt these steps (i´m on mountain lion..asus g73jh):
 
1. patch (hexedit) the nomascus framebuffer (@amd5000controller) personality´s like this:
 
02000000400000000901000010000005   ->lvds
00080000040200000000000021030102   ->hdmi
10000000100000000001000010100208   ->vga
00040000040700000073000021030303   ->no port for this one but paste it too, it doesnt conflicts with the other ports
 
-save it @ S/L/E/ATI5000Controller.kext/Contents/MacOS... rebuild permissions
 
2. next step -> edit your dsdt @ PCI0/PEG1/GFX0:

Device (GFX0)
                {
                    Name (_ADR, Zero)
                    OperationRegion (VSID, PCI_Config, Zero, 0x04)
                    Field (VSID, ByteAcc, NoLock, Preserve)
                    {
                        REG0,   32
                    }
                    Name (PCTG, Package (0x10) {})
                    Method (_DSM, 4, NotSerialized)       <--init DSM Method
                    {
                        Store (Package (0x18)
                            {
                                "AAPL,slot-name", 
                                Buffer (0x0C)
                                {
                                    "PCI Slot 11"
                                }, 
                                "AAPL00,DualLink",     <-- init DualLink for lvds
                                Buffer (0x03)
                                {
                                     0x01, 0x00, 0x00
                                }, 
                                "@0,name",             <-- init the ports to use with Nomascus
                                Buffer (0x0D)
                                {
                                    "ATY,Nomascus"
                                }, 
                                "@1,name", 
                                Buffer (0x0D)
                                {
                                    "ATY,Nomascus"
                                }, 
                                "@2,name", 
                                Buffer (0x0D)
                                {
                                    "ATY,Nomascus"
                                }, 
                                "@3,name", 
                                Buffer (0x0D)
                                {
                                    "ATY,Nomascus"
                                }, 
                                "model", 
                                Buffer (0x1C)
                                {
                                    "AMD Mobility Radeon HD 5870"
                                }, 
                                "@0,display-link-component-bits", 
                                Buffer (0x04)
                                {
                                     0x06, 0x00, 0x00, 0x00
                                }, 
                                "@0,display-pixel-component-bits", 
                                Buffer (0x04)
                                {
                                     0x06, 0x00, 0x00, 0x00
                                }, 
                                "AAPL00,Dither", 
                                Buffer (0x04)
                                {
                                     0x00, 0x00, 0x00, 0x00
                                }, 
                                "@0,display-dither-support", 
                                Buffer (0x04)
                                {
                                     0x00, 0x00, 0x00, 0x00
                                }, 
                                "hda-gfx",                        <---HDMI Audio (not testet but it should work)
                                Buffer (0x0A)
                                {
                                    "onboard-1"
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
}

-compile it and save aml @ Extra/DSDT.aml

 

3.Bootloader (i´m using chameleon but clover works fine too)

- build your config as you like but do not inject your ATI, also you do not need to load ATIROM or VBIOS

 

that it..reboot and you will have fully working display, hdmi and vga

 --vga doesnt detect your monitor resolution automatically, set your desired resolution in preferences or use switchres..

 

my specs:

asus g73jh ty048v

I5 2,4Ghz

HD5870m

Mountain Lion->maybe you have to change some settings to get it working..

 

..for audio:

maybe you should use VoodooHDA.kext and VoodooHDA.prefPane instead of AppleHDA.kext, works fine for me

Attached Files



#13
Kuebeker

Kuebeker

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts

I'm particular interested in "IRQ" and "ACPI" information 

 

IRQ = interrup request

The most Important IRQ's are for HPET ( High Precision Event Timer ).

What you want are 4 HPET IRQ's that will not interfere with other IRQ's like USB IRQ's.

The most popular Apple dsdt HPET IRQ's are 0,2,8. Once loaded, using IORegistryExplorer, the most popular Mac HPET IRQ's are 0,2,8,11,12.

11 and 12 being those Mac dynamicly allocates.  

Note that not all Apple DSDT's have a Device (HPET) like MacPro3,1.

Take note that you cannot change the IRQ's of PS2K Keyboard which is IRQ 1 and PS2M Mouse(trakpad) which is IRQ 12 which are still present in current laptops and used by VooDooPS2.kext.

 

I have come to the conclusion that the HPET IRQ's do not have to be 0,2,8,11 or 12.

IRQ's 0 ( CPU ) and 1 (PS2K) are taken by MAC before HPET that is why if you put 0 as IRQ Mac will see that it's already allocated and move to the next one available. You might see in some Apple DSDT's IRQ 0 in HPET. That is an Apple error. 

You need to dictate 4 IRQ's in HPET or else Mac will dynamically allocate what he needs regardless if those IRQ's have been allocated in the dsdt for other devices, like USB. That is why if you have an IRQ conflict, you move your mouse while your playing music and the audio acts up. 

 

Open your DSDT and search for IRQNoFlags ().

 

For Asus G73JH use

 

Device  IRQ -> New IRQ

IPIC   2   -> 3

Math    13

RTC     8   -> 9

TIMR    0   -> 10

PS2M    12  -> 13

PS2K    1

HPET    NA  -> 2,8,14,15 

 

ACPI is a hell of a read. http://www.acpi.info.../ACPIspec30.pdf



#14
mmon

mmon

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
  • Gender:Male

@NOYFB, you can easy get working ati card under the clover, and also get auto patched dsdt with clover's patches. After that, sleep should work

you may check my signature, almost all clover settings will be the same for your configuration



#15
Kuebeker

Kuebeker

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts

The following post is no longer good. 

 

drone4zone,

 

I'm working on the display issues.

 

Could you test my work on your rig and let me know if all ports work and display sleep. Use the Mission Control -> Hot Corners..." "Put Display to Sleep". We don't want the laptop to sleep just the LCD.

 

There is a DSDT.aml and the AMD5000Controller.kext.

Attached File  Display Sleep - Fixing - 00.zip   795.2KB   2 downloads

 

My post for fixing our issues.

Thank you gebeater for your info. You put me on the right track. Sleep kind of works.When it wakes up the resolution is OK but the colors are bezerk and there is noise. 



#16
gebeater

gebeater

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

to fix your issue you could try to disable vga permanently,

this should be possible if you use orangutan framebuffer instead of nomascus.it has only 2 personalitys you have to adjust in amd5000controller.kext

- hex edit the AMD5000Controller @S/L/E/ATI5000Controller.kext/Contents/MacOS and search orangutan frambuffer:

 

02000000400000000901000000000005 ->used for lvds
00040000040600000073000011020101 -> used for display port

 

change it to:

 

02000000400000000901000010000005   ->lvds
00080000040200000000000021030102   ->hdmi

 

follow the steps i posted before but inject dsdt like this..

Device (GFX0)
                {
                    Name (_ADR, Zero)
                    OperationRegion (VSID, PCI_Config, Zero, 0x04)
                    Field (VSID, ByteAcc, NoLock, Preserve)
                    {
                        REG0,   32
                    }
                    Name (PCTG, Package (0x10) {})
                    Method (_DSM, 4, NotSerialized)       <--init DSM Method
                    {
                        Store (Package ()             
                            {
                                "AAPL,slot-name", 
                                Buffer ()
                                {
                                    "PCI Slot 11"
                                }, 
                                "AAPL00,DualLink",     <-- init DualLink for lvds
                                Buffer ()
                                {
                                     0x01, 0x00, 0x00
                                }, 
                                "@0,name",             <-- init the ports to use with Orangutan--only 2
                                Buffer ()
                                {
                                    "ATY,Orangutan"
                                }, 
                                "@1,name", 
                                Buffer ()
                                {
                                    "ATY,Orangutan"
                                }, 
                                "model", 
                                Buffer ()
                                {
                                    "AMD Mobility Radeon HD 5870"
                                }, 
                                "@0,display-link-component-bits", 
                                Buffer ()
                                {
                                     0x06, 0x00, 0x00, 0x00
                                }, 
                                "@0,display-pixel-component-bits", 
                                Buffer ()
                                {
                                     0x06, 0x00, 0x00, 0x00
                                }, 
                                "AAPL00,Dither", 
                                Buffer ()
                                {
                                     0x00, 0x00, 0x00, 0x00
                                }, 
                                "@0,display-dither-support", 
                                Buffer ()
                                {
                                     0x00, 0x00, 0x00, 0x00
                                }, 
                                "hda-gfx",                        <---HDMI Audio (not testet but it should work)
                                Buffer ()
                                {
                                    "onboard-1"
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)

this should work...hopefully



#17
drone4zone

drone4zone

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

NOYFB

hey been away I will check out your patch on my rig ..I also upgraded my LED to 1920x1080 big big difference ...will let you know  when I  test..

gebeater...not sure how to  patch the kext personality if you could  upload  the  kext I'll give it a  try  thanks 



#18
Kuebeker

Kuebeker

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts

gebeater...not sure how to  patch the kext personality if you could  upload  the  kext I'll give it a  try  thanks 

 

No need to test my files, I'm almost finished fixing the display issues.

His idea of disabling the VGA ports made sense, I was to focused on getting the VGA port to auto switch. I would have came to the same conclusion after all my tests and just say the hell with VGA!. I now know that port auto switching is not controlled by frambuffers.

 

I'll be finishing benchmarking the different Framebuffers today. Nomacus is not the fastest one. Display sleep/wake finally works. :)



#19
Kuebeker

Kuebeker

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts

Display fix is finished. 

 

Sleep/Wake by lid or manually, disabled the VGA port, Langur framebuffer with a Cinebench GPU score of 40.25, HDMI hotplug detect.

 

Attached File  Sleep,Wake, VGA disable, Langur framebuffer - fix.zip   796.15KB   36 downloads

 

 

Test it and let me know. 

 

Thank you gbeater for your help.



#20
Kuebeker

Kuebeker

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts

I'm now work on system sleep.

If you put system to sleep, only the monitor goes to sleep, the rest stays powered.

 

Any hints?

 

SleepEnabler.kext = boot pacnic.

Tried Darkwake=10, no go. 







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy