Jump to content

Cant get AppleHDA to load


  • Please log in to reply
6 replies to this topic

#1
Lordadmiral Drake

Lordadmiral Drake

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 408 posts
  • Gender:Male
  • Location:Austria

I downloaded a patched AppleHDA.kext for my sound codec. But it won't load. When I try to load it manually with kextutil I get the error: Code signing failure: Code signature is invalid 



#2
slayer2333

slayer2333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 198 posts
  • Gender:Male

Did you try to boot without caches after you installed your kext and repaired permissions ?



#3
Lordadmiral Drake

Lordadmiral Drake

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 408 posts
  • Gender:Male
  • Location:Austria

No. I installed the kext using Kext Wizard and then did "Rebuild System Kext Cache" I didn't do repair permissions because AFAIK kext Wizard does that during kext installation



#4
slayer2333

slayer2333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 198 posts
  • Gender:Male

Ok, but what i mean is that for some reason, some configurations (like mine) won't load AppleHDA when using Cache at boot.  You may try with nocaches in clover or -f in chameleon to see if it still doesn't load.  If so, you may double check your AppleHDA patch.



#5
Allaп

Allaп

    InsanelyMacaholic

  • Local Moderators
  • 2,759 posts
  • Gender:Male
  • Location:Brazil

try this: 

sudo touch /System/Library/Extensions

after this, shut down, don't restart, and wait 10 sec, and start.

looks funny, but it worked for me.

 

Thanks Mirone by that.



#6
Lordadmiral Drake

Lordadmiral Drake

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 408 posts
  • Gender:Male
  • Location:Austria

Booting ignoring caches did the trick for me. But is there a way to get the kext to load even if I don't do that?



#7
slayer2333

slayer2333

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 198 posts
  • Gender:Male

Booting ignoring caches did the trick for me. But is there a way to get the kext to load even if I don't do that?

Let me know if you find out how to load AppleHDA using Caches.  Tried deleting caches and rebuilding with: KextWizard/Kext Utility/Pandora/Manually from terminal/ but nothing worked for me, everything loads except audio.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy