Jump to content

Move Clover from USB to EFI, help me


  • Please log in to reply
3 replies to this topic

#1
Hackintosher1

Hackintosher1

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Norway
Hi,
...first of all: You might think thats quite easy or why are you asking for help to do that, BUT in my situation this is kinda impossible. Here is why:

I have clover bootloader working perfectly fine on a 8gb usb formatted MBR and fat. I can boot from it (even though i get artifacts) and therefore i thought i could migrate from chameleon. So i installed clover on my HD for UEFI bios and the EFI partition was mounted. Then i copied the config.plist that was working with usb and replaced the one in EFI. *reboot* Surprisingly, not clover but chameleon bootloader showed up. I've tried the whole process more than twice and other settings, also copied all of the files from usb but no luck...

My hard drive is formatted GPT. What am i doing wrong, am i missing any steps?!
If you cant help me with that, do you know why i get graphics artifacts? My graphics card is Intel HD Graphics 3000.
Thank you in advance :)

#2
chris1111

chris1111

    InsanelyMac Deity

  • Donators
  • 1,523 posts
  • Gender:Male
  • Location:Montreal Canada

Hi,
...first of all: You might think thats quite easy or why are you asking for help to do that, BUT in my situation this is kinda impossible. Here is why:

I have clover bootloader working perfectly fine on a 8gb usb formatted MBR and fat. I can boot from it (even though i get artifacts) and therefore i thought i could migrate from chameleon. So i installed clover on my HD for UEFI bios and the EFI partition was mounted. Then i copied the config.plist that was working with usb and replaced the one in EFI. *reboot* Surprisingly, not clover but chameleon bootloader showed up. I've tried the whole process more than twice and other settings, also copied all of the files from usb but no luck...

My hard drive is formatted GPT. What am i doing wrong, am i missing any steps?!
If you cant help me with that, do you know why i get graphics artifacts? My graphics card is Intel HD Graphics 3000.
Thank you in advance :)

You have better chance to move your thread here   ;)

 

http://www.insanelym...ussion/page-169



#3
Maniac10

Maniac10

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,248 posts
  • Gender:Not Telling

You need to install Clover for legacy boot instead of UEFI, that way Clover will replace Chameleon on the MBR boot sector. Just deselect "For UEFI motherboards…", select boot0af or boot0ss from "Bootloaders" and SATA or BiosBlockIO from "CloverEFI". Here's a guide about legacy boot with Clover, and here's a detailed description of each option on the installer.

 

If instead you want to boot in UEFI mode (make sure your system is capable), first try to disable any legacy/compatibility boot option from the bios. If that doesn't work then you will probably need to wipe the MBR boot sector with fdisk.

diskutil list (notice the disk number)
sudo fdisk -u /dev/diskX

And I agree that this discussion belongs to the Clover section.



#4
Hackintosher1

Hackintosher1

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Norway

You need to install Clover for legacy boot instead of UEFI, that way Clover will replace Chameleon on the MBR boot sector. Just deselect "For UEFI motherboards…", select boot0af or boot0ss from "Bootloaders" and SATA or BiosBlockIO from "CloverEFI". Here's a guide about legacy boot with Clover, and here's a detailed description of each option on the installer.

 

If instead you want to boot in UEFI mode (make sure your system is capable), first try to disable any legacy/compatibility boot option from the bios. If that doesn't work then you will probably need to wipe the MBR boot sector with fdisk.

diskutil list (notice the disk number)
sudo fdisk -u /dev/diskX

And I agree that this discussion belongs to the Clover section.

now i get boot1: error

i can still boot from usb though







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy