Jump to content

Samsung np530-u3c a08ru


  • Please log in to reply
12 replies to this topic

#1
mladshev

mladshev

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi!
I have the problem installing OSX on my laptop.
Installation was successful, but when my video card starts it turns off backlight of the display and nothing happened further.
I can start it only in vesa mode (64mb), but it's not usable in that mode, also i can not use external display over hdmi.
I think that problem is in my CPU i3-2377M, video is HD3000.
I'll be happy if someone can help me to fix it.

#2
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
Intel HD 3000

#3
mladshev

mladshev

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Intel HD 3000

Thanks, but it doesn't help.
My video card starts only without kext AppleIntelSNBGraphics.
In hardware info about graphics i see "No kext loaded" (or something like that, i have russian localization)
Even after patching dsdt.

ADDED

My device id is 0x0116.
SMBios - MacBookPro 8,1

#4
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,485 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.
Please extract and upload your dsdt.

#5
mladshev

mladshev

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Please extract and upload your dsdt.

I hope that i made it right.
Here it is.
Thank you, for your attention to my problem!
Attached File  DSDT.zip   38.8KB   3 downloads

#6
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,485 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.
There you go.

Attached Files



#7
mladshev

mladshev

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

There you go.

Thank you very much!
Sorry for stupid question, explain me please, what should i do further?
Patch my dsdt with dsdt patcher and then install AppleIntelSNBGraphics?

#8
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,485 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

Thank you very much!
Sorry for stupid question, explain me please, what should i do further?
Patch my dsdt with dsdt patcher and then install AppleIntelSNBGraphics?


No, I already patched everything. Just put the dsdt.aml in your /Extra folder and reboot.
Don't install AppleIntelSNBGraphics. I have patched your DSDT with a dev id to work with the stock kext.

#9
mladshev

mladshev

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
I'va placed file dsdt.aml if root/Extra and rebooted, but nothing happened.
Still written: "No kext loaded".
Maybe i deleted some needed kexts? Could you tell me what kext should be loaded?

#10
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,485 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

I'va placed file dsdt.aml if root/Extra and rebooted, but nothing happened.
Still written: "No kext loaded".
Maybe i deleted some needed kexts? Could you tell me what kext should be loaded?


So you're booting without AppleIntelSNBGraphics?
If so, reinstall all the kexts you removed.

#11
mladshev

mladshev

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

So you're booting without AppleIntelSNBGraphics?
If so, reinstall all the kexts you removed.

Yes, i deleted that kext
I'll try to perform clean install and than put dsdt.

ADDED

Yes, i deleted that kext
I'll try to perform clean install and than put dsdt.


I've rebooted once more time and now system shows me "HD Graphics 3000 Mobile",
but now i can not change resolution (it's 1024x768) and it's shows me that it has 64 Mb of memory in common use with system.
Can you help me once more?
And thank you for previous advice.

P.S. External display (over HDMI) doesn't works too :(

ADDED

When i'm starting without Dr.Hurt's DSDT it shows me device id 0x0116, but with DSDT it shows id 0x0126, is it normal?

#12
mladshev

mladshev

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Unfortunatly i have no progress yet :(
Maybe someone can help me?

#13
leociotti

leociotti

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

I think i can help you.

You have to extract your display EDID. You can do this via windows or linux. There are many apps that does the job easily, like this one. Copy it and paste in a txt.

Next step is to use the clover bootloader. I couldn't make it work with chameleon.

With a Plist editor, open de config.plist file located on EFI/Clover folder and paste your EDID in EDID field.

Extract your dsdt and apply the EFI HD3000 6 series patch from toleda, via Maciasl, from this source: https://raw.github.c...i_hd3000/master and save your dsdt on EFI/Clover/ACPI/patched.

Make shure to apply the intel patch, ##### - Display - Intel.

 

Reboot.

 

Now you should have your HD3000 working as it should be.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy