Jump to content

[Solved]AppleIntelCPUPowerManagement KP just before desktop


  • Please log in to reply
15 replies to this topic

#1
SRSR333

SRSR333

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:Singapore
Hey guys.

I've got a stable OS X 10.8.2 Install on my Samsung RF411, which runs an Intel Core i7-2630QM. However, there's one really pressing issue bothering me-the battery life on my notebook when running OS X. I get about 3.5 to 4 hours in Windows when my notebook is idling. However, I get barely 2 hours when in OS X. Also, when under load in Windows, the CPU uses Turbo Boost to increase its frequency from 2.0 GHz to 2.9 GHz, but nothing of the sort in OS X. Furthermore, to add on, I only have 2 P-states reached as shown in MSRDumper.kext: 8 and 20. I have a feeling all this is due to badly configured CPU power options by the OS.

I have seen and heard of many things, like NullCPUPowerManagement.kext (which I have currently installed), a patched version of AppleIntelCPUPowerManagement.kext, SSDTs, and SpeedStepper.kext.

I have set up my notebook with a patched DSDT and SSDT, and patched AppleIntelCPUPowerManagement. However, my notebook kernel panics at the end of verbose boot, where everything else, right down to my trackpad and LAN kexts are loaded, and just before the desktop GUI screen appears, I get a kernel panic that backtraces to AppleIntelCPUPowerManagement. How is this possible? Please help me!!!

#2
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 747 posts
  • Gender:Male
Which smbios do you use?
Where are your DSDT and SSDT from?

Edited by Gringo Vermelho, 06 February 2013 - 04:41 AM.
Please don't quote entire posts when replying directly below them. All overquoting removed from thread


#3
SRSR333

SRSR333

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:Singapore
I use MacBookPro8,1 as my SMBIOS, and my DSDT and SSDT were extracted and edited by myself, with the latest BIOS installed.

#4
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 747 posts
  • Gender:Male
Try to switch to smbios of MBP 8,2. It is suiting your i7 qm. With smbios of MBP 8,1 are only i5 m and i7 m sandybridge supported. I have been forced to use smbios of MBP 8,2 at first to get gfx output on the display of my Edge e320. Therefore no ACPM has been possible. After editing the pinout of AplleIntelSNBGraphicsFBios.kext I have been able to change to personality of MBP 8,1 with full ACPM and without any issues.

Have fun.

#5
b419kid

b419kid

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Have you been able to get sleep working on the notebook?

#6
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 747 posts
  • Gender:Male
Sleep can only work native, if ACPM is fully functional. Without it, you need sleepenabler.kext.

#7
SRSR333

SRSR333

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:Singapore
Here's a photo of the kernel panic:

http://www.tonymacx8...lp-imag0108.jpg

And no, I haven't got either SleepEnabler.kext or proper sleep with power mgmt yet.



#8
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
Attached File  Remember.zip   526.72KB   50 downloads

#9
SRSR333

SRSR333

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:Singapore
Yes, I know InsanelyMac doesn't support tmx86. I'm not asking anyone to support him; I'm just asking ppl to follow the link directly to the picture... If you have seen the link, you will notice that there's nothing but the photo there. It's just hosted on tmx86.. Please, I'm just asking for help..

#10
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 747 posts
  • Gender:Male
Nobody can help you, because of your not in details known hardware. Therefore you should not wonder, that suppurt for your issues is rare. Nobody enjoys to do a research for afterwards being able to help you.
If somebody tries to support you with your issues, you don´t read the posts. Look at post 4 in your thread. A Smbios of an MBP with only i7 2...m cpu does normally not support i7 2...qm cpu´s. You should at first change to a correct personality for your laptop.

Have fun.

#11
SRSR333

SRSR333

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:Singapore
I've already changed the SMBIOS to MacBookPro8,2. IT DOESN'T WORK. Have you even seen the model name shown in the picture? It is MacBookPro8,2.

Anyway, I've partially solved my problem... I moved IOPlatformPluginFamily.kext to another folder, and it booted successfully. However, I get NO Turbo Boost and only 2 P-states, 8 and 20, most of the time. It very rarely shows P-states 16, 17, 18 and 19.

#12
SRSR333

SRSR333

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:Singapore
Honestly, so much for this forum helping lots of people. In the end, it was someone else, somewhere else, that helped me solve my Speedstep problem

Edited by fantomas1, 05 February 2013 - 01:25 AM.


#13
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,720 posts
  • Gender:Male
happy for you!

;)

#14
SRSR333

SRSR333

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:Singapore
Well, I posted the URL to my solution here for others to see, if they have similar problems. If you wish to edit it out just because its hosted on a site that's not approved of here, then you only do other forum members a disservice.

#15
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,047 posts
  • Gender:Male
  • Location:Brazil
That's like, your opinion man. Believe me, we (the staff) have discussed tmx86 to death and disservice is not the word you're looking for (waves hand).

Besides, linking to off-site images is generally a bad idea, because you never know if said image will still be at the same URL tomorrow.
If you want to show someone a screenshot, best practice is to click "use full editor" and attach it to your post.

#16
SRSR333

SRSR333

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:Singapore
It's not my place to argue here, and I don't wish to. Honestly, I've had enough of online software wars to last a lifetime, even though I'm only a teenager. I'd rather not start another one here. Nevertheless, I wasn't talking about the screenshot. I had posted a link to my solution which was also on a thread at tmx86, which the mod edited out.... I honestly have nothing against InsanelyMac, nor do I support tonymac's commercialisation. I only use what helps me best, and hope to give my own tips to others. I hope the link is reinstated, because it may help someone else who has a similar problem... If not, I'll copy and paste from that forum to here. Hope you guys understand...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy