Jump to content

Can someone confirm ATI Mobility Radeon 4300/4500 series DevID:9555 work or not


  • Please log in to reply
19 replies to this topic

#1
memey

memey

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Hi there,


Can someone who got card same as me confirm this card can be modified or not because I've been struggling with this card to enable QE/CI in Lion 10.7. Thanks

#2
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,991 posts
  • Gender:Male
What exact model is this for? Yes it can work if you put the time in to make it work. Add the device ID's to the ATI 4600 kext and the ATI x2000 controller kext. Then post your DSDT and IOreg here and I will look at the DSDT injection.

#3
memey

memey

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

What exact model is this for? Yes it can work if you put the time in to make it work. Add the device ID's to the ATI 4600 kext and the ATI x2000 controller kext. Then post your DSDT and IOreg here and I will look at the DSDT injection.


It's ATI Mobility Radeon HD 4300/4500 Series. VenID = 1002 DevID = 9555. It's rare card and I can't find much topic about it. My attempt to enable this card:

Added ID into ATI4600Controller.kext and ATIRadeonX2000.kext but I got blank screen. I don't know whether kext is loading or not because I can't access it.

#4
memey

memey

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
Hi, I attached my ioreg and dsdt for your reference. Thank you very much. Do inform me if you want something else

Attached Files



#5
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,991 posts
  • Gender:Male
Use my guide here for IOreg:

http://rampagedev.wo...w-to-use-ioreg/

Make sure you are not using GraphicsEnabler=Yes

#6
memey

memey

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Use my guide here for IOreg:

http://rampagedev.wo...w-to-use-ioreg/

Make sure you are not using GraphicsEnabler=Yes



I boot with GraphicsEnabler=No. This is updated ioreg following your guide.

Attached Files



#7
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,991 posts
  • Gender:Male
Install this DSDT by placing it in your extra folder then restart and post a new IOreg.

Attached Files



#8
memey

memey

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Install this DSDT by placing it in your extra folder then restart and post a new IOreg.



Ok mate, I updated my ioreg after installed dsdt and restart.

Attached Files



#9
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,991 posts
  • Gender:Male
HDMI audio is now working. Next lets address onboard audio. Install DSDT and Kext attached. Use enclosed app to install kext. Post new IOreg after restarting.

Attached Files



#10
memey

memey

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

HDMI audio is now working. Next lets address onboard audio. Install DSDT and Kext attached. Use enclosed app to install kext. Post new IOreg after restarting.



I think my onboard sound not working after installing AppleHDA. Kext not loading. For my graphic, ATI4600Controller and ATIRadeonX2000 loaded but still no native resolution or QE/CI.

#11
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,991 posts
  • Gender:Male
Post IOreg.

#12
memey

memey

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Post IOreg.



Updated ioreg

Attached Files



#13
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,991 posts
  • Gender:Male
Make sure AppleHDA is installed. It shows nothing for AppleHDA even for HDMI audio. Check S/L/E

#14
memey

memey

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

Make sure AppleHDA is installed. It shows nothing for AppleHDA even for HDMI audio. Check S/L/E



AppleHDA installed correctly. I reinstall using kext utility and it exists in S/L/E but not loaded. Here is latest IOREG

Attached Files



#15
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,991 posts
  • Gender:Male
OK, I will have to look into it tomorrow. Time to sleep.

#16
memey

memey

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

OK, I will have to look into it tomorrow. Time to sleep.


Thanks mate. I really appreciate your help. Good night.

#17
mosi

mosi

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

hey buddies,

any conclusion? i need this kext for 10.8.2



#18
memey

memey

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

hey buddies,

any conclusion? i need this kext for 10.8.2

I don't know mate since I changed to other machine. I gave up with this card.



#19
mosi

mosi

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

i tried lots of kext and adding dev id to several, even i tried EDID

just a few moments ago in a detailed guide i saw that the only dev which  is not working is 9555! even lots of older devices work!

:(

 

I don't know mate since I changed to other machine. I gave up with this card.



#20
maverick42

maverick42

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts

Hi,

 

I install MoutainLion LeoHazards on 10.8.2 on my HP ProBook 4720s.

All, All works fine (Wifi, sound, keyboard, mouse ...) except .... the graphics cards

 

I have a "the" bad graphic card 0x9555 .... It work with 1600x900 but not QE/CI and it's a problem ....

 

did someone find the solution ?

 

Thankds







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy