Jump to content

ATHR: Unknown locale: 21 - Lion 10.7.5


  • Please log in to reply
3 replies to this topic

#1
JuniorGump

JuniorGump

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Paraíba, Brasil
Good afternoon guys. Sorry for my English.

It is this: this past weekend, I did the installation of Lion on my PC, I configured properly, applied DSDT, latest version of Chameleon, and updated kexts etc, and everything was running smoothly will.

Yesterday I went to start the PC, and I run into a kernel panic, okay. I did boot in verbose mode to see what it was, and behold, I get the following message: ATHR: Unknown locale: 21

Googlei this message, but will not get a concrete solution. From what I know, seems like it has with Wireless will see "I use a wireless card TP-Link, Atheros 938x chipset" that runs natively on the Mac

Here the image of the log:

Posted Image

I thought it might be video problem, so I started with GraphicsEnabler = No, and gave the same.

I kept moving here, and managed to get the safe mode. Up to and beauty. Reinstalled the NullPowerCPUManagement, and gave the boot.

At one point the screen stopped here "before installing the NPCM":

Posted Image

After I installed the NCPM, the screen here now:

Posted Image

If anyone has an idea of ​​what might be, I would be very grateful.

#2
existation

existation

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
what wifi card/chip do you have?
I have the same error on my pc (see my signature for wifi model). I added dsdt section to adrp and i patch rom of my wifi to proper country detection.
See here #153 Good luck!

#3
JuniorGump

JuniorGump

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Paraíba, Brasil

what wifi card/chip do you have?
I have the same error on my pc (see my signature for wifi model). I added dsdt section to adrp and i patch rom of my wifi to proper country detection.
See here #153 Good luck!


Atheros AR9380. But it works natively. Just jab and use. The problem is that I do not know if the error is in it or not.

#4
westwaerts

westwaerts

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 879 posts
  • Gender:Male
dont use lnx2mac kext, better realtek 2.0.6 or higher
and
seems c-states are not initialized properly ( DSDT or Chameleon )





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy