Jump to content

USB2.0-CRW


  • Please log in to reply
20 replies to this topic

#1
kali2000

kali2000

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
Hi friends!!!
I'm running Mountain Lion 10.8.2 in my K53SC.
All work fine except nVidia optimus and card reader.
I know optimus not have solution at the moment and does not worry me because HD3000 work fine, but need help with my card reader.
My card reader is a USB2.0-CRW from Realtek.
It have:
DivID: 0x0139=313
VenID: 0x0bda=3034
I have tried several methods to it work, but I did not succeed. (AnyCardReader, Voodoo, Add DivID&VenID).
The card reader is detected, but not configured.
Can anyone make me some suggestion about solving the problem?
I have added a picture for you can see the problem.
Thanx in advance!!!

Attached Files



#2
Hacktrix2006

Hacktrix2006

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 423 posts
  • Gender:Male
i have the very same Card Reader as well, also tried many kexts file and still have no luck.
Have you managed to get any further?

#3
kali2000

kali2000

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
No, no luck. apparently, the only solution is port the kext from Linux.
We hope that some privileged mind can do it.

#4
Lordadmiral Drake

Lordadmiral Drake

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 421 posts
  • Gender:Male
  • Location:Austria
I got that card reader to work by just inserting device ID and vendor ID into the plist of AppleUSBCardReader.kext inside AppleStorageDrivers.kext.
Reader is listet in sysprofiler under Card Readers and inserted cards show up as such in Finder.

Don't know if this info is still of use for the thread starter, but it may be for others using this device

#5
kali2000

kali2000

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male

I got that card reader to work by just inserting device ID and vendor ID into the plist of AppleUSBCardReader.kext inside AppleStorageDrivers.kext.
Reader is listet in sysprofiler under Card Readers and inserted cards show up as such in Finder.

Don't know if this info is still of use for the thread starter, but it may be for others using this device


I beg to differ, because I tried that with no luck. Can you put an image similar to the one in the first post to check the veracity of what you're saying?
Thanx in advance...

#6
Lordadmiral Drake

Lordadmiral Drake

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 421 posts
  • Gender:Male
  • Location:Austria
Here you go:

Attached File  usbcrw20-1.tiff   150.14KB   165 downloads Attached File  usbcrw20-2.tiff   97.64KB   119 downloads Attached File  usbcrw20-3.tiff   187.29KB   117 downloads

#7
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Hi, i've a bit different card reader on my laptop and i can't make it work.

USB2.0-CRW:

              Product ID: 0x0129
              Vendor ID: 0x0bda  (Realtek Semiconductor Corp.)
              Version: 39,60
              Serial Number: 20100201396000000
              Speed: Up to 480 Mb/sec
              Manufacturer: Generic
              Location ID: 0x1a130000 / 3
              Current Available (mA): 500
              Current Required (mA): Unknown (Device has not been configured)

I appreciate any help.

Edited by jl4c, 04 March 2013 - 08:46 PM.


#8
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
bump :)

#9
Lordadmiral Drake

Lordadmiral Drake

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 421 posts
  • Gender:Male
  • Location:Austria
What OS X version do you use?

#10
Lordadmiral Drake

Lordadmiral Drake

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 421 posts
  • Gender:Male
  • Location:Austria
Try this kext. It goes in plugins folder of AppleStorageDrivers.kext in S/L/E
From OS X 10.8.2

Attached Files



#11
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Am on 10.8.2
Thanks for the kext, but doesn't work :(

#12
Lordadmiral Drake

Lordadmiral Drake

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 421 posts
  • Gender:Male
  • Location:Austria
Hmm, then maybe these drivers are quite selective and I just got lucky

#13
romaincs

romaincs

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Location:France

Same problem here, any news about this device ?



#14
Hacktrix2006

Hacktrix2006

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 423 posts
  • Gender:Male

Anyone managed to get this SD-Card reader working yet.

 

DivID: 0x0139=313
VenID: 0x0bda=3034

 

I have found on mine that its connected to the USB3.0 as with USB 3.0 from NEC the USB-CRW doesn't even show.

 

Reason i ask is ordadmiral Drake has  the following

 

DivID: 0x0139=312
VenID: 0x0bda=3034

 

 

with everything working

 

yet the

 

DivID: 0x0139=313

VenID: 0x0bda=3034

 

is not working as the last mA reading is not detecting.



#15
Kataryno

Kataryno

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Portugal

My problem is exactly the opposite. I have your card reader too, and it works on 10.8.2, but i want to disable it, because, when it's loaded i cannot have the usb ports working...



#16
romaincs

romaincs

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Location:France
I would do that : Look at your system profiler and look for the kext that is loaded for it and then move it out from your extension folder.

Rebuild kext cache and reboot.

#17
Kataryno

Kataryno

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Portugal

I would do that : Look at your system profiler and look for the kext that is loaded for it and then move it out from your extension folder.

Rebuild kext cache and reboot.

 

It's the same kext that load USB ports, sometimes loads the camera and card reader, others the usb ports... AppleUSBEHCI.

 

Strange is i did not find this specific kext on S/L/E...



#18
romaincs

romaincs

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Location:France

Inside AppleStorageDrivers.kext, you have in Content a PlugIns folder. Inside it, you should have AppleUSBCardReader.kext



#19
Kataryno

Kataryno

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Portugal

Oh, thanks I will try it.

 

Just another thing, I have another kexts, like AppleUSBEthernet, AppleUSBAudio, etc. From your experience, you think that this kexts may be the responsible as well to this situation?



#20
romaincs

romaincs

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Location:France

I don't realy know, but I don't think.

 

You're welcome !







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy