Jump to content

D525 GA-D525TUD dead end! IDE/PATA Issues, and general questions

IDE Atom GA-D525TUD PATA iCloud D525 PCI

  • Please log in to reply
5 replies to this topic

#1
jamdox

jamdox

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
Hello All,

I've reached a dead end getting my file server up and running. I've installed 10.8.1, and can boot into the OS no problem using a patched kernel from here, as well as FakeSMC.kext, NullCPUPowerManagement.kext, and lnx2mac's RTL81XXX driver.

HOWEVER, I try to install MacMan's Jmicron SATA and ATA drivers, and they do not load! These are listed as working with 10.8, so I'm confused. I have also installed ApplePCIIDE.kext, IOAHCIBlockStorageInjector.kext, and tried booting with PCIROOT=1. I have a Mac Mini 3,1 system definition and serial from Chameleon Wizard. I think I also have an IOATAFamily that's been patched in there too, but maybe not...

Currently, the IDE controller is registered as connected to the PCI bus, but the kext is not loaded.

However, MacMan's kext should be the right one, this is the "GSATA" Gigabyte chip, JmicronXXX363. What can I do to get the kexts to load? Should I make a DSDT for this system (even though it doesn't seem to need it)? Would a different system definition help?

Please help! I am soooo close to getting this system up!

Thanks!

PS: I can't get iCloud to work, either. It has a "communication error"...

#2
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
getting IDE to work with SATA can be a bit tricky, some bios confg may be needed. Here is alt jmicron http://puu.sh/LX8G .
and see here http://www.insanelym...howtopic=278075

#3
jamdox

jamdox

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
Thanks! More info on the jmicron above? (my IDE is jmicron, not intel)

I'll try it tomorrow...

#4
jamdox

jamdox

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
Unfortunately, it did not work. The system still shows the IDE controller attached to the PCI bus, but no driver loaded.

However, I have a number of other kexts installed, and I also tried a Lion install on the main drive (exact same problems, lol) and am running ML off a cloned drive. So my next steps are to restore ML to the main drive (since it's equivalent to L and IIRC has networking fixes), restore the stock extensions directory and carefully reinstall minimum kexts; the above jmicron will be the first storage one I try under this approach.

In anticipation of failure I've decided to throw money at the problem and ordered a 3TB WD Caviar Red. Better to get some real space and forward-compatible RAID features than fight and fight for 500GB of space on 2 drives that are already at end-of-life :lol:

#5
jamdox

jamdox

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
Does the kext work with Lion?

#6
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
I haven't used IDE in years, so cannot testify to it's effectiveness. The one above was linked from another topic. Here is my collection of Lion and ML Lion PATA and SATA kexts, out of all of them, I only use one.

Attached Files







Also tagged with one or more of these keywords: IDE, Atom, GA-D525TUD, PATA, iCloud, D525, PCI


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy