Jump to content

ASRock Z77 Extreme 4: USB 3.0 Ports not working


  • Please log in to reply
2 replies to this topic

#1
eroxm

eroxm

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
My setup is running quite well by now, what's not working is the USB 3.0 ports. I've made two screenshots of the system profiler:

Posted Image

Posted Image

I think what's shown here is the Z77 integrated USB 3.0 ports. The board also features an ASMedia ASM1042 for 2 additional ports, but without the suitable kext, it shouldn't be recognized by the OS. When I plug in a USB flash drive or hard drive, the LED of the drive is on, but it doesn't get recognized by the system, it just simply does nothing. I tried the rear and the front ports. Has anybody a hint how I can get this to work? If somebody needs to take a look at the DSDT or ioreg, I've attached them to this post.

Thanks in advance for your help!

eroxm

Attached File  eroxm_dsdt_ioreg.zip   452.46KB   26 downloads

#2
^Andy^

^Andy^

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 659 posts
  • Gender:Male

The board also features an ASMedia ASM1042 for 2 additional ports, but without the suitable kext, it shouldn't be recognized by the OS. When I plug in a USB flash drive or hard drive, the LED of the drive is on, but it doesn't get recognized by the system, it just simply does nothing. I tried the rear and the front ports. Has anybody a hint how I can get this to work? If somebody needs to take a look at the DSDT or ioreg, I've attached them to this post.

Thanks in advance for your help!

eroxm


Try these modified drivers http://www.mediafire...dxcetph021ft8uy

#3
klhd

klhd

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Try these modified drivers http://www.mediafire...dxcetph021ft8uy

I tried several usb3.0 driver for my asrock z77 extreme 4 (with ML 10.8.2). But they all caused boot errors (i was not able to boot again into osx, not even by deleting the kext).

Does this one work flawlessly for you?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy