Jump to content

[Guida] Mountain Lion P5QL PRO & ATI4850

Ati 4850 ALC1200

  • Please log in to reply
37 replies to this topic

#1
orlando23

orlando23

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Ciao a tutti.
Ho installato Mountain Lion sul mio pc. Di seguito una breve guida che spero possa essere utile, raccogliendo anche i suggerimenti e l'aiuto di PortazRulez.

Queste le specifiche, :

Motherboard Asus P5QL Pro (P43+ICH10)
Processore Intel coreduo E7300
Audio ALC1200
Video ATI 4850 512

Installato Mountain Lion avendo preparato la chiave USB normalmente.

Per il boot ho installato Chamaleon 2.1 r1820 settando l'installazione ad hoc con Macpro 3,1 per creare smbios.

Installati anche FakeSMC , NullCPUPowerManagement.kext e AttansicL1eEthernet.kext (per l'ethernet)
(Sono andati bene quelli che avevo per Lion) In allegato qui Attached File  Archivio.zip   93.73KB   114 downloads

Ho preso questo org.chamaleon.plist e l'ho copiato nella cartella Extra Attached File  org.chameleon.Boot.plist.zip   904bytes   75 downloads

Poi con kext utility ho installato i driver audio e video

1- l'audio (come detto è un chip ALC1200). Il kext migliore è questo AppleHDA versione 1063. lo trovate qui Attached File  AppleHDA.kext.zip   1.73MB   111 downloads. Si sente molto forte e senza nessun tipo di fruscio.

( Se non vi dovesse funzionare, potete provare anche questo, ma si sente più basso Attached File  VoodooHDA.kext.zip   160.61KB   40 downloads )

2- La scheda video (Ati 4850) Attached File  QE_CI Exotic patch Mountain Lion GM.zip   1.37MB   54 downloads



N.B. Per la scheda video ho dovuto fare attenzione ad un particolare: sembrava non funzionare. Ho spostato il cavo dvi all'altra uscita della scheda e il driver veniva caricato correttamente. Impostata la risoluzione del monitor e tutto funziona. Quindi se dovesse partire e sembrare bloccato prima che carichi mouse e dock, provate a cambiare porta di uscita.

Bluetooth: installato bt trust 15300. Funziona perfettamente, riconosciuto dal sistema come Broadcom


Posted Image

Uploaded with ImageShack.us

Per accedere direttamente a iCloud e Appstore poi ho seguito una guida generica che mi ha permesso di evitare l'errore al login. Se cercate qui sul forum dovreste trovarla facilmente.


Ultime cose da sistemare:

1-Nel pannello di sistema mi viene indicata la scheda video come ATI 4800 anzichè 4850. Ma funzionando tutto lo lascerò cosi.

Aggiornamenti

- Aggiornato alla versione 10.8.1
- Aggiornato alla versione 10.8.2 tramite aggiornamento software. Al riavvio reinstallati i kext audio e video, tutto ok

#2
PortazRulez

PortazRulez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
Per l'audio prova il kext che ti allego Attached File  VoodooHDA.zip   153.49KB   29 downloads

#3
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

you need the QE_CI Exotic patch Mountain Lion GM for hd48xx


#4
PortazRulez

PortazRulez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
Come dice iFire ci vuole l'Exotic Patch. Questa dovrebbe andare: Attached File  QE_CI Exotic patch Mountain Lion GM.zip   1.36MB   29 downloads

#5
orlando23

orlando23

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
grazie mille, li scarico e li provo sul sistema pulito.

per installarli va bene se uso Kext Utility ? Devo fare altro?
Per i driver video devo togliere o aggiungere qualche altro kext ?

#6
PortazRulez

PortazRulez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
Basta che li installi con Kext Utility o con Champlist e ripari i permessi (il secondo lo fa in automatico)
Li devi installare in S/L/E.

#7
orlando23

orlando23

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Ho installato l'audio e funziona. Grazie.

Poi ho riavviato e installato la scheda video, ma al riavvio quando finisce di girare la rotellina sotto la mela, si chiude lo schermo come per entrare nel sistema operativo e poi diventa tutto lo schermo bianco e si ferma cosi.
Qualche idea ?

#8
orlando23

orlando23

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
niente da fare.
mi carica il sistema operativo, mi carica la foto della scrivania e un secondo prima di caricare dock e puntatore del mouse si blocca e rimane così...
cosa mi consigliate di fare?

#9
orlando23

orlando23

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
scusate, io non ho il file org.chamaleon.plist perchè quando installo il bios e setto come macpro 3,1 non me lo crea.

può essere quello il problema? in effetti non ho da nessuna parte in questo modo il graphicenabler=yes

come posso crearlo ?

#10
PortazRulez

PortazRulez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
Prova a metterci questo: Attached File  org.chameleon.zip   412bytes   44 downloads

#11
orlando23

orlando23

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
PortazRulez un grazie enorme!!!!!
Ha funzionato! e grazie all'org.chamaleon.plist che mi hai postato ho potuto anche settare la scheda ethernet per fare in modo che potessi accedere a icloud, appstore, imessage e tutto il resto.

Per la scheda video in pratica ho spostato il connettore dvi sull'altra uscita della scheda video (pensare che ci ho sbattuto la testa due giorni interi!) . li ho visto che vedeva la mia scheda video e ho selezionato la risoluzione del mio monitor.
Anche se viene vista come ATI 4800 e non come 4850. Poco male, l'importante è che funziona.

Ora ho un ultimo problemino: l'audio che mi hai postato si sente e non fruscia. Solo che è molto basso. C'è un modo per risolvere questa cosa?
Se volessi riprovare a vedere con un altro kext come posso fare? Cancello manualmente questo e provo con un altro ?

Se riesco ad affinare anche questa cosa potrei fare una piccola guida

#12
PortazRulez

PortazRulez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
Prego. Si. Fai il backup di questo, lo rimuovi e poi installo quello nuovo.

Ps. Anche da me la scheda video la vede come HD5000 ed è una HD5670

#13
orlando23

orlando23

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Grazie ancora. Faccio un paio di prove per l'audio ma solo per scrupolo.
Il voodooHDA che avevo su Lion mi riconosceva le porte front e rear cosi da avere 4 uscite e soprattutto si sentiva molto più forte il volume.
Finite le prove edito il messaggio iniziale e lo compongo come una guida in modo che magari per qualcuno possa risultare utile.

#14
orlando23

orlando23

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Ho editato il post. Con questa piccola guida magari posso essere d'aiuto a qualcuno.
Se ci sono domande provo a dare il mio contributo volentieri.
Grazie ancora a PortaRulez e iFIRE che mi hanno aiutato.

Come detto farò delle prove per l'audio

#15
PortazRulez

PortazRulez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts

Ho editato il post. Con questa piccola guida magari posso essere d'aiuto a qualcuno.
Se ci sono domande provo a dare il mio contributo volentieri.
Grazie ancora a PortaRulez e iFIRE che mi hanno aiutato.

Come detto farò delle prove per l'audio


Perchè non provi ad estrapolare il Kext su Lion e lo provi a mettere su Mountain Lion?

Pui provare anche con Champlist a cambiare il tuo SMBIOS come iMAC 10.1 Dovrebbe rappresentare meglio in tuo pc. Se ti da problemi basta che riporti quello vecchio.

#16
orlando23

orlando23

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
per estrapolare che intendi ?

è un file .pkg
ho provato ad installarlo qui sul mountain lion ma non funziona. se posso fare qualcosa dimmi pure, sono tutto orecchie!

Che benefici potrei avere cambiando a iMac10,1 ? Se è solo per le scritte riepilogative lascerei così come è. Altrimenti faccio una prova

#17
PortazRulez

PortazRulez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts

per estrapolare che intendi ?

è un file .pkg
ho provato ad installarlo qui sul mountain lion ma non funziona. se posso fare qualcosa dimmi pure, sono tutto orecchie!

Che benefici potrei avere cambiando a iMac10,1 ? Se è solo per le scritte riepilogative lascerei così come è. Altrimenti faccio una prova


La apple identificherebbe correttamente il tuo PC. Anche a me su lion mi dava MacPro3,1 ma ho dovuto convertirlo in iMac10,1 pechè si adatta meglio al mio processore perchè non ho uno xenon e non mi funzionava ne MAS ne iCloud quindi dovrebbe migliorarti un po'.

iMac 10,1 >>> Intel Core 2 Duo ("Wolfdale")
MacPro 3,1 >>> Intel Xeon serie 5400 ("Harpertown") / Core2Quad
MacPro 4,1 >>> Intel Xeon serie 3500 o 5500 ("Bloomfield, Gainestown") / Core i Nehalem/ Quad Core HT / Line 9xx
MacPro 5,1 >>> Intel Xeon W3530, W3565, W3680, E5620, X5650, or X5670 ("Bloomfield, Westmere") / Core i Nehalem/ Quad o Six Core HT / Line 9xx

#18
orlando23

orlando23

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
ci proverò allora. in effetti il mio è un wolfdale
devo trovare però una versione di champlist che mi funzioni.

per l'audio dici che non c'è modo di estrapolarlo da un file pkg ?

#19
PortazRulez

PortazRulez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
ChampList prova a scaricarlo da quì: http://www.insanelym...howtopic=264563 Altrimenti cerca su internet la versione 2.4 che è quella che uso io.

Quanto esegui il .pkg ti estrapola lui in automatico il kext e te lo mette in S/L/E

#20
orlando23

orlando23

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
trovato il kext per l'audio che fa sentire l'audio pulito e soprattutto molto forte!
ho aggiornato un po' la guida con tutti i collegamenti e i file in download.

ora non mi rimane da provare con ChampList a configurare l'smbios come un iMac 10,1





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy