Jump to content

[PARTIAL SUCCESS] GA-Z77-D3H Sound on MT 10.8 Project (VIA 2021)

GA-Z77-D3H 10.8 Mountain Lion VIA2021 Sound

  • Please log in to reply
9 replies to this topic

#1
Tim182

Tim182

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
This is a project to enable full audio functionality on the GA-Z77-D3H using a patched APPLEHDA. Note that this may also work on other motherboards using the VIA2021 chip, however those works will require a different DSDT.aml file.

Currently working:
- Green line out
- Mic in

Project aim:
to get full functionality with the priority of getting the digital out to work.

Guide:
1. Delete all current audio kext from system/library/extensions/. Look for APPLEHDA.kext, VoodooHDA.kext and VIA2021.kext and delete them
2. After deleting run kext utility to repair permissions and restart the computer
3. The computer should boot fine. Place the APPLEHDA.kext and the VIA2021.kext downloaded from this threat on your desktop and install using kext utility (drag into window)
4. Restart
5. Make sure you are on BIOS version F11. This may work on newer ones but I have not tested this. If you are on another version flash your bios to F11.
6. Delete any existing DSDT.aml from the /extra/ folder and replace with DSDT.aml from this threat.
7. Check your org.chameleon.Boot.plist for any conflicting audio flags and remove. Check the below as a reference:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Graphics Mode</key>
<string>1920x1080x32</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>ncpi=0x3000 darkwake=0</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
<key>UseKernelCache</key>
<string>Yes</string>
</dict>
</plist>

8. Reboot, you are done. Simply select internal speaker under sound preferences and use the green line out to connect to your speaker.


The way forward:
In order to get full functionality the DSDT file most likely have to be changed further. Possibly also need to work on the layout. Please head to the following thread for work on the DSDT.aml for the GA-Z77-D3H:
http://www.insanelym...howtopic=281948

References and thanks to all of the following:
http://www.osx86.net...0_applehda.html

Attached Files



#2
b0dyr0ck2008

b0dyr0ck2008

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:UK, London
Any updates on this?

#3
Tim182

Tim182

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Any updates on this?


Yeah, HDMI audio is now working as well but people here don't seem very appreciative, interested or helpful. Moved on elsewhere with this project.

#4
b0dyr0ck2008

b0dyr0ck2008

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:UK, London
I followed all the above to the letter but haven't got any audio devices in sound.

#5
b0dyr0ck2008

b0dyr0ck2008

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:UK, London
Tim, how did you get ml installed on your system? I seem to be having a few issues

#6
Tim182

Tim182

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Tim, how did you get ml installed on your system? I seem to be having a few issues


Straight forward, installed through appstore, booted into safe mode with -x -f -s -v, performed a rollback of acpi (only needed if you installed FAKESMC) and rebooted.

#7
b0dyr0ck2008

b0dyr0ck2008

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:UK, London
Oh, you upgraded from a previous version<br /><br />I'm trying to install mountain lion direct but having a few issues:<br /><br />See here:<br /><br />http://www.insanelym...um/index.php<br /><br />And here:<br /><br />http://www.insanelym...forum/index.php

Damn tapatalk.....


Oh, you upgraded from a previous version

I'm trying to install mountain lion direct but having a few issues:

See here:

http://www.insanelym...forum/index.php

And here:

http://www.insanelym...hameleon-issues

#8
Tim182

Tim182

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Oh, you upgraded from a previous version<br /><br />I'm trying to install mountain lion direct but having a few issues:<br /><br />See here:<br /><br />http://www.insanelym...um/index.php<br /><br />And here:<br /><br />http://www.insanelym...forum/index.php

Damn tapatalk.....


Oh, you upgraded from a previous version

I'm trying to install mountain lion direct but having a few issues:

See here:

http://www.insanelym...forum/index.php

And here:

http://www.insanelym...hameleon-issues


Sorry, can't help you with that. Never seen that problem, maybe try and redownload

#9
Za0oO

Za0oO

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hi Tim,

I tried all of your DSDT as i got the exact same board... i'm using onboard HD4000. Bios is F14 and set to 96M, even tried 64M.. everything boot fine without issue... booted using the same boot flags as you did... The only thing not working is the Audio... tried HDMI output, VGA adapter, same thing... even tried your custom DSDT get kernel panic... i tried mine doesn't work...

I did everything, deleted Voodoo, AppleHDA.kext and no audio, can you please patch my DSDT? here it is.

Thanks a lot!

Attached Files



#10
ekica

ekica

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 304 posts
  • Gender:Male
  • Location:Serbia,Zaječar,Salaš

Hi Tim,

I tried all of your DSDT as i got the exact same board... i'm using onboard HD4000. Bios is F14 and set to 96M, even tried 64M.. everything boot fine without issue... booted using the same boot flags as you did... The only thing not working is the Audio... tried HDMI output, VGA adapter, same thing... even tried your custom DSDT get kernel panic... i tried mine doesn't work...

I did everything, deleted Voodoo, AppleHDA.kext and no audio, can you please patch my DSDT? here it is.

Thanks a lot!

 

 

Use this DSDT patch for your audio.

Device (HDEF)
        {
            Name (_ADR, 0x001B0000)
            OperationRegion (HDAR, PCI_Config, 0x4C, 0x10)
            Field (HDAR, WordAcc, NoLock, Preserve)
            {
                DCKA,   1, 
                        Offset (0x01), 
                DCKM,   1, 
                    ,   6, 
                DCKS,   1, 
                        Offset (0x08), 
                    ,   15, 
                PMES,   1
            }

            Method (_PRW, 0, NotSerialized)
            {
                Return (GPRW (0x0D, 0x04))
            }

            Method (_DSM, 4, NotSerialized)
            {
                Store (Package (0x06)
                    {
                        "hda-gfx", 
                        Buffer (0x0A)
                        {
                            "onboard-1"
                        }, 

                        "layout-id", 
                        Buffer (0x04)
                        {
                            0x0C, 0x00, 0x00, 0x00
                        }, 

                        "PinConfigurations", 
                        Buffer (0x30)
                        {
                            /* 0000 */    0x10, 0x40, 0x11, 0x01, 0xF0, 0x00, 0x00, 0x40, 
                            /* 0008 */    0xF0, 0x00, 0x00, 0x40, 0xF0, 0x00, 0x00, 0x40, 
                            /* 0010 */    0xF0, 0x00, 0x00, 0x40, 0xF0, 0x00, 0x00, 0x40, 
                            /* 0018 */    0x50, 0x30, 0x81, 0x01, 0x60, 0x90, 0xA1, 0x90, 
                            /* 0020 */    0xF0, 0x00, 0x00, 0x40, 0x20, 0x21, 0x45, 0x07, 
                            /* 0028 */    0xF0, 0x00, 0x00, 0x40, 0xF0, 0x00, 0x00, 0x40
                        }
                    }, Local0)
                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                Return (Local0)
            }
        }

Is placed above Device Sata..Use this kext!!!!I have a same sound card and work.....

Attached Files







Also tagged with one or more of these keywords: GA-Z77-D3H, 10.8, Mountain Lion, VIA2021, Sound


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy