Jump to content

5870 and ML 10.8 no QI/CI


  • Please log in to reply
63 replies to this topic

#61
motrix

motrix

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
I solved same problem with a 5750 adding the device id into ATI5000Controller.kext and AMDRadeonAccelerator.kext.

#62
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

I solved same problem with a 5750 adding the device id into ATI5000Controller.kext and AMDRadeonAccelerator.kext.

Glad to hear you solved your problem. The 5870's device ID of 6898 is already included in the kexts since it is available to purchase from Apple as an upgrade card for MacPro's.

#63
chappatti

chappatti

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
@eep357:

Hi,

I am also having issues with DVD player crashing on my 10.8 ML with HD5450. BUT everything else is fully working, and I have full HDMI resolution output/control - dashboard ripples, you tube video OK, facetime OK, other dvd software like Mac Blu Ray player work and Bluray discs show up. So I do not know where my problem is: I do not think its the card...but I may be wrong

The only thing is DVD player crashing. I am posting the crash log: Can you PLEASE help?


Thanks in advance.....

Attached Files



#64
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

@eep357:

Hi,

I am also having issues with DVD player crashing on my 10.8 ML with HD5450. BUT everything else is fully working, and I have full HDMI resolution output/control - dashboard ripples, you tube video OK, facetime OK, other dvd software like Mac Blu Ray player work and Bluray discs show up. So I do not know where my problem is: I do not think its the card...but I may be wrong

The only thing is DVD player crashing. I am posting the crash log: Can you PLEASE help?


Thanks in advance.....

When it crashes, in the popup window do you get error -70012? What motherboard? It's probably the sata controller, if system info shows your card correctly with right amount of RAM and not as 5400 or 5000 series then I doubt it's the GPU. SATA issue is caused when OSX thinks your drive is external as DVD app will only work on internal drives. There are a few different ways to fix this, I've only even done one of them, which is editing DSDT SATA device ID to ESB2 which is also called "orange icon fix" in DSDTSE and other patches, but can be done manually quite easily. Also newest version of Chameleon Enoch branch has optional module that can be installed from the customize menu of it's intaller, there its refferred to as yellow icon fix. I haven't tried that one yet. Other methods involve AHCI port kexts. You can also check in Diskutility to see if drive shows internal or external.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy