Jump to content

5870 and ML 10.8 no QI/CI


  • Please log in to reply
63 replies to this topic

#41
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,059 posts
  • Gender:Male
No, that means that you need to add that device ID to the proper kext. But this is what I find when looking into the ATI5000Controller.kext:


<string>AMD5000Controller</string>
<key>IOPCIMatch</key>
<string>0x68981002 0x68991002 0x68E01002 0x68E11002 0x68D81002 0x68C01002 0x68C11002 0x68D91002 0x68B81002 0x68B01002 0x68B11002 0x68A01002 0x68A11002 </string>

Your device ID is there... The DSDT edit is correct and that is not the issue. Do not revert back to GE=Yes. Do a clean install like I said before on another drive to test to see if the install is bad...

#42
seninha

seninha

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:Holland
OK.I will try that this afternoon.Thanks

#43
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Here is IOreg from fully working 5870 so you can digest the differences as you see fit. Running 10.8.1 as update was just seeded to devs a couple hours ago, it's just a small 40mb delta update tho, nothing special.

Also the official Apple ripples if you want one less thing to need :)

Attached File  ripples.png   31.4KB   29 downloads

Ya'll way overkilling this. Since 5870 is one of few, true "works otb" cards with built in OSX support, it's probably just something stupid like PCIrootID=1 which happens to be missing from your boot.plist and should be included for your board. Used to have same mobo with my 5870 on it. With PCIroot set, all you need is GE, period.

Just put two and two together:
1. you used mbeast to install which gives {censored} cookie cutter config file along with some other junk you probably don't want.
2. you didn't need to edit DSDT before, and no one else needs to edit DSDT to get 5870 working in ML, why would it just be you?

I guess that would be putting one and two together, but that's not how the saying goes :)

Attached Files



#44
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
Seninha, coloca este comando na terminal app, para ver si estao leendo todos os kexts para tua grafica, i assim economizamos muito tempo e tiramos as duvidas si sao os kexts o otra coisa, ok!!!! postea aqui o resultado

kextstat > ~/Desktop/kext.txt

#45
seninha

seninha

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:Holland
iFIRE.Lo voy a acer hoy de tarde cuando llege de el trabajo. :D

For the rest of the forum users, here translation:

iFIRE: Il will do that after getting back from work this afternoon ^_^

#46
seninha

seninha

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:Holland
http://dl.dropbox.co...285948/kext.txt

OK,here are my kext

#47
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
your kexts are loading fine. Here, I don't know if I could possibly make this any easier, use your orig DSDT that was auto-patched and this orig.chameleon.Boot.plist and your done, unless you want HDMI audio which can be added no prob. The way your card is functioning now, no ripples or DVD, is how any reference design 5870 would function otb without any DSDT and GE=No or anything else in org.chameleon.boot.plist.

Attached Files



#48
seninha

seninha

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:Holland
So what you mean is to do a Clean Install (using Unibeats+OSX 10.8 USB stick)

After install is done follow next steps:
  • Run DSDTAutopatcher to creat a new DSDT.aml
  • Creat a new EXTRA folder.
  • Move DSDT.aml and your org.chameleon.boot.plist. to this EXTRA folder
  • Install Chameleon
And after this is done I should have a good running OSX 10.8 with a GPU that is working like it should.

All of this without using ######???

#49
TH3L4UGH1NGM4N

TH3L4UGH1NGM4N

    (~_~)

  • Retired
  • 1,159 posts
  • Gender:Male
  • Location:Wonderland
  • Interests:(~_^)
I suggest you restore the installer to a usb and use chameleon to boot it don't use a beast to auto create things for you as that's how things can go wrong and you want to weed out all possibilities of things going wrong.

#50
seninha

seninha

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:Holland
Let me see if I get it right what you just said.

Restore OSX to the USB using Disk Assistant.
After this is done run Chameleon and install it on this same USB drive?

If it is that simple to install OSX 10.8, why do not other sites (like Tonymacx86) mention this but instead publish a guide with the use of,for example, U-beast

#51
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,059 posts
  • Gender:Male

Let me see if I get it right what you just said.

Restore OSX to the USB using Disk Assistant.
After this is done run Chameleon and install it on this same USB drive?

If it is that simple to install OSX 10.8, why do not other sites (like Tonymacx86) mention this but instead publish a guide with the use of,for example, U-beast


Because one people on the site that you mention commercialize what we do and they do not care about the easy method but just making money... and that method is not easy for beginners. I use myHack (See sig for guide and it works like a charm).

I suggest you restore the installer to a usb and use chameleon to boot it don't use a beast to auto create things for you as that's how things can go wrong and you want to weed out all possibilities of things going wrong.


Agreed.

#52
seninha

seninha

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:Holland
OK, I will try your guide and see what it will bring.

Only wonder if using mentioned methode my Sound will work? Because I always need to use a Rollback from M-Beast to make it work again.

#53
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Don't reinstall yet, just try swapping out the org.chameleon.Boot.plist and use DSDT without injection first. If still no go, then reinstall. And definatly don't use mbeast

#54
seninha

seninha

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:Holland
OK, but I already used mbeast when I installed OSX a couple of days ago.Should that not give me any problem? I don't know if the kext I have in de Extention folder (in Extra folder) will give me any problem.(unfurtunately I am not able to see which kext I have in this folder because i am at work :wink2: at the moment

#55
seninha

seninha

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:Holland
Strange issue here. I try to make a new DSDT using autopatcher but I get an error:

Posted Image

#56
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
just use the one you uploaded a few days ago, it was already patched

#57
seninha

seninha

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:Holland
eep357: I just restarted with your uploaded .plist and DSDT that " Here to Help" uploaded a couple of days ago.
But that did not do the job.

I will now try the DSDT.aml file that I have on my time machine (original,made after the first 10.8 install)

#58
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,059 posts
  • Gender:Male
I just can't believe all of the issue you are having with the ATI 5870... it's one of those cards that always seems to work great....

#59
seninha

seninha

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
  • Gender:Male
  • Location:Holland
Last update about this issue. Just to be sure mbeast is not giving this problem I did myhack install.

First I made a new partiton on my OSX 10.8 drive.then I run myhack and installed 10.8 on the USB drive.
Booted from USB and installed OSX 10.8.

let it install until the myhack came with the EXTRA question,then I restarted.
Again rebooted from USB and SOX cam on screen.

But with one big problem...NO INTERNET.
So I could not do anything.
Luckly I could reach my other 10.8 partition and took myhack app from there and rn it.This time I installed chameleon and extras.

But that did not do the job. Still no internet and again NO DVD plater (same error as before)

Wasn't able to make a new DSDT because I have no JAVA (no internet so program does not install)

Used old OSX 10.8 DSDT but again no internet

#60
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Internet aside, there are 2 separate causes to the DVD player not working, one being graphics card related and the other caused by the sata controller, the only difference is the error number you get when DVD player crashes. So as far as making sure the GPU is working properly, check that translucent menubar works, and for ripples(now back in ML, yay) you need to go to Mission Control section in SystemPrefs and uncheck "Use dashboard as space" you can then ripple widgets. Chess now works no matter what, even with zero GPU exceleration so that is no longer a good thing to check

Not to mention if you can provide the error number listed in DVDplayer crash window, can tell you real quick if it's your gpu or not. If not, it's pretty easy to fix.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy